3 sverweise hintereinander mit 3 möglichen Suchkriterien
#1
Hallo zusammen.

Seit Jahren lese ich hier mit und habe immer eine Lösung gefunden, Danke dafür.
Ich habe mich nun schon dumm und dusselig gesucht und nichts passenden gefunden.

Ich habe eine Tabelle in der mit drei immer nur einmal vorkommenden Begriffen gesucht werden kann.
Aktuell habe ich drei einzelne Sverweise erstellt wo mit den drei Wörtern bzw. Zahlen gesucht werden kann.

Ich hätte dies gerne variabel in einem Sverweis eingebaut.
Mann kann somit in die eine Zelle die drei vorkommenden Wörter bzw. Zahlen eintragen.
Wenn der erste Sverweis kein Ergebnis findet, soll der zweite suchen und dann der dritte. Einver von denen wird ein Ergbenis finden, nie alle zusammen.
Sobald ein Ergebnis gefunden wurde soll die Suche der ggf. noch anderen beiden Sverweise nicht mehr durchgeführt werden, da diese eh nichts finden werden.

Ich hoffe es ist verständlich erklärt.

Suchbegriff     Suchbegriff     Suchbegriff    Ergebnis
Haus                   100                  AAA           Anton
Villa                      200                 BBB           Jürgen
Wohnwagen       300                  CCC          Wilhelm

Danke schon mal.

VG Maik
Antwortento top
#2
Hola,

entweder:


Code:
=WENNFEHLER(WENNFEHLER(SVERWEIS(G1;A2:D4;4;0);SVERWEIS(G1;B2:D4;3;0));SVERWEIS(G1;C2:D4;2;0))


oder als Matrixformel (mit Strg-Shift-Enter abschließen!):


Code:
=INDEX(D2:D4;MIN(WENN(A2:C4=G1;ZEILE(1:3))))

In G1 steht das Suchkriterium.

Gruß,
steve1da
Antwortento top
#3
22 


Danke Dir, ich wär auf den doppelten wennfehler nie gekommen.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste