Spalten sortieren und leere Zeilen ohne Lücke auffüllen
#1
Photo 
Hallo zusammen,

ich versuche gerade eine Auswertung bei der Arbeit zu automatisieren.
Dazu möchte ich folgende Tabelle automatisch nach gewissen Kriterien sortieren lassen.

Dateiupload bitte im Forum.com/wE8dc4g.png" class="highslide" onclick="return hs.expand(this)">Dateiupload bitte im Forum.com/wE8dc4g.png" alt="?mage" title="Larger ?mage" />

Wenn in Spalte D der Typ "Fonds" steht, soll die entsprechende Bezeichnung aus Spalte B und die Stückzahl aus Spalte A automatisch in die Spalte J bzw. K übertragen werden.
Dies, wenn möglich, ohne leere Zeilen zu produzieren. Bei den Typen "Aktie" und "Zertifikat" soll die Aufgabe analog ausgeführt werden.

Weiß jemand wie und ob das geht?

Im Internet habe ich soweit nur diese verwandten Tipps gefunden:
(Die Spalten-/Zeilenangaben aus den Tipps sind hier nicht an mein Excelsheet angepasst)

Spalte(n) mit Leerzellen ohne Lücken auflisten:
{=WENN(ZEILE(A1)>ANZAHL2(A:A);"";INDEX(A:A;KKLEINSTE(WENN(A$1:A$1000<>"";ZEILE($1:$1000));ZEILE(A1))))}

und das hier zum sortieren von Zeilen mit gleichem Inhalt:

=Index(B:B;Vergleich(C1;A:A;0))

Vielen Dank schon einmal im voraus!
Antwortento top
#2
Hi,

benutze Sp. G als Hilfsspalte:


Code:
=WENN(D2="Fonds";ZEILE();"")

In J:


Code:
=WENNFEHLER(INDEX(B:B;KKLEINSTE(G:G;ZEILE(A1)));"")

In K:


Code:
=WENNFEHLER(INDEX(A:A;VERGLEICH(J1;B:B;0));"")
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#3
Hi,

eine weitere Moglichkeit: formatiere deine Tabelle als intelligente Tabelle mit STRG+T. Dann kannst du bequem filtern
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#4
Danke für die schnelle Antwort.

Hat super gelkappt
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste