Formel für täglichen Wert
#1
Hallo,

ich habe eine Liste von Wetterdaten (stündlich).
Heinz Ulm hat mir dafür eine Formel erstellt, mit der für den Niederschlag die 24h - Rate ermittelt wird (Spalte I), immer so um 18 Uhr rum.
Diese Formel würde ich nun gerne umstellen auf 24 Uhr. Wie passe ich die an?
Wenn ich statt 18/24 eingebe 24/24, kommt die Fehlermeldung #NV.

2015
ABCDEFGHIJK
2066206320.11.15 17:016,63,032,433,334,8102,6
2067206420.11.15 18:016,73,335,736,638,1105,935,7
2068206520.11.15 19:016,03,33939,941,4109,2
2069206620.11.15 20:014,92,441,442,343,8111,6
2070206720.11.15 21:014,11,542,943,845,3113,1
2071206820.11.15 22:013,60,943,844,746,2114
2072206920.11.15 23:013,40,344,14546,5114,3
2073207021.11.15 00:013,3044,144,746,5114,3
2074207121.11.15 01:013,60,344,444,746,8114,6
2075207221.11.15 02:013,5044,444,746,8114,6
2076207321.11.15 03:012,5044,444,746,8114,6
2077207421.11.15 04:012,1044,444,746,8114,6
2078207521.11.15 05:010,8043,844,746,8114,6
2079207621.11.15 06:010,3038,144,746,8114,6
2080207721.11.15 07:010,1035,144,746,8114,6
2081207821.11.15 08:010,8032,744,746,8114,6
2082207921.11.15 09:011,7030,344,746,8114,6
2083208021.11.15 10:013,5027,344,746,8114,6
2084208121.11.15 11:015,5024,944,746,8114,6
2085208221.11.15 12:014,6022,544,746,8114,6
2086208321.11.15 13:016,0020,744,746,8114,6
2087208421.11.15 14:015,8018,644,746,8114,6
2088208521.11.15 15:015,4016,244,746,8114,6
2089208621.11.15 16:012,71,216,245,948115,8
2090208721.11.15 17:012,60,313,546,248,3116,1
2091208821.11.15 18:022,0010,246,248,3116,113,5
2092208921.11.15 19:020,706,946,248,3116,1
2093209021.11.15 20:020,604,546,248,3116,1
2094209121.11.15 21:02-0,103,046,248,3116,1
2095209221.11.15 22:02002,146,248,3116,1
2096209321.11.15 23:020,501,846,248,3116,1
2097209422.11.15 00:020,301,846,248,3116,1
2098209522.11.15 01:020,201,546,248,3116,1
2099209622.11.15 02:020,301,545,948,3116,1
2100209722.11.15 03:020,101,545,948,3116,1
2101209822.11.15 04:020,101,545,948,3116,1
2102209922.11.15 05:02001,545,948,3116,1
2103210022.11.15 06:02001,545,948,3116,1
2104210122.11.15 07:020,101,545,948,3116,1
2105210222.11.15 08:020,101,545,948,3116,1
2106210322.11.15 09:020,401,545,948,3116,1

verwendete Formeln
Zelle Formel Bereich N/A
A2066:A2106=WENN(B2066="";"";A2065+1)
J2066:J2106=WENN(U2066="";"";INDIREKT("H"&VERGLEICH(GANZZAHL(B2066)+18/24;U:U;0))-INDIREKT("H"&VERGLEICH(GANZZAHL(B2066)+18/24;U:U;0)-25))

Bedingte Formatierung Haupttabelle 1
Wird angewendet auf   Nr. Bed.  Regeltyp  Operator   Formel1   Formel2   Format Schrift Füllfarbe   Unterstrichen   Schrift- farbe Muster   Musterfarbe Typ Bereich
$A$4:$J$3556501.Bed.: Formel ist=MONAT($B4)<>MONAT($B5) Test       2A4:J35565
$J$4:$J$3556502.Bed.: Formel ist=$J4<>""15773696       2J4:J35565
Bedingte Formatierung Haupttabelle 2 oberere/unterer Bereich  
Wird angewendet auf   Nr. Bed. Format Zelle Anhalten Auswahl   Anzeige   Anzahl   Durchschnitt   Typ   Bereich
$A$4:$J$3556501.Bed.   Falsch          2A4:J35565
$J$4:$J$3556502.Bed.   Falsch          2J4:J35565
Rahmen
    Links     Rechts     Oben     Unten  
 Wird angewendet auf   Nr. Bed.   Linienart     Farbe     Linienart     Farbe     Linienart     Farbe     Linienart     Farbe  
$A$4:$J$3556501.Bed.       dünn durchgehend
Die Bedingungen wurden mit Excel-Version ab 2007 ausgelesen.

Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 19.08 einschl. 64 Bit

Antwortento top
#2
Hallo Ralf

Zitat:=WENN(U2066="";"";INDIREKT(...
Offensichtlich ist der Auslöser in Spalte U.
Grüsse
Detlef

Bitte keine PN!
Seit Nikolaus 2012 mit Excel 2010. Seit Ostern 2015 mit Office 365
Antwortento top
#3
Hi Detlef,

(15.06.2016, 11:03)Hydronaut schrieb: Offensichtlich ist der Auslöser in Spalte U.

ooh, stimmt, habe ich übersehen:

.xlsb   Wetterdaten-Stunde - Forum.xlsb (Größe: 583,07 KB / Downloads: 7)

Da das Tool grad rumspackt leider nur als Download-Datei.
Antwortento top
#4
Arbeitsblatt mit dem Namen '2015'
 ABCDEFGHIJKSTUV
2071206820.11.15 22:013,60,943,844,746,2114,0    42328  
2072206920.11.15 23:013,40,344,145,046,5114,3    42328  
2073207021.11.15 00:013,30,044,144,746,5114,3 44,1  4232922.11.15 00:0022.11.15
2074207121.11.15 01:013,60,344,444,746,8114,6    42329  
2075207221.11.15 02:013,50,044,444,746,8114,6    42329  

ZelleFormel
J2073=WENN(U2073="";"";INDIREKT("H"&VERGLEICH(GANZZAHL(B2073)+24/24;U:U;0))-INDIREKT("H"&VERGLEICH(GANZZAHL(B2073)+24/24;U:U;0)-25))
U2073=WENN(GANZZAHL(B2073)>GANZZAHL(B2072);GANZZAHL(B2073)+24/24;"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Grüsse
Detlef

Bitte keine PN!
Seit Nikolaus 2012 mit Excel 2010. Seit Ostern 2015 mit Office 365
[-] Folgende(r) 1 Benutzer sagt Danke an Hydronaut für diesen Beitrag:
  • Rabe
Antwortento top
#5
Hi Detlef,

danke!
Antwortento top
#6
Hallo Ralf,

was willst du mit der Formel erreichen, die Daten stehen doch schon in der Tabelle?
Die Formel "bläst" die Datei doch nur auf.

Sieht für mich nach einer Pivot aus um bestimmte Daten erscheinen zu lassen, oder verstehe ich etwas ganz falsch?

.xlsb   Wetterdaten-Stunde - Forum.xlsb (Größe: 123,68 KB / Downloads: 2)
lg
Chris
lg Chris
Feedback nicht vergessen.
3a2920576572206973742064656e20646120736f206e65756769657269672e
 ?mage

Antwortento top
#7
Dazu reicht doch diese MatrixFormel (ohne Hilfespalten) auch ?


Code:
=SUM((INT(B4:B3000)=INT(B2091)-1)*D4:D3000)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste