Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

Formel rutscht runter, wie noch besser fixieren ?
#1
Hallo People'z, hallo @all Excelianer

Bearbeitungblatt ist hier Tab1

Edit:
Die Abfrage sucht zuerst einen Text; zudem Text einen Namen, dann soll der Wert rechts ausgeben werden.
Edit end

Nach 5 Einträgen rutscht die fixierte trotzdem runter. Wieso ???

PHP-Code:
=SUMMENPRODUKT((Tab2!$B$8:$B$4005=$A$1)*(Tab2!$C$8:$C$4005=$B$8)*(Tab2!$K$8:$K$4005)) 


Erneuert
PHP-Code:
=SUMMENPRODUKT((Tab2!$B$3:$B$4000=$A$1)*(Tab2!$C$3:$C$4000=$B$8)*(Tab2!$D$3:$D$4000)) 

So sollte die Formel auch stehen bleiben, weil die Daten ab Zeile 3 werden mit berechnet

Wie kann hier bessere Abhilfe geschaffen werden, die neuen Daten werden in Zeile 3 eingefügt, alles was schon in der Datentabelle ist, rutscht folglich nach unten.

Bitte um Hilfe, Vorschläge

danke vorab, mfg
?mage
to top
#2
hi, ohne deine datei zu kennen..:

PHP-Code:
=SUMMENPRODUKT((INDEX('Tab2'!B:B;3):INDEX('Tab2'!B:B;4000)=$A$1)*(INDEX('Tab2'!C:C;3):INDEX('Tab2'!C:C;4000)=$B$8);(INDEX('Tab2'!D:D;3):INDEX('Tab2'!D:D;4000))) 
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • WergibtmirRat
to top
#3
Hallo Jörg
(07.06.2014, 18:00)Jockel schrieb: ...ohne deine datei zu kennen...


Genauso passt es, die Datei ist in den Kinderschuhen, wird gerade zusammengestrickt, teils Hand teils Makrorekorder.

Ich meine irgendwo mal sowas eventuell gesehen zu haben:

Summenprodukt($B$40:B ich kann mich auch irren.

Danke, hast mir geholfen, der Nagel ist versenkt ...

__________________________
gleich gehn wir wieder und wünschen uns: > GUT HOLZ <
------------------------------
mfg
?mage
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste