Matrix Formel: SVERWEIS mit mehrfach vorkommendem Suchkriterium
#1
Hallo Ihr Ex(cel)perten,

ich habe eine Tabelle (s. Anhang und Screenshot), aus welcher ich alle Treffer zu einem Suchkriterium angezeigt bekommen möchte.
Das klappt soweit mit unten stehender Formel.
Code:
{=WENNFEHLER(INDEX($B$1:$B$22;KGRÖSSTE(($A$1:$A$22=$E$1)*ZEILE($A$1:$A$22);ZÄHLENWENN($A$1:$A$22;$E$1)+1-ZEILE(A1)));"ENDE")}
Nun möchte ich gerne, dass Duplikate nicht angezeigt werden. In dem Beispiel also 1-4-2 statt 1-4-1-2-2-1-4.
Kann man die Formel "modifizieren" sodass dies möglich ist?

Beste Grüße
Wolfgang


Angehängte Dateien Thumbnail(s)
   

.xlsx   DuplikateMatrixFormel.xlsx (Größe: 9,71 KB / Downloads: 7)
Antwortento top
#2
Hi Wolfgang,

hilft dir diese Seite weiter?

http://excelformeln.de/formeln.html?welcher=28
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#3
Hallo Wolfgang

Deine Formel liefert ein falsches Ergebnis. Der Wert 5 wird nicht aufgeführt.

Ich würde hier mit Pivot-Tabelle und Datenschnitt arbeiten.
"Ergebnisspalte" in die Zeilen und "Suchspalte" als Datenschnitt.
Grüsse
Detlef

Bitte keine PN!
Seit Nikolaus 2012 mit Excel 2010. Seit Ostern 2015 mit Office 365
Antwortento top
#4
Hallo,

@Detlef: Habe die Formel nochmal runterkopiert, die 5 taucht jetzt auf das passt.

@Günther: Ich verstehe nicht wie das mit der Index-Formel funktionieren soll.. Muss ich die auch "runterkopieren" oder wie im Beispiel nur in einer Zelle stehen lassen (das kann doch garnicht gehen oder..)

Bin also noch recht ratlos.
Von Pivot Tabellen habe ich leider überhaupt gar keine Ahnung..
Die Tabelle die der Berechnung zugrunde liegt würde sich auch häufig verändern.
Ist dann eine Pivot Tabelle überhaupt anwendbar?
Antwortento top
#5
(10.06.2016, 09:53)st3inadler schrieb: Die Tabelle die der Berechnung zugrunde liegt würde sich auch häufig verändern.
Ist dann eine Pivot Tabelle überhaupt anwendbar?
Ja.
Grüsse
Detlef

Bitte keine PN!
Seit Nikolaus 2012 mit Excel 2010. Seit Ostern 2015 mit Office 365
Antwortento top
#6
in F2: Matrixformel:


Code:
=(COUNTIF( $F$1:$F1;LARGE(($A$2:$A$22=$E$1)*($B$2:$B$22);ROW()-1))=0)*LARGE(($A$2:$A$22=$E$1)*($B$2:$B$22);ROW()-1)
Antwortento top
#7
Hallo, ich habe das so verstanden..:

Arbeitsblatt mit dem Namen 'Sheet1'
 ABCDE
1SuchspalteErgebnisspalte Suchkriteriuma
2a1 Ergebnisse1
3d2  2
4f3  4
5g2  5
6h1   
7a4   
8r1   
9d2   
10s3   
11a1   
12r3   
13d4   
14a2   
15b4   
16g4   
17a2   
18t3   
19a1   
20a5   
21g4   
22a2   

ZelleFormel
E2{=MIN(WENN(A2:A22=E1;B2:B22))}
E3{=WENNFEHLER(KKLEINSTE(WENN(($A$2:$A$22=$E$1)*($B$2:$B$22>E2);$B$2:$B$22);ZÄHLENWENN($E$2:E2;E2));"")}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste