Einen Rechner für ein Transportunternehmen
#1
Hallo,

ich würde gerne einen Rechner für unser Transportunternehmen erstellen.

Es geht einfach darum das unser Tarif was ich mit PDF erstellt habe über 40 Seiten ist und die Kunden
manchmal Probleme haben den richtigen Preis zu finden, weil jede Stadt verschiedene Zonen hat und und jede Zone hat andere Preise
und da geht es wiederum wie viel Gewicht die Sendung hat.

Diese Daten muss der Kunde eingeben:

1) PLZ ( nur Deutschland )
2) Gewicht
3) Import oder Export Sendung

= der Kunde bekommt den Preis raus.

Es soll eine neutrale Seite sein die ich selber gestalten kann, die ganzen PLZ usw. sollen nicht zu sehen sein.

PLZ die ich brauche habe ich alles und die Zonen + Preise auch haben ja schon einen Tarif aber als PDF.

Wie kann ich das bewerkstelligen?

Gibt es da eventuell eine Muster/Vorlage das man bearbeiten kann, darf ruhig auch was kosten.

Ich es wird Zeit in Anspruch nehmen das weiß ich aber ich versuche das mal in Angriff zu nehmen aber brauche da Hilfe von euch, die ich hoffentlich bekommen.
Antwortento top
#2
Hi,

erstelle eine Datei  mit zwei Tabellenblättern.

Im ersten kannst du deine Suchkriterien eingeben, die dazu gehörenden Daten hast du im zweiten Tabellenblatt. Diese holtst du dir mit einem SVERWEIS.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#3
Hi,

du kannst auch die Inhalte der PDF in Excel einlesen unddann dort weiter bearbeiten, zumindest lese ich das so in diesem Beitrag:

http://praxistipps.chip.de/pdf-in-excel-umwandeln_1234

Spart dir das Eintippen in Excel. Die restliche Umsetzung siehe Günters Beitrag.
Mit freundlichen Grüßen  Smile
Michael
Antwortento top
#4
Hi,

(09.06.2016, 21:37)Zwergel schrieb: du kannst auch die Inhalte der PDF in Excel einlesen unddann dort weiter bearbeiten, zumindest lese ich das so in diesem Beitrag:
http://praxistipps.chip.de/pdf-in-excel-umwandeln_1234

das geht ab Excel/Word 2013 sogar noch einfacher, wenn die PDF eine umgewandelte Excel- oder Word-Datei ist und kein eingescanntes Papier, also kein "Bild".

Einfach Rechtsklick auf die PDF und dann "Öffnen mit..." und entsprechend Word oder Excel auswählen.
Antwortento top
#5
Hi Ralf,

der TE hat aber nur XL2010 32
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#6
Hi,

(10.06.2016, 07:52)WillWissen schrieb: der TE hat aber nur XL2010 32

dann soll TE die PDF herschicken/zur Verfügung stellen und wir machen das.
Antwortento top
#7
Hallo,

konnte den Tarif Online in Excel konvertieren, das passt schon mal da freue ich mich das ich das nicht neu eintippen muss Smile

Ist das ok so? ( Excel Datei ist als Anhang dabei )


Angehängte Dateien
.xlsx   beispiel.xlsx (Größe: 74,12 KB / Downloads: 10)
Antwortento top
#8
Hi,

(10.06.2016, 08:54)tdisk schrieb: Ist das ok so? ( Excel Datei ist als Anhang dabei )

Warum sind manche Stadtnamen linksbündig und alle anderen zentriert?

Als Erstes würde ich alle PLZ auf ein einziges Arbeitsblatt bringen und dann nicht 6 Spalten, sondern nur 3, das Blatt umbenennen in PLZ-Liste
Und dann eine intelligente Tabelle draus machen: STRG-L, das schadet eigentlich nie!
Die Zone findest Du dann durch diese Formel:
=SUMMENPRODUKT((PLZ-Liste!A2:A2073='page 4'!C20)*(PLZ-Liste!$B$2:$B$2073='page 4'!C21);PLZ-Liste!$C$2:$C$2073)
Hier findet Excel bei Zwischengewichten immer nur die nächstkleineren Kosten (F25). Und SuMMENPRODUKT() geht gar nicht (F26).

page 4
BCDEF
20PLZ34376
21StadtIMMENHAUSEN
22Gewicht110
23
24Preis:Zone7
25eintreffend:ca. 19 Uhr68.00 €
260

verwendete Formeln
Zelle Formel Bereich N/A
F24=SUMMENPRODUKT((PLZ!A2:A2073='page 4'!C20)*(PLZ!$B$2:$B$2073='page 4'!C21);PLZ!$C$2:$C$2073)
C25=WVERWEIS(F24;A1:H17;17;0)
F25=SVERWEIS(C22;A1:H15;F24+1;1)
F26=SUMMENPRODUKT((A3:A14=C22)*(B1:H1=F24);B3:H14)

Daten, Gültigkeit
Zelle Zulassen Daten Wert1 Wert2 Leere Zellen ignorieren Zellendropdown Titel Eingabemeldung Eingabemeldung Titel Fehler Fehlermeldung Typ Fehlermeldung
C20Liste   =PLZ!$A:$A     Wahr   Wahr           Stopp
C21Liste   =PLZ!$B:$B     Wahr   Wahr           Stopp
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 19.08 einschl. 64 Bit

Antwortento top
#9
Hallo,

bei Spedition bestimmt eigentlich nur die PLZ den Tarif. deswegen würde ich das so lösen:

Arbeitsblatt mit dem Namen 'page 4'
 ABCDEFGHI
1ZONE1234567 
2frachtpfl. Gewicht        
325 kg6,50 €8,50 €9,70 €17,60 €25,00 €40,00 €53,00 € 
450 kg9,00 €12,50 €14,50 €24,00 €32,50 €45,00 €57,00 € 
5100 kg12,50 €16,50 €18,00 €25,80 €40,00 €51,00 €68,00 € 
6200 kg20,00 €25,00 €27,50 €41,00 €50,50 €57,00 €71,00 € 
7300 kg26,50 €35,50 €39,00 €52,50 €61,00 €69,50 €72,00 € 
8400 kg36,50 €44,50 €50,00 €61,00 €75,00 €80,50 €84,00 € 
9500 kg44,50 €54,50 €61,50 €78,60 €86,00 €92,50 €96,00 € 
10600 kg46,50 €59,50 €63,00 €81,00 €92,00 €103,00 €106,00 € 
11700 kg49,50 €62,50 €67,00 €85,50 €100,00 €108,00 €115,00 € 
12800 kg51,50 €65,00 €71,00 €89,50 €105,00 €111,00 €124,00 € 
13900 kg53,50 €68,00 €73,50 €94,00 €112,00 €121,00 €127,00 € 
141000 kg56,50 €71,00 €80,00 €98,00 €121,00 €132,50 €136,50 € 
15Je 100 kg1,70 €2,30 €2,80 €3,20 €4,00 €4,70 €5,20 € 
16Importavis per Fax bisVortag
17 Uhr
Vortag
17 Uhr
Vortag
17 Uhr
Vortag
17 Uhr
Vortag
17 Uhr
Vortag
17 Uhr
Vortag
17 Uhr
 
17Export eintreffendca. 17
Uhr
ca. 17
Uhr
ca. 17
Uhr
ca. 18
Uhr
ca. 18
Uhr
ca. 18
Uhr
ca. 19
Uhr
 
18         
19         
20PLZ34376       
21StadtIMMENHAUSEN       
22Gewicht110       
23         
24Preis:68,00 €68,00 €Zone7    
25eintreffend:ca. 19
Uhr
ca. 19
Uhr
      

ZelleFormatWert
A3Standard" kg"25
B3#.##0,00 €;[Rot]-#.##0,00 €6,5
B24_-* #.##0,00 €_-;-* #.##0,00 €_-;_-* "-"?? €_-;_-@_-68

ZelleFormel
B24=INDEX($B$3:$H$14;WENNFEHLER(VERGLEICH(MIN(B22;1100);$A$3:$A$14;1);1);SVERWEIS(B20;'page 5'!$A:$C;3;0))+WENN(B22<1100;0;MAX(0;KÜRZEN((B22-1100)%;)*INDEX($B$15:$H$15;SVERWEIS(B20;'page 5'!$A:$C;3;0))))
C24=INDEX($B$3:$H$14;WENNFEHLER(VERGLEICH(MIN(B22;1100);$A$3:$A$14;1);1);E24)+WENN(B22<1100;0;MAX(0;KÜRZEN((B22-1100)%;)*INDEX($B$15:$H$15;E24)))
E24=SVERWEIS(B20;'page 5'!A:C;3;0)
B25=INDEX($B$17:$H$17;SVERWEIS(B20;'page 5'!$A:$C;3;0))
C25=INDEX($B$17:$H$17;E24)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Die Tabellen mit den PLZ müssten natürlich alle zusammengefasst werden!
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#10
Hi,

(10.06.2016, 11:18)BoskoBiati schrieb: bei Spedition bestimmt eigentlich nur die PLZ den Tarif. deswegen würde ich das so lösen:

aber auch Deine Formel stimmt nicht ganz, denn bei 110 kg müßte der Preis für 200 kg gezahlt werden.
Also bei Überschreiten der Grenze immer der nächstgrößere Preis.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste