Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Summenprodukt und im Ergebnis #Wert
#1
es ist ein Kreuz, da will man was schaffen, aber schafft sich nur noch grauere Haare.

Guten Abend @all

In einer Tabelle stehen Daten horizontal (Personenbezogen) zur Verfügung aus Guthaben und offenen Beträgen.

Die Abfragetabelle hat nun alle Personen In Zeile stehen. Datum nach unten.
Wenn ich nun versuche die Positionen zu berechnen, geht es gut solang nur + oder - Werte in einer Zeile sind.

zuerst berechne ich: Soll - Ist = 40 - 30 = -10€ Minus
zuerst berechne ich: Soll - Ist = 50 - 55 = +5€ Guthaben

Mein Konstrukt schlägt fehl:
Summiere alle Werte die größer sind als Null ... ?
Wenn(Wert höher Null;+(Wert höher Null; ... wie weiter ???

Mir qualmssssssssssssssssss Huh

Wer steigt durch und ist gewillt hier einen Tipp abzugeben.
anbei, kleine konfuse zusammengestrickte Bespieldatei

.xlsx   SUMMENPRODUKT(.xlsx (Größe: 11,6 KB / Downloads: 17)

mfg
?mage
to top
#2
Hallo Frank

Ich habe in deinem Beispiel nirgends #WERT gesehen, sondern einen Zirkelbezug.
Deine Formel in G4
Code:
=WENN(G4<SUM.....
kann so nie funktionieren.

Gruss Sepp
to top
#3
Hi Frank,

wenn ich dich jetzt nicht komplett missverstanden habe, dann reicht es in G4
PHP-Code:
=WENN(C4<0;C4;""
einzutragen und in I4
PHP-Code:
=WENN(C4>0;C4;""

Das ist dann das Ergebnis:

Tabelle1

ABCDEFGHI
1olid; border-left-styleConfusedolid; border-top-width:2px; border-left-width:2px; border-top-color:#000000; border-left-color:#000000; ">olid; border-top-width:2px; border-top-color:#000000; ">olid; border-top-width:2px; border-top-color:#000000; ">olid; border-top-width:2px; border-top-color:#000000; ">olid; border-top-width:2px; border-top-color:#000000; ">olid; border-top-width:2px; border-top-color:#000000; ">olid; border-top-width:2px; border-top-color:#000000; ">Minus
anzeigen
olid; border-top-width:2px; border-top-color:#000000; ">olid; border-right-styleConfusedolid; border-top-width:2px; border-right-width:2px; border-top-color:#000000; border-right-color:#000000; ">Plus
anzeigen
2olid; border-left-width:2px; border-left-color:#000000; ">ArnoArni
3olid; border-left-width:2px; border-left-color:#000000; ">olid; border-bottom-width:1px; border-bottom-color:#000000; ">€olid; border-bottom-width:1px; border-bottom-color:#000000; ">olid; border-bottom-width:1px; border-bottom-color:#000000; ">€olid; border-bottom-width:1px; border-bottom-color:#000000; ">olid; border-bottom-width:1px; border-bottom-color:#000000; ">€olid; border-bottom-width:1px; border-bottom-color:#000000; ">olid; border-bottom-styleConfusedolid; border-right-width:2px; border-bottom-width:1px; border-right-color:#000000; border-bottom-color:#000000; ">€
4olid; border-left-width:2px; border-left-color:#000000; ">02.06.2014-3125-31olid; border-right-width:2px; border-right-color:#000000; ">
5olid; border-left-width:2px; border-left-color:#000000; ">03.06.201410-70olid; border-right-width:2px; border-right-color:#000000; ">10
Formeln der Tabelle
ZelleFormel
C4=SUMMENPRODUKT(($K$4:$K$7=$A4)*($M$4:$M$7=C$2)*$Q$4:$Q$7)-SUMMENPRODUKT(($K$4:$K$7=$A4)*($M$4:$M$7=C$2)*$O$4:$O$7)
E4=SUMMENPRODUKT(($K$4:$K$7=$A4)*($M$4:$M$7=E$2)*$Q$4:$Q$7)-SUMMENPRODUKT(($K$4:$K$7=$A4)*($M$4:$M$7=E$2)*$O$4:$O$7)
G4=WENN(C4<0;C4;"")
I4=WENN(C4>0;C4;"")
C5=SUMMENPRODUKT(($K$4:$K$7=$A5)*($M$4:$M$7=C$2)*$Q$4:$Q$7)-SUMMENPRODUKT(($K$4:$K$7=$A5)*($M$4:$M$7=C$2)*$O$4:$O$7)
E5=SUMMENPRODUKT(($K$4:$K$7=$A5)*($M$4:$M$7=E$2)*$Q$4:$Q$7)-SUMMENPRODUKT(($K$4:$K$7=$A5)*($M$4:$M$7=E$2)*$O$4:$O$7)
G5=WENN(C5<0;C5;"")
I5=WENN(C5>0;C5;"")

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#4
Hallo,

ich sehe das so:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFGHIJKLMNOPQ
1      Minus
anzeigen
 Plus
anzeigen
        
2  Arno Arni       soll ist
3           
402.06.2014 -31 25 -31 25 02.06.14 Arno 41 10
503.06.2014 10 -70 -70 0 02.06.14 Arni 25 50
6          03.06.14 Arno 100 110
7        03.06.14 Arni 80 10
8                 

ZelleFormel
C4=SUMMENPRODUKT(($K$4:$K$7=$A4)*($M$4:$M$7=C$2)*($Q$4:$Q$7-$O$4:$O$7))
E4=SUMMENPRODUKT(($K$4:$K$7=$A4)*($M$4:$M$7=E$2)*($Q$4:$Q$7-$O$4:$O$7))
G4=SUMMEWENN(C4:E4;"<0")
I4=SUMMEWENN(E4:G4;">0")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß


Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#5
Hi Edgar,

ich glaube, du hast natürlich Recht. Ich hatte übersehen, dass da ja noch eine zweite Spalte ist, die ebenfalls mitberechnet werden muss.
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#6
Josef B Thx
WillWissen Thx
BoskoBiati Thx

Hallo Montagnachmittagg'meinde
- nun eine kleine Ecke weiter
nehmen wir mal an es handelt sich um die gleiche Anordnung, aber jetzt per VBA Code die Formel erstellen.
Habs mal mit dem Makrorekorder versucht, uff, da ist mir mein altes Audio-Tape lieber.

Bin zwar in der Rubrik "Wie verwende ich ...." am lesen, aber das realisieren ist beschi...... .
Zeigt mir einer von euch bitte den Codeschnipsel + Erläuterung.
Text- Combo- Listboxen befüllen geht ja schon, aber das is doch schärfster Tobak für mich.
Mach mir jetzt erst mal ne Pfeife 'Sherry&Cherry' und warte auf ein paar kleine Gedanken.

vorab danke
mfg
(>'I')> Dienstag. 03.Juni.2014 05:04 PM <('I'<)
?mage
to top
#7
Hallo Frank,

Zitat:Habs mal mit dem Makrorekorder versucht, uff, da ist mir mein altes Audio-Tape lieber.

Bin zwar in der Rubrik "Wie verwende ich ...." am lesen, aber das realisieren ist beschi...... .
Zeigt mir einer von euch bitte den Codeschnipsel + Erläuterung.

Das ist im Grunde doch ganz einfach.
Wenn ich das richtig verstanden habe, was Du tun willst, dann geht das so ....

1. Makrorecorder einschalten
2. Auf dem Tabellenblatt das machen, was das Makro machen soll
3. Makrorekorder ausschalten.
4. In den VBA-Editor wechseln, Code anschauen, verstehen und optimieren.
5. Den ganzen Kram speichern.

6. sich freuen, daß Alles läuft 190519
________________________________________________________________________
wer aufgibt, ohne es versucht zu haben, gibt einfach nur auf!

?mage
[-] Folgende(r) 1 Benutzer sagt Danke an Käpt'n Blaubär für diesen Beitrag:
WergibtmirRat
to top
#8
(03.06.2014, 19:12)Käptn Blaubär schrieb: Das ist im Grunde doch ganz einfach.
Wenn ich das richtig verstanden habe, was Du tun willst, dann geht das so .... sich freuen, daß Alles läuft
Tja, geduldig ist der Frickler (wie ich einer bin)
Geht nicht, gibt's bei mir zu 98% nicht.

Danke für die kurze knappe Antwort. Hab es dann doch hinbekommen. [Summenprodukt]

Was nur auffällt bei der Umschaltung von A1;B1; C1 auf Z1;C1, der Code ist noch unleserlicher Huh

mfg
?mage
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Wert suchen in Spalte und wert da neben ausgeben VBA michel34497 2 44 02.12.2016, 23:33
Letzter Beitrag: michel34497
  Zeitreihe in Formel einsetzen und Ergebnis in Tabelle speichern Japa 4 72 29.11.2016, 20:54
Letzter Beitrag: Japa
  Performance-Problem Summenprodukt Klexx 6 89 24.11.2016, 14:24
Letzter Beitrag: Klexx
  Summenprodukt mit Datum derunsichere 4 52 17.11.2016, 14:27
Letzter Beitrag: BoskoBiati
  Summenprodukt aber nur in den letzten 5 Jahren marie 6 134 05.11.2016, 13:45
Letzter Beitrag: schauan
  Summenprodukt mit Bereich.verschieben exceltalent 3 69 03.11.2016, 17:06
Letzter Beitrag: Jockel
  Tabelle nach Wert durchsuchen, und jede Zeile ausspucken die diesen Wert besitzt THE ARCHITECT 14 260 01.11.2016, 12:19
Letzter Beitrag: snb
  KW + xWochen mit KW als Ergebnis StephPsc 12 214 19.10.2016, 08:37
Letzter Beitrag: BoskoBiati
  Umkehrung von Summenprodukt exceltalent 4 117 12.10.2016, 15:40
Letzter Beitrag: exceltalent
  Makro: Wenn Zelle Wert ≠ 0, dann Wert speichern und Formel löschen TsuBasti1 6 225 01.10.2016, 06:27
Letzter Beitrag: IchBinIch

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste