Automatische Neusortierung einer Tabelle mit 2 Bedingungen (INDEX,WENN,KGRÖSSTE,VERG)
#1
Hallo!
 
Ich möchte die folgende Aufgabe mit Excel automatisiert lösen:
 
Ich habe eine Ausgangstabelle (vereinfacht; Original mit mehr als 10 Datensätzen) mit den Spalten Name (Spalte A); Team (Spalte B); Gesamtergebnis (Spalte C) und (Rang (Gesamtergebnis) (Spalte D)) (siehe Bild oder Attachment anbei).

http://fs5.directupload.net/images/160607/vdvpdh8e.jpg

Diese Tabelle möchte ich von Excel neu sortieren lassen (in den Spalten F-I) nach den folgenden Regeln: Zuerst sollen alle Mitglieder aus Team Gold und Team Silber (sortiert nach Gesamtergebnis absteigend) aufgeführt werden; danach alle anderen Mitglieder (=Mitglieder aus Team Rot und Team Grün), auch wieder sortiert nach Gesamtergebnis absteigend.
 
Wie müssten die Formeln für die Spalten F-I lauten? Wahrscheinlich lässt sich die Aufgabe mit einer Kombination aus den Funktionen INDEX; KGRÖSSTE; WENN und ggf. VERGLEICH lösen. Eine gute Kombination will mir aber nicht in den Sinn kommen. Hat jemand eine Idee?
 
Vielen Dank für die Hilfe!


Angehängte Dateien
.xlsx   Kopie von Beispiel-Tabelle.xlsx (Größe: 11,5 KB / Downloads: 4)
Antwortento top
#2
Hallo

Arbeitsblatt mit dem Namen 'Tabelle1 (2)'
 ABCDEFGHIJK
1Ausgangstabelle     Neusortierte Tabelle    
2           
3NameTeamGesamtergebnisRang (Gesamtergebnis)Hilfsspalte NameTeamGesamtergebnisRang (neu)Hilfsspalte
4Mustermann, MaxRot58,28%3100,582807 Musterfrau, MaxiGold87,37%12
5Musterfrau, MaxiGold87,37%1200,8736842 Neid, SilviaSilber50,00%28
6Qualle, HubertusRot59,32%2100,5931579 Löw, JogiSilber39,47%310
7Keule, KarlGrün39,47%5100,3947368 Schweinsteiger, SebastianGold26,39%45
8Schweinsteiger, SebastianGold26,39%8200,2638596 Qualle, HubertusRot59,32%53
9Müller, ThomasGrün21,05%10100,2105263 Mustermann, MaxRot58,28%61
10Reus, MarcoGrün34,21%7100,3421053 Keule, KarlGrün39,47%74
11Neid, SilviaSilber50,00%4200,5 Reus, MarcoGrün34,21%87
12Klinsmann, JürgenRot23,68%9100,2368421 Klinsmann, JürgenRot23,68%99
13Löw, JogiSilber39,47%5200,3947368 Müller, ThomasGrün21,05%106

ZelleFormel
E4=VERWEIS(B4;{"Gold";"Grün";"Rot";"Silber"};{200;100;100;200})+C4
G4=INDEX(A$4:A$13;$K4)
K4=VERGLEICH(KGRÖSSTE($E$4:$E$13;ZEILE(A1));$E$4:$E$13;0)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
[-] Folgende(r) 1 Benutzer sagt Danke an shift-del für diesen Beitrag:
  • emmvau
Antwortento top
#3
Hola,

auch immer interessant zu lesen:

http://www.clever-excel-forum.de/Thread-Crossposting

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • emmvau
Antwortento top
#4
Vielen Dank für die schnelle Rückmeldung! Ich werde die Lösung morgen ausprobieren und gebe hier eine Rückmeldung.

Für das Crossposting bitte ich um Entschuldigung!
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste