Abfrage aus 9er Matrix
#1
Liebes Forum,

ich hoffe ihr könnt mir helfen.

Ich habe zwei Spalten. Beide Spalten können je drei unterschiedliche Werte haben. Die zwei Spalten in Kombination ergeben einen Wert. Sprich 9er Matrix.

Ich möchte nun in einer dritten Spalte den entsprechenden Wert dieser Kombination angeben.

Habt ihr einen Lösungsvorschlag?

Viele Grüße,

Dominik


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#2
Hola,

schau mal hier:

http://www.excelformeln.de/formeln.html?welcher=39

Gruß,
steve1da
Antwortento top
#3
Hi,

(07.06.2016, 16:49)sewol schrieb: Habt ihr einen Lösungsvorschlag?

=summenprodukt(($E$4:$G$4=A4)*($D$5:$D$7=B4);($E$5:$G$7))
Antwortento top
#4
(07.06.2016, 16:53)Rabe schrieb: Hi,

=summenprodukt(($E$4:$G$4=A4)*($D$5:$D$7=B4);($E$5:$G$7))

Hallo Ralf, du kannst hier 2 Klammern verkaufen...

... alternativ zu deiner Lösung ginge auch kürzer ..:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFGHI
3  AB  LargeMediumSmall
444LargeMedium Large123
577LargeSmallYMedium456
655MediumMedium Small789

ZelleFormel
A4=SVERWEIS(D4;$F$4:$I$6;VERGLEICH(C4;$F$3:$I$3;0))
B4=SUMMENPRODUKT(($G$3:$I$3=C4)*($F$4:$F$6=D4);$G$4:$I$6)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
Antwortento top
#5
Hallo Jörg,

Dein Glück, dass die Bezeichnungen aufsteigend sortiert sind, sonst würde Deine Formel ohne den 4.Parameter nicht funktionieren (Spalte B):

[html]
Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFGHIJ
3   AB  LargeMediumSmall
4444LargeMedium Small789
5717LargeSmallYMedium456
6555MediumMedium Large123

ZelleFormel
A4=INDEX($H$4:$J$6;VERGLEICH(E4;$G$4:$G$6;0);VERGLEICH(D4;$H$3:$J$3;0))
B4=SVERWEIS($E4;$G$4:$J$6;VERGLEICH($D4;$G$3:$J$3;0))
C4=SVERWEIS($E4;$G$4:$J$6;VERGLEICH($D4;$G$3:$J$3;0);0)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
[/html]
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#6
Hi Jörg,

(07.06.2016, 17:17)Jockel schrieb: du kannst hier 2 Klammern verkaufen...

danke, ich kann mir einfach nicht merken, wann ich die Klammern setzen muß und wann nicht. Aber vermutlich ist es nur dann, wenn eine Matrix mit Vergleich enthalten ist.
Antwortento top
#7
Hallo,

Zitat:Aber vermutlich ist es nur dann, wenn eine Matrix mit Vergleich enthalten ist

richtig!
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#8
oder


Code:
=INDEX({1\2\3;4\5\6;7\8\9};SEARCH(LEFT(D2;1);"LMS");SEARCH(LEFT(C2;1);"LMS"))
Antwortento top
#9
Hallo snb,

was soll das? Ohne zugehörige Tabelle ist die Formel witzlos und in deutsche Syntax übersetzen dürfte auch nicht jedem gelingen!!!!
Zudem ist das noch die längste der vorgestellten Formeln.
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#10
Vielen Dank für die vielen Antworten. Leider konnte ich immer noch kein Ergebnis erzielen.

Habe noch mal einen genaueren Beispiel-Screenshot gemacht. Die Zahlen in der Matrix werden random sein, nicht auf bzw absteigend.


Angehängte Dateien Thumbnail(s)
   
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste