Vergleich Fußballtabellen automatisch erstellen
#1
Guten Tag an alle
Ich will drei Fußballtabellen miteinander vergleichen, die sich automatisch erstellen.
Die beiden obigen Tabellen funktionieren. (Siehe Bild)
Die untere dritte funktioniert aber nicht. (Siehe Bild, das ich extra posten musste, weil nur 500 Zellen von Jeani als Bild erstellt werden.)
Wer kann mir helfen?
FußballTabelle

ABCDEFGHIJKLMNOPQ
2Mannheim18-31Hamburg2512Mannheim21-31München255
3Offenbach2132Braunschweig238Offenbach1432Hannover23-8
4Frankfurt14-63Stuttgart225Frankfurt21-63Hamburg2112
5München2154Freiburg216München2554Darmstadt21-2
6Hamburg25125München215Hamburg21125Mannheim21-3
7Stuttgart2256Offenbach213Stuttgart1656Frankfurt21-6
8Hannover16-87Darmstadt18-2Hannover23-87Braunschweig188
9Braunschweig2388Mannheim18-3Braunschweig1888Freiburg186
10Darmstadt18-29Hannover16-8Darmstadt21-29Stuttgart165
11Freiburg21610Frankfurt14-6Freiburg18610Offenbach143
Formeln der Tabelle
ZelleFormel
F2{=INDEX(A:A;VERGLEICH(G2;B$1:B$92+(C$1:C$92)/1000-ZEILE($1:$92)/10000000;0))}
G2{=KGRÖSSTE(WENN($A$2:$A$92<>"";(B$2:B$92+C$2:C$92/1000-ZEILE($2:$92)/10000000));ZEILE()-1)}
H2=INDEX(C:C;VERGLEICH(F2;A:A;0))
O2{=INDEX(J:J;VERGLEICH(P2;K$1:K$92+(L$1:L$92)/1000-ZEILE($1:$92)/10000000;0))}
P2{=KGRÖSSTE(WENN($J$2:$J$92<>"";(K$2:K$92+L$2:L$92/1000-ZEILE($2:$92)/10000000));ZEILE()-1)}
Q2=INDEX(L:L;VERGLEICH(O2;J:J;0))
E3=WENN(RUNDEN(G3;5)=RUNDEN(G2;5);"";ZEILE()-1)
F3{=INDEX(A:A;VERGLEICH(G3;B$1:B$92+(C$1:C$92)/1000-ZEILE($1:$92)/10000000;0))}
G3{=KGRÖSSTE(WENN($A$2:$A$92<>"";(B$2:B$92+C$2:C$92/1000-ZEILE($2:$92)/10000000));ZEILE()-1)}
H3=INDEX(C:C;VERGLEICH(F3;A:A;0))
N3=WENN(RUNDEN(P3;5)=RUNDEN(P2;5);"";ZEILE()-1)
O3{=INDEX(J:J;VERGLEICH(P3;K$1:K$92+(L$1:L$92)/1000-ZEILE($1:$92)/10000000;0))}
P3{=KGRÖSSTE(WENN($J$2:$J$92<>"";(K$2:K$92+L$2:L$92/1000-ZEILE($2:$92)/10000000));ZEILE()-1)}
Q3=INDEX(L:L;VERGLEICH(O3;J:J;0))
E4=WENN(RUNDEN(G4;5)=RUNDEN(G3;5);"";ZEILE()-1)
F4{=INDEX(A:A;VERGLEICH(G4;B$1:B$92+(C$1:C$92)/1000-ZEILE($1:$92)/10000000;0))}
G4{=KGRÖSSTE(WENN($A$2:$A$92<>"";(B$2:B$92+C$2:C$92/1000-ZEILE($2:$92)/10000000));ZEILE()-1)}
H4=INDEX(C:C;VERGLEICH(F4;A:A;0))
N4=WENN(RUNDEN(P4;5)=RUNDEN(P3;5);"";ZEILE()-1)
O4{=INDEX(J:J;VERGLEICH(P4;K$1:K$92+(L$1:L$92)/1000-ZEILE($1:$92)/10000000;0))}
P4{=KGRÖSSTE(WENN($J$2:$J$92<>"";(K$2:K$92+L$2:L$92/1000-ZEILE($2:$92)/10000000));ZEILE()-1)}
Q4=INDEX(L:L;VERGLEICH(O4;J:J;0))
E5=WENN(RUNDEN(G5;5)=RUNDEN(G4;5);"";ZEILE()-1)
F5{=INDEX(A:A;VERGLEICH(G5;B$1:B$92+(C$1:C$92)/1000-ZEILE($1:$92)/10000000;0))}
G5{=KGRÖSSTE(WENN($A$2:$A$92<>"";(B$2:B$92+C$2:C$92/1000-ZEILE($2:$92)/10000000));ZEILE()-1)}
H5=INDEX(C:C;VERGLEICH(F5;A:A;0))
N5=WENN(RUNDEN(P5;5)=RUNDEN(P4;5);"";ZEILE()-1)
O5{=INDEX(J:J;VERGLEICH(P5;K$1:K$92+(L$1:L$92)/1000-ZEILE($1:$92)/10000000;0))}
P5{=KGRÖSSTE(WENN($J$2:$J$92<>"";(K$2:K$92+L$2:L$92/1000-ZEILE($2:$92)/10000000));ZEILE()-1)}
Q5=INDEX(L:L;VERGLEICH(O5;J:J;0))
E6=WENN(RUNDEN(G6;5)=RUNDEN(G5;5);"";ZEILE()-1)
F6{=INDEX(A:A;VERGLEICH(G6;B$1:B$92+(C$1:C$92)/1000-ZEILE($1:$92)/10000000;0))}
G6{=KGRÖSSTE(WENN($A$2:$A$92<>"";(B$2:B$92+C$2:C$92/1000-ZEILE($2:$92)/10000000));ZEILE()-1)}
H6=INDEX(C:C;VERGLEICH(F6;A:A;0))
N6=WENN(RUNDEN(P6;5)=RUNDEN(P5;5);"";ZEILE()-1)
O6{=INDEX(J:J;VERGLEICH(P6;K$1:K$92+(L$1:L$92)/1000-ZEILE($1:$92)/10000000;0))}
P6{=KGRÖSSTE(WENN($J$2:$J$92<>"";(K$2:K$92+L$2:L$92/1000-ZEILE($2:$92)/10000000));ZEILE()-1)}
Q6=INDEX(L:L;VERGLEICH(O6;J:J;0))
E7=WENN(RUNDEN(G7;5)=RUNDEN(G6;5);"";ZEILE()-1)
F7{=INDEX(A:A;VERGLEICH(G7;B$1:B$92+(C$1:C$92)/1000-ZEILE($1:$92)/10000000;0))}
G7{=KGRÖSSTE(WENN($A$2:$A$92<>"";(B$2:B$92+C$2:C$92/1000-ZEILE($2:$92)/10000000));ZEILE()-1)}
H7=INDEX(C:C;VERGLEICH(F7;A:A;0))
N7=WENN(RUNDEN(P7;5)=RUNDEN(P6;5);"";ZEILE()-1)
O7{=INDEX(J:J;VERGLEICH(P7;K$1:K$92+(L$1:L$92)/1000-ZEILE($1:$92)/10000000;0))}
P7{=KGRÖSSTE(WENN($J$2:$J$92<>"";(K$2:K$92+L$2:L$92/1000-ZEILE($2:$92)/10000000));ZEILE()-1)}
Q7=INDEX(L:L;VERGLEICH(O7;J:J;0))
E8=WENN(RUNDEN(G8;5)=RUNDEN(G7;5);"";ZEILE()-1)
F8{=INDEX(A:A;VERGLEICH(G8;B$1:B$92+(C$1:C$92)/1000-ZEILE($1:$92)/10000000;0))}
G8{=KGRÖSSTE(WENN($A$2:$A$92<>"";(B$2:B$92+C$2:C$92/1000-ZEILE($2:$92)/10000000));ZEILE()-1)}
H8=INDEX(C:C;VERGLEICH(F8;A:A;0))
N8=WENN(RUNDEN(P8;5)=RUNDEN(P7;5);"";ZEILE()-1)
O8{=INDEX(J:J;VERGLEICH(P8;K$1:K$92+(L$1:L$92)/1000-ZEILE($1:$92)/10000000;0))}
P8{=KGRÖSSTE(WENN($J$2:$J$92<>"";(K$2:K$92+L$2:L$92/1000-ZEILE($2:$92)/10000000));ZEILE()-1)}
Q8=INDEX(L:L;VERGLEICH(O8;J:J;0))
E9=WENN(RUNDEN(G9;5)=RUNDEN(G8;5);"";ZEILE()-1)
F9{=INDEX(A:A;VERGLEICH(G9;B$1:B$92+(C$1:C$92)/1000-ZEILE($1:$92)/10000000;0))}
G9{=KGRÖSSTE(WENN($A$2:$A$92<>"";(B$2:B$92+C$2:C$92/1000-ZEILE($2:$92)/10000000));ZEILE()-1)}
H9=INDEX(C:C;VERGLEICH(F9;A:A;0))
N9=WENN(RUNDEN(P9;5)=RUNDEN(P8;5);"";ZEILE()-1)
O9{=INDEX(J:J;VERGLEICH(P9;K$1:K$92+(L$1:L$92)/1000-ZEILE($1:$92)/10000000;0))}
P9{=KGRÖSSTE(WENN($J$2:$J$92<>"";(K$2:K$92+L$2:L$92/1000-ZEILE($2:$92)/10000000));ZEILE()-1)}
Q9=INDEX(L:L;VERGLEICH(O9;J:J;0))
E10=WENN(RUNDEN(G10;5)=RUNDEN(G9;5);"";ZEILE()-1)
F10{=INDEX(A:A;VERGLEICH(G10;B$1:B$92+(C$1:C$92)/1000-ZEILE($1:$92)/10000000;0))}
G10{=KGRÖSSTE(WENN($A$2:$A$92<>"";(B$2:B$92+C$2:C$92/1000-ZEILE($2:$92)/10000000));ZEILE()-1)}
H10=INDEX(C:C;VERGLEICH(F10;A:A;0))
N10=WENN(RUNDEN(P10;5)=RUNDEN(P9;5);"";ZEILE()-1)
O10{=INDEX(J:J;VERGLEICH(P10;K$1:K$92+(L$1:L$92)/1000-ZEILE($1:$92)/10000000;0))}
P10{=KGRÖSSTE(WENN($J$2:$J$92<>"";(K$2:K$92+L$2:L$92/1000-ZEILE($2:$92)/10000000));ZEILE()-1)}
Q10=INDEX(L:L;VERGLEICH(O10;J:J;0))
E11=WENN(RUNDEN(G11;5)=RUNDEN(G10;5);"";ZEILE()-1)
F11{=INDEX(A:A;VERGLEICH(G11;B$1:B$92+(C$1:C$92)/1000-ZEILE($1:$92)/10000000;0))}
G11{=KGRÖSSTE(WENN($A$2:$A$92<>"";(B$2:B$92+C$2:C$92/1000-ZEILE($2:$92)/10000000));ZEILE()-1)}
H11=INDEX(C:C;VERGLEICH(F11;A:A;0))
N11=WENN(RUNDEN(P11;5)=RUNDEN(P10;5);"";ZEILE()-1)
O11{=INDEX(J:J;VERGLEICH(P11;K$1:K$92+(L$1:L$92)/1000-ZEILE($1:$92)/10000000;0))}
P11{=KGRÖSSTE(WENN($J$2:$J$92<>"";(K$2:K$92+L$2:L$92/1000-ZEILE($2:$92)/10000000));ZEILE()-1)}
Q11=INDEX(L:L;VERGLEICH(O11;J:J;0))
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
           
FußballTabelle

FGHIJKLMNOPQRS
13F2: {=INDEX(A:A;VERGLEICH(G2;B$1:B$90+(C$1:C$90)/1000-ZEILE($1:$90)/10000000;0))}
14O2: {=INDEX(J:J;VERGLEICH(P2;K$1:K$90+(L$1:L$90)/1000-ZEILE($1:$90)/10000000;0))}
15N22{=INDEX(I:I;VERGLEICH(O22;J$22:J$92+(K$22:K$92)/1000-ZEILE($1:$92)/10000000;0))}
16G2:):{=KGRÖSSTE(WENN($A$2:$A$100<>"";(B$2:B$100+C$2:C$100/1000-ZEILE($2:$100)/10000000));ZEILE()-1)}
17P2:{=KGRÖSSTE(WENN($J$2:$J$100<>"";(K$2:K$100+L$2:L$100/1000-ZEILE($2:$100)/10000000));ZEILE()-1)}
18O22:{=KGRÖSSTE(WENN($A$2:$A$92<>"";(J$2:J$92+K$2:K$92/1000-ZEILE($2:$92)/10000000));ZEILE()-1)}
19H2=H2:=INDEX(C:C;VERGLEICH(F2;A:A;0))
20Q2= Q2:=INDEX(L:L;VERGLEICH(O2;J:J;0))
21P22= P22:INDEX(K:K;VERGLEICH(N22;I:I;0))
22Mannheim14-31#WERT!#WERT!#WERT!
23Offenbach213#WERT!#WERT!#WERT!#WERT!
24Frankfurt25-6#WERT!#WERT!#WERT!#WERT!
25München215#WERT!#WERT!#WERT!#WERT!
26Hamburg1612#WERT!#WERT!#WERT!#WERT!
27Stuttgart235#WERT!#WERT!#WERT!#WERT!
28Hannover25-8#WERT!#WERT!#WERT!#WERT!
29Braunschweig238#WERT!#WERT!#WERT!#WERT!
30Darmstadt21-2#WERT!#WERT!#WERT!#WERT!
31Freiburg186#WERT!#WERT!#WERT!#WERT!
Formeln der Tabelle
ZelleFormel
N22{=INDEX(I:I;VERGLEICH(O22;J$22:J$92+(K$22:K$92)/1000-ZEILE($1:$92)/10000000;0))}
O22{=KGRÖSSTE(WENN($A$2:$A$92<>"";(J$2:J$92+K$2:K$92/1000-ZEILE($2:$92)/10000000));ZEILE()-1)}
P22=INDEX(K:K;VERGLEICH(N22;I:I;0))
M23=WENN(RUNDEN(O23;5)=RUNDEN(O22;5);"";ZEILE()-1)
N23{=INDEX(I:I;VERGLEICH(O23;J$1:J$92+(K$1:K$92)/1000-ZEILE($1:$92)/10000000;0))}
O23{=KGRÖSSTE(WENN($A$2:$A$92<>"";(J$2:J$92+K$2:K$92/1000-ZEILE($2:$92)/10000000));ZEILE()-1)}
P23=INDEX(K:K;VERGLEICH(N23;I:I;0))
M24=WENN(RUNDEN(O24;5)=RUNDEN(O23;5);"";ZEILE()-1)
N24{=INDEX(I:I;VERGLEICH(O24;J$1:J$92+(K$1:K$92)/1000-ZEILE($1:$92)/10000000;0))}
O24{=KGRÖSSTE(WENN($A$2:$A$92<>"";(J$2:J$92+K$2:K$92/1000-ZEILE($2:$92)/10000000));ZEILE()-1)}
P24=INDEX(K:K;VERGLEICH(N24;I:I;0))
M25=WENN(RUNDEN(O25;5)=RUNDEN(O24;5);"";ZEILE()-1)
N25{=INDEX(I:I;VERGLEICH(O25;J$1:J$92+(K$1:K$92)/1000-ZEILE($1:$92)/10000000;0))}
O25{=KGRÖSSTE(WENN($A$2:$A$92<>"";(J$2:J$92+K$2:K$92/1000-ZEILE($2:$92)/10000000));ZEILE()-1)}
P25=INDEX(K:K;VERGLEICH(N25;I:I;0))
M26=WENN(RUNDEN(O26;5)=RUNDEN(O25;5);"";ZEILE()-1)
N26{=INDEX(I:I;VERGLEICH(O26;J$1:J$92+(K$1:K$92)/1000-ZEILE($1:$92)/10000000;0))}
O26{=KGRÖSSTE(WENN($A$2:$A$92<>"";(J$2:J$92+K$2:K$92/1000-ZEILE($2:$92)/10000000));ZEILE()-1)}
P26=INDEX(K:K;VERGLEICH(N26;I:I;0))
M27=WENN(RUNDEN(O27;5)=RUNDEN(O26;5);"";ZEILE()-1)
N27{=INDEX(I:I;VERGLEICH(O27;J$1:J$92+(K$1:K$92)/1000-ZEILE($1:$92)/10000000;0))}
O27{=KGRÖSSTE(WENN($A$2:$A$92<>"";(J$2:J$92+K$2:K$92/1000-ZEILE($2:$92)/10000000));ZEILE()-1)}
P27=INDEX(K:K;VERGLEICH(N27;I:I;0))
M28=WENN(RUNDEN(O28;5)=RUNDEN(O27;5);"";ZEILE()-1)
N28{=INDEX(I:I;VERGLEICH(O28;J$1:J$92+(K$1:K$92)/1000-ZEILE($1:$92)/10000000;0))}
O28{=KGRÖSSTE(WENN($A$2:$A$92<>"";(J$2:J$92+K$2:K$92/1000-ZEILE($2:$92)/10000000));ZEILE()-1)}
P28=INDEX(K:K;VERGLEICH(N28;I:I;0))
M29=WENN(RUNDEN(O29;5)=RUNDEN(O28;5);"";ZEILE()-1)
N29{=INDEX(I:I;VERGLEICH(O29;J$1:J$92+(K$1:K$92)/1000-ZEILE($1:$92)/10000000;0))}
O29{=KGRÖSSTE(WENN($A$2:$A$92<>"";(J$2:J$92+K$2:K$92/1000-ZEILE($2:$92)/10000000));ZEILE()-1)}
P29=INDEX(K:K;VERGLEICH(N29;I:I;0))
M30=WENN(RUNDEN(O30;5)=RUNDEN(O29;5);"";ZEILE()-1)
N30{=INDEX(I:I;VERGLEICH(O30;J$1:J$92+(K$1:K$92)/1000-ZEILE($1:$92)/10000000;0))}
O30{=KGRÖSSTE(WENN($A$2:$A$92<>"";(J$2:J$92+K$2:K$92/1000-ZEILE($2:$92)/10000000));ZEILE()-1)}
P30=INDEX(K:K;VERGLEICH(N30;I:I;0))
M31=WENN(RUNDEN(O31;5)=RUNDEN(O30;5);"";ZEILE()-1)
N31{=INDEX(I:I;VERGLEICH(O31;J$1:J$92+(K$1:K$92)/1000-ZEILE($1:$92)/10000000;0))}
O31{=KGRÖSSTE(WENN($A$2:$A$92<>"";(J$2:J$92+K$2:K$92/1000-ZEILE($2:$92)/10000000));ZEILE()-1)}
P31=INDEX(K:K;VERGLEICH(N31;I:I;0))
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
[Ich schreibe mit Excel 2007]

Lieben Gruß und Danke
Stefan
Antwortento top
#2
Hallo Stefan

Was mir auffällt.
In Spalte N verwendest du ZEILE($1:$92)/10000000 und in Spalte O stattdessen ZEILE($2:$92)/10000000.
In Spalte O steht außerdem ZEILE()-1. Damit wird in Zeile 22 der 21-größte Wert gesucht. Wenn es weniger als 21 Zahlenwerte in der Matrix (J$2:J$92+K$2:K$92/1000-ZEILE($2:$92)/10000000) gibt dann kommt eben der Fehler #WERT!.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#3
Lieber shift-del,
danke.
zunächst einmal: dein Link auf deine Homepage (cloud) funkt nicht.
1. Ich habe die Zelle O der Zelle N angepasst: also "ZEILE($1:$92)/" in O hingeschrieben.
2. Dann habe ich in O "ZEILE()-10" hingeschreiben, weil es sich um 10 Mannschaftgen handelt.
Mir erscheint das unlogisch, denn in den oberen beiden Tabellen handelt es sich auch nur um 10 Mannschaften, wobei hier die Tabelle funkt mit "Zeile()-1".
Ich gehe falsch mit deinen Ratschlägen um, weil ich die Formeln nicht verstehe. Ich muss mich also langsam rantasten an einen Verbesserungsvorschlag.
[Ich schreibe mit Excel 2007]

Lieben Gruß und Danke
Stefan
Antwortento top
#4
Hallo Stefan,

Du solltest Dir im Klaren sein, was Zeile() überhaupt macht: Diese Funktion gibt nur eine Zahl aus, nämlich die Zeilennummer, in der die Formel steht.

Das hier:


Code:
=KGRÖSSTE(WENN($A$2:$A$92<>"";(B$2:B$92+C$2:C$92/1000-ZEILE($2:$92)/10000000));ZEILE()-1)

ergibt in Zeile 2 den grössten Wert, in Zeile 9 aber den achtgrößten Wert, in Zeile 1 sogar einen Fehler! Besser wäre es wohl hier Zeile(A1) zu schreiben, das ergibt den größten und wenn man es nach unten zieht, immer den nächstkleineren Wert!

[html]
Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCD
5541212
6 388
73177
80#ZAHL!55
98#ZAHL!44
1012#ZAHL!33
110#ZAHL!11
120#ZAHL!#ZAHL!#ZAHL!
134#ZAHL!#ZAHL!#ZAHL!
147#ZAHL!#ZAHL!#ZAHL!
150   
160   
170   
181   

ZelleFormel
B5{=KGRÖSSTE(WENN($A$5:$A$18<>0;$A$5:$A$18);ZEILE())}
C5{=KGRÖSSTE(WENN($A$5:$A$18<>0;$A$5:$A$18);ZEILE(A1))}
D5{=KGRÖSSTE(WENN($A$5:$A$18<>0;$A$5:$A$18);ZEILE()-4)}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
[/html]
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • Stefan Link
Antwortento top
#5
Danke, Edgar, für
die Erklärung der Formel "Zeile". Wie gesagt, ich arbeite mich vor. Habe heute keine Zeit mehr. Morgen wieder. Ich gebe dir Bescheid.
[Ich schreibe mit Excel 2007]

Lieben Gruß und Danke
Stefan
Antwortento top
#6
(06.06.2016, 07:15)Stefan Link schrieb: Lieber shift-del,
danke.
zunächst einmal: dein Link auf deine Homepage (cloud) funkt nicht.
Danke, werde ich mir mal ansehen und korrigieren.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#7
Lieber BoskoBiati,
um die Funktion von "ZEILE" erst mal zu verstehen,
brachte ich deinen Vorschlag auf Zahlenverhältnisse,
wenn man die Werte auf die erste Zeile bringt.
Hier das Ergebnis.
Und die Analyse ergibt: "Zeile()" in B1 hat den richtigen Wert erbracht, nicht "Zeile(A1)" in C1.
(Die anderen Formel-Arguemnte verstehe ich jetzt auch. Morgen probiere ich mal aus, wenn ich auf einem Tabellenblatt drei unterschiedliche Tabellen habe, um diese Tabellen miteinader vergleichen zu können - so wie mein Ausgangsproblem war.)


ABCD
15128#ZAHL!
2083#ZAHL!
3370#ZAHL!
4050#ZAHL!
584012
612308
70#ZAHL!#ZAHL!#ZAHL!
80#ZAHL!#ZAHL!#ZAHL!
94#ZAHL!#ZAHL!4
107#ZAHL!#ZAHL!3
110#ZAHL!#ZAHL!#ZAHL!
120#ZAHL!#ZAHL!#ZAHL!
130#ZAHL!#ZAHL!#ZAHL!
Formeln der Tabelle
ZelleFormel
A1='2'!A2
B1{=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$1:$A$13);ZEILE())}
C1{=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$3:$A$13);ZEILE(A1))}
D1=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$1:$A$13);ZEILE()-4)
A2='2'!A3
B2{=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$1:$A$13);ZEILE())}
C2{=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$3:$A$13);ZEILE(A2))}
D2=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$1:$A$13);ZEILE()-4)
A3='2'!A4
B3{=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$1:$A$13);ZEILE())}
C3{=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$3:$A$13);ZEILE(A3))}
D3=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$1:$A$13);ZEILE()-4)
A4='2'!A5
B4{=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$1:$A$13);ZEILE())}
C4{=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$3:$A$13);ZEILE(A4))}
D4=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$1:$A$13);ZEILE()-4)
A5='2'!A6
B5{=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$1:$A$13);ZEILE())}
C5{=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$3:$A$13);ZEILE(A5))}
D5=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$1:$A$13);ZEILE()-4)
A6='2'!A7
B6{=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$1:$A$13);ZEILE())}
C6{=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$3:$A$13);ZEILE(A6))}
D6=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$1:$A$13);ZEILE()-4)
A7='2'!A8
B7{=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$1:$A$13);ZEILE())}
C7{=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$3:$A$13);ZEILE(A7))}
D7=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$1:$A$13);ZEILE()-4)
A8='2'!A9
B8{=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$1:$A$13);ZEILE())}
C8{=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$3:$A$13);ZEILE(A8))}
D8=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$1:$A$13);ZEILE()-4)
A9='2'!A10
B9{=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$1:$A$13);ZEILE())}
C9{=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$3:$A$13);ZEILE(A9))}
D9=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$1:$A$13);ZEILE()-4)
A10='2'!A11
B10{=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$1:$A$13);ZEILE())}
C10{=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$3:$A$13);ZEILE(A10))}
D10=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$1:$A$13);ZEILE()-4)
A11='2'!A12
B11{=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$1:$A$13);ZEILE())}
C11{=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$3:$A$13);ZEILE(A11))}
D11=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$1:$A$13);ZEILE()-4)
A12='2'!A13
B12{=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$1:$A$13);ZEILE())}
C12{=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$3:$A$13);ZEILE(A12))}
D12=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$1:$A$13);ZEILE()-4)
A13='2'!A14
B13{=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$1:$A$13);ZEILE())}
C13{=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$3:$A$13);ZEILE(A13))}
D13=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$1:$A$13);ZEILE()-4)
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
[Ich schreibe mit Excel 2007]

Lieben Gruß und Danke
Stefan
Antwortento top
#8
Hi Stefan,

(07.06.2016, 08:13)Stefan Link schrieb: um die Funktion von "ZEILE" erst mal zu verstehen,
brachte ich deinen Vorschlag auf Zahlenverhältnisse,
wenn man die Werte auf die erste Zeile bringt.
Hier das Ergebnis.
Und die Analyse ergibt: "Zeile()" in B1 hat den richtigen Wert erbracht, nicht "Zeile(A1)" in C1.

das kann nicht sein!
Zeile() in Zelle B1 ergibt als Zahl die 1  [= Ergebnis ist die Zeile der aktuellen Zelle]
Zeile(A1) egal in welcher Zelle, ergibt als Zahl ebenfalls und immer die 1  [= Ergebnis ist die Zeile der Zelle A1, also 1]

Wenn in zwei Zellen der gleichen Zeile ein unterschiedliches Ergebnis raus kommt, dann sind es unterschiedliche Formeln!

Und wenn Du Dir Deinen Ausschnitt anschaust, siehst DU das auch:
B1 {=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$1:$A$13);ZEILE())}
C1 {=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$3:$A$13);ZEILE(A1))}


Tabelle1
ABCD
151212#ZAHL!
2088#ZAHL!
3377#ZAHL!
4055#ZAHL!
584412
612338
70#ZAHL!#ZAHL!7
80#ZAHL!#ZAHL!5
94#ZAHL!#ZAHL!4
107#ZAHL!#ZAHL!3
110#ZAHL!#ZAHL!#ZAHL!
120#ZAHL!#ZAHL!#ZAHL!
130#ZAHL!#ZAHL!#ZAHL!

verwendete Formeln
Zelle Formel Bereich N/A
B1:B13{=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$1:$A$13);ZEILE())}$B$1
C1:C13{=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$1:$A$13);ZEILE(A1))}$C$1
D1: D13{=KGRÖSSTE(WENN($A$1:$A$13<>0;$A$1:$A$13);ZEILE()-4)}$D$1:$D$13
{} Matrixformel mit Strg+Umschalt+Enter abschließen
Matrixformeln sind durch geschweifte Klammern {} eingeschlossen
Diese Klammern nicht eingeben!!

Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 19.08 einschl. 64 Bit

[-] Folgende(r) 1 Benutzer sagt Danke an Rabe für diesen Beitrag:
  • Stefan Link
Antwortento top
#9
Es ist doch immer wieder köstlich; warum guckt sich niemand die online-Hilfe an oder probiert mit ZEILE() ... D1 ist besonders reizend in diesem Zusammenhang.
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
Antwortento top
#10
Thumps_up Thumps_up Thumps_up Thumps_up Thumps_up
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste