Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


[Excel] Quersumme einer mehrziffrigen Zahl berechnen
#1
Wer die Quersumme einer größeren Zahl - z.B 123456789 - benötigt, kann dies mit der Matrixformel* (in diesem Beispiel ausgehend von der Zahl in Zelle A1 und der Berechnung in Zelle B1)

PHP-Code:
=SUMME(1*TEIL(A1;ZEILE(INDIREKT(„1:&LÄNGE(A1)));1)) 


bewerkstelligen.

Tabelle2

AB
112345678945
Formeln der Tabelle
ZelleFormel
B1{=SUMME(1*TEIL(A1;ZEILE(INDIREKT("1:"&LÄNGE(A1)));1))}

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

* Matrixformeln werden mit STRG+UMSCHALT+ENTER abgeschlossen.

Aufgrund eines ergänzenden Beitrags von Edgar (BoskoBiati) habe ich mir die angegebene Seite angesehen. Es gibt in der Tat noch mehrere, ressourcenschonendere Formeln.

Hier der Link zu Excelformeln.de
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste