Zusammenhängende Zeiten auf volle Stunden aufrunden
#1
Hallo Zusammen,

dieses Forum hat mir bisher schon bei einigen Excelproblemen als stiller Leser helfen können, leider bin ich jetzt an einem Punkt angekommen an dem dies nicht mehr ausreicht.
Jedenfalls habe ich nichts per Suchfunktion gefunden

Nun zu meinem Problem:

In Spalte A habe ich ein Datum (TT.MM.JJJJ)
In Spalte B die Beginn Zeit  (HH:MM)
In Spalte C die End Zeit (HH:MM)
In Spalte D die errechnete Dezimalzeit
In Spalte E soll gerundet werden wenn der Zeitabschnitt danach nicht unmittelbar anschließt.

Nun würde ich gerne direkt aufeinanderfolgende Abschnitte zusammenrechnen und nur den letzten auf die Gesamtzahl der Stunden aufrunden lassen.
Ein Beispiel:

        A            B          C         D       E
02.06.2016 / 08:00 / 09:15 / 1,25 / 1,25
02.06.2016 / 09:15 / 10:30 / 1,25 / 1,25
02.06.2016 / 10:30 / 11:15 / 0,75 / 1,50  (1,25+1,25+0,75 = 3,25 aufgerundet 4,00 / 4-1,25-1,25 = 1,5)

02.06.2016 / 11:30 / 12:00 / 0,50 / 0,50
02.06.2016 / 12:00 / 13:30 / 1,50 / 1,50 (0,5+1,5 = 2 aufrunden nicht nötig) 

Irgendjemand eine Idee wie ich das zu Stande bekommen könnte?
VG
NurDieAushilfe (Jochen)
[-] Folgende(r) 1 Benutzer sagt Danke an NurDieAushilfe für diesen Beitrag:
  • Kuwer
Antwortento top
#2
Hallo,

1. wieso rundest Du auf 4 auf?
2. die Gesamtzahl der Stunden beträgt bei mir nur 3,5????
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#3
Hallo,

In Spalte D stehen die tatsächlichen Stunden

in diesem Fall 1,25 + 1,25 + 0,75 = 3,25
alle zusammenhängenden Abschnitte sollen auf volle Stunden aufgerundet werden, sprich aus 3,25 in Summe sollen 4 werden.

Da die 1,25 aus Zeile 1 und die 1,25 aus Zeile 2 nicht gerundet werden sollen, bleibt mir nur übrig die Differenz aus den aufgerundeten Gesamtstunden und den ungerundeten Einzelstunden zu ermitteln.

   4 Gesamtstunden
- 1,25 ungerundete Stunden Zeile1
- 1,25 ungerundete Stunden Zeile2

= 1,5

Gruß
NurDieAushilfe (Jochen)
Antwortento top
#4
Hi Jochen,

Mir erschließt sich nicht der Sinn der einzelnen Rundungen. Kannst du das bitte anhand eines Tabellenausschnittes besser erläutern? Was willst/musst du denn in deinem Original erreichen? Ich nehme an, dass deine Beispielzahlen nicht deinem Original entsprechen. Wenn du das besser rüberbringst, gibt es u.U. eine andere/bessere Lösung als Runden.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#5
Hallöchen,

Du brauchst in dem Fall einfach nur zu prüfen, ob die Endzeit der aktuellen Zeile der Startzeit der Folgezeile entspricht.
Also z.B. in E1

=WENN(C1=B2;...formel für ungerundet...;...formel für gerundet...)
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste