Hilfe S-Verweis Wenn/Sonst
#1
Hallo liebe Community,


Ich habe ein kleines Problem, anbei erhaltet ihr meine Tabelle.
Mir geht es um die Spalte ab H8, dort wird mein eingebener Brutto Beitrag * 100 genommen und durch den jeweiligen Steuersatz der jeweiligen Versicherung gerechnet, im Anschluss wird auch noch gemäß Zahlweise der Zuschlag abgezogen, damit ich den reinen Nettobetrag habe. Das klappt auch alles Super. Diese Regelung trifft aber leider nicht für die Versicherung "Kranken      mb:" und für "Leben      VS:" zu. Ich hab mir eigentlich gedacht das es in etwa soaussehen soll, kenne mich mit Excel nicht so gut aus habe leichte Java Kenntnisse:
Wenn ("E8=Kranken      mb:" dann mach X;Wenn E8="Leben      VS:" dann mach Y;Sonst mach das, was bis jetzt in der Formel steht.
Ich kann es leider nicht umsetzten, ich hoffe ihr könnt mir helfen Smile

Vielen Dank im voraus


Angehängte Dateien
.xlsx   Provision.xlsx (Größe: 29,04 KB / Downloads: 3)
Antwortento top
#2
Hi,

(31.05.2016, 13:29)hbboy15 schrieb: Wenn ("E8=Kranken      mb:" dann mach X;Wenn E8="Leben      VS:" dann mach Y;Sonst mach das, was bis jetzt in der Formel steht.
Ich kann es leider nicht umsetzten, ich hoffe ihr könnt mir helfen Smile

Du hast zum einen die " bei der Wennformel falsch gesetzt, es fehlen Klammern bei der zweiten WENN, es fehlen ; und zum anderen stehen in E8 andere Texte drin als in Deiner Formel (mehr Leerzeichen!).

heir mal korrigiert:

Januar
EFGH
7SparteZahlweiseBeitrag BruttoNetto
8Kranken          MB :dann mach X
9

verwendete Formeln
Zelle Formel Bereich N/A
H8=WENN(E8="Kranken          MB :";"dann mach X";WENN(E8="Leben              VS :";"dann mach Y";WENNFEHLER(G8*SVERWEIS(E8;Vorgaben!A$1: D$15;4;0)/SVERWEIS(E8;Vorgaben!A$1: D$15;3;0)*SVERWEIS(F8;Vorgaben!A$1: D$20;3;0)/SVERWEIS(F8;Vorgaben!A$1: D$20;2;0)*SVERWEIS(F8;Vorgaben!A$1: D$20;4;0);"")))
H9=WENNFEHLER(G9*SVERWEIS(E9;Vorgaben!A$1: D$15;4;0)/SVERWEIS(E9;Vorgaben!A$1: D$15;3;0)*SVERWEIS(F9;Vorgaben!A$1: D$20;3;0)/SVERWEIS(F9;Vorgaben!A$1: D$20;2;0)*SVERWEIS(F9;Vorgaben!A$1: D$20;4;0);"")

Daten, Gültigkeit
Zelle Zulassen Daten Wert1 Wert2 Leere Zellen ignorieren Zellendropdown Titel Eingabemeldung Eingabemeldung Titel Fehler Fehlermeldung Typ Fehlermeldung
E8Liste   =Vorgaben!$A$2:$A$13     Wahr   Wahr           Stopp
F8Liste   =Vorgaben!$A$17:$A$20     Wahr   Wahr           Stopp
E9Liste   =Vorgaben!$A$2:$A$13     Wahr   Wahr           Stopp
F9Liste   =Vorgaben!$A$17:$A$20     Wahr   Wahr           Stopp
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 19.08 einschl. 64 Bit



.xlsx   Provision.xlsx (Größe: 27,63 KB / Downloads: 1)
Antwortento top
#3
Hallo,

ich habe mal ein bißchen dran gearbeitet:


.xlsx   Provision.xlsx (Größe: 29,14 KB / Downloads: 7)

@Ralf,

wenn die Vorgaben auf ein einheitliches Maß gebracht werden, dann braucht man die Unterscheidungen nicht!
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste