Zahlenreihe wiederholen
#1
Hallo zusammen!
Ich versuch schon seit vielen Stunden folgendes Problem zu lösen:
es soll eine Zahlenreihe x-mal wiederholt werden, die auf Grund der Eingabe y zwischen 1 und 10 endet. Beispiel: x= 3, y= 4 -> 123412341234. Dabei sollen die Zahlen des Ergebnisses in einzelnen Zellen untereinander stehen.
Danke schonmal. Smile
Antwortento top
#2
Hallo

Zitat:Beispiel: x= 3, y= 4 -> 123412341234. Dabei sollen die Zahlen des Ergebnisses in einzelnen Zellen untereinander stehen.
Das klingt für mich auch nach einem Widerspruch.
Entweder ...
123412341234
... oder ...
1234
1234
1234
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#3
Die Zahlenreihe 1-4 soll 3 Mal untereinander dargestellt werden:
1
2
3
4
1
2
3
4
1
2
3
4
Antwortento top
#4
Also ganz anders.
Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCD
1x3 1
2y4 2
3   3
4   4
5   1
6   2
7   3
8   4
9   1
10   2
11   3
12   4
13    

ZelleFormel
D1=WENN(QUOTIENT(ZEILE(A1)-1;$B$2)+1>$B$1;"";REST(F1-1;$B$2)+1)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#5
Sieht gut aus. Funktioniert bei mir nur leider nicht. In Zelle D1 steht "WAHR" wenn ich die Formel übernehme.
Wieso bezieht sich die Formel auf Zelle F1?
Antwortento top
#6
Sorry, das war noch ein Rest vom Testen.
Code:
=WENN(QUOTIENT(ZEILE(A1)-1;$B$2)+1>$B$1;"";REST(ZEILE(A1)-1;$B$2)+1)
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
[-] Folgende(r) 1 Benutzer sagt Danke an shift-del für diesen Beitrag:
  • Duplomantin
Antwortento top
#7
Hallo,

oder auch so:

Arbeitsblatt mit dem Namen 'Tabelle2'
 ABCD
1x3 1
2y4 2
3   3
4   4
5   1
6   2
7   3
8   4
9   1
10   2
11   3
12   4

ZelleFormel
D1=WENN(ZEILE(A1)>$B$1*$B$2;"";REST(ZEILE(F1)-1;$B$2)+1)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • Duplomantin
Antwortento top
#8
Vielen Dank für eure Hilfe!
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste