Zählenwenns/Summewenns ist 0
#1
Hallo.... ich habe ein Problem mit Zählenwenns und Summewenns....

meine aktuelle Formel:

=ZÄHLENWENNS(Rohdatei!AW:AW;B2;Rohdatei!V:V;">0";Rohdatei!AX:AX;"<21";Rohdatei!AG:AG;{"<301"."489"."490"."352"})

Hier kommt als Ergebnis immer 0

Sobald ich das letzte Kriterium weg lasse ( Rohdatei!AG:AG;{"<301"."489"."490"."352"} ) geht die Formel richtig. Ich benötige aber die weiteren Kriterien.....

Habe auch schon versuche mit =Summe(Zählenwenns(...... dann bekomme ich zwar ein Ergebnis, aber wenn ich es überprüfe leider nicht das richtige ;-(
Antwortento top
#2
Hallo,

dieser Teil:


Zitat:Rohdatei!AG:AG;{"<301"."489"."490"."352"}

kann mit ZÄHLENWENNS nicht funktionieren. Was willst Du damit überhaupt erreichen???
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#3
Ich habe eine große Datei mit Daten. Aus dieser möchte ich verschiedene Anzahlen und Summen mit diesen Kriterien raussuchen....
Antwortento top
#4
Hallo,

Anrede und Gruß zu jedem Beitrag wären ganz nett! Wir sind hier nicht im Chat!

Was soll dieser Formelteil denn bewirken????
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#5
Hallo Edgar,

sorry, ich bin nur etwas gestresst, weil ich die erforderlichen Daten nicht herbekomme.

Hatte eben probiert diese 300, 489 etc. in einer neuen Spalte mit *1 neu zu schreiben. Ich weiß nicht warum aber mit Summe(zählenwenns..... Formel funktioniert es jetzt.
Die Spalte hatte ich vorher schon versucht mit Zahl, Text, Standard etc. zu formatieren. Hatte keine Änderung ergeben. Die Zahlen *1 zu nehmen hat geklappt ?!?!?

Ich freue mich, dass es geht - bin aber für Verbesserungsvorschläge echt dankbar, da ich das öfter machen muss und bisher immer mit "Hilfstabellen" gearbeitet habe die ich dann addiert habe.
Die Verarbeitung der Daten dauert dann auch dem entsprechend lange und ich kann bei jedem Klick Kaffee trinken gehen.

Danke und Grüße
Antwortento top
#6
Hallo,

wie soll man etwas verbessern, was man nicht kennt????
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#7
Hallo

Ich mache mal den Jockel und werfe DBANZAHL()/DBANZAHL2() in die Runde.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#8
(25.05.2016, 16:53)shift-del schrieb: Hallo

Ich mache mal den Jockel ...

21  17
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
Antwortento top
#9
Hallöchen,

ich nehme an, die Werte der Spalte AG sollen entweder <301 sein oder einer der anderen 3 Werte. Entsprechend musst Du die Zählung wohl einzeln vornehmen und addieren.
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste