Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Werte innerhalb eines Monats zählen
#1
Hallo zusammen,

kennt jemand eine Formel für folgendes Problem:

http://www.bilder-hochladen.tv/pic/ESxG3Ex1/

Beispiel:
Im Monat Januar sind in den Spalten G bis I insgesamt 5 Werte eingetragen.
Excel soll nun automatisch die Zellen zählen in denen etwas steht und die Summe in Spalte K ausgeben. Im Beispiel Januar ist die Zahl 5 auszugeben. Es muss nicht unbedingt ein X sein. Es können beliebige Buchstaben u Ziffern sein und die Anzahl der Ziffern kann auch beliebig lang sein.

Das selbe gilt für die darauffolgenden Monate.

Problem ist, dass voher nicht definiert werden kann, dass z.B Monat Januar Zeile 3-7 ist, denn es können beliebig viele Zeilen in einem Monat stehen.

Ich hoffe,die Frage verständlich geschildert zu haben.

Vielen Dank im Vorraus.
Viele Grüße
to top
#2
Hallo Tumi,

wieso nur 5 Werte für Januar? Ich sehe 6 Werte.

Mit ZÄHLENWENN() kannst Du die Anzahl ermitteln.
Gruß Werner
.. , - ...
to top
#3
hi, meinst du so..: =ZÄHLENWENN(G3:I7;"x*")
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#4
(20.05.2014, 08:44)der neopa schrieb: Hallo Tumi,

wieso nur 5 Werte für Januar? Ich sehe 6 Werte.

Mit ZÄHLENWENN() kannst Du die Anzahl ermitteln.

hi Werner, du siehst 6 werte... wow. ich 5..:

Arbeitsblatt mit dem Namen 'Tabelle3'
 ABCDEFGHIJK
3P12345     x123   5
4P12346     x234x678   
5P12347     x456 x789  
6           
7           

ZelleFormel
K3=ZÄHLENWENN(G3:I7;"x*")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#5
Hi Jockel,

Tumi schrieb:...Es muss nicht unbedingt ein X sein. Es können beliebige Buchstaben u Ziffern sein und die Anzahl der Ziffern kann auch beliebig lang sein...

Hi Tumi,

mal abgesehen davon, dass Dein Tabellenblattaufbau für eine solche Auswertung denkbar ungeeignet ist, würde =ANZAHL2() funktionieren. Allerdings musst Du den auszuwertenden Bereich in jeder Formel manuell anpassen ...

 ABCDEFGHIJKLM
1Jan 13         Anzahl der X im Jan 13  
2      XXX    
3P12345     X123   5  
4P23456     X234X678     
5P56987     X456 X789    
6             
7             
8Feb 13         Anzahl der X im Feb 13  
9      XXX    
10P4567     X098   2  
11P6789       X987    
12             
13             
14Mrz 13         Anzahl der X imMrz 13  
15      XXX    
16P8765      X765  1  

ZelleFormel
K3=ANZAHL2(B3:I7)
K10=ANZAHL2(B10:I13)
K16=ANZAHL2(B16:I19)
to top
#6
hi Kl@us, richtig, wo du recht hast, hast du recht. und: du hast recht...

trotzdem sind es nur 5 werte... 21

außerdem wurde das thema - wie gerade gesehen, auch im CF gepostet...
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#7
Hallo Jörg, hallo Klaus

nachdem ich Brille und Bildschirm geputzt habe, kann ich auch nur noch 5 Einträge zählen.

Allerdings mit ANZAHL2() bin ich immer vorsichtig, weil oftmals in den Daten sich ein = " " oder ="" verstecken kann. Wenn wegen beliebiger Datenstruktur ZÄHLENWENN() nicht ausreicht, nutze ich dann lieber z:B. SUMMENPRODUKT().
Gruß Werner
.. , - ...
to top
#8
Hi Werner,

(20.05.2014, 09:18)der neopa schrieb: Wenn wegen beliebiger Datenstruktur ZÄHLENWENN() nicht ausreicht, nutze ich dann lieber z:B. SUMMENPRODUKT().

oder eine Pivot-Tabelle?
Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top
#9
Hallo,

der Aufbau ist für eine Pivottabelle suboptimal - vor allem auch wenn nach Monaten ausgewertet werden soll.
Gruß
Peter
to top
#10
Hallo zusammen,

vielen Dank für eure Nachrichten.

Leider gibt es momentan keine richtige Formel für mein Problem.

Ich habe hier eine Formel die korrekt ist:
=ANZAHL2(INDEX(Daten!A:A;VERGLEICH(Daten!A18;Daten!A:AWink):INDEX(Daten!A:A;VERGLEICH(Daten!A3;Daten!A:AWink))-2

Diese Formel zählt allerdings nur die Einträge in Spalte A.
Ich brauche eine Formel die mir aber statt nur Spalte A, Spalte G bis I zählt.

VG
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Formel für: Kosten durch die aktuelle Anzahl der Tage des Monats * die Anzahl der ... User255 10 129 18.11.2016, 14:43
Letzter Beitrag: BoskoBiati
Question Anzahl der Einträge in einer Zeile zählen (nicht Zahlen) Olivenbaum2013 6 86 11.11.2016, 10:35
Letzter Beitrag: Olivenbaum2013
  Suchen und Ersetzen innerhalb einer Zelle Nelson 4 104 04.11.2016, 14:16
Letzter Beitrag: Kuwer
Question Zelle mit Text innerhalb eines VBA-Bereiches ermitteln hellidor 3 96 19.10.2016, 14:13
Letzter Beitrag: IchBinIch
  Werte eines Bereiches anzeigen die ungleich einer Vorgabe sind blade22 4 126 16.10.2016, 18:45
Letzter Beitrag: blade22
  Kosten durch die aktuelle Anzahl der Tage des Monats User255 6 223 01.09.2016, 22:18
Letzter Beitrag: User255
  Wie kann man ständig auf Werte eines Feldes zugreifen Lupy 4 265 30.08.2016, 14:21
Letzter Beitrag: Lupy
Star Hyperlinks innerhalb verschiedener Tabellenblätter mentolpaula 7 322 16.08.2016, 08:12
Letzter Beitrag: mentolpaula
  Werte auf kleinste/größte Werte einer anderen Spalte zuordnen MaxiL 2 236 21.07.2016, 10:24
Letzter Beitrag: MaxiL
  Letzter Wert eines Monats heuler 6 383 17.07.2016, 12:44
Letzter Beitrag: snb

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste