Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Spalten nach gleichen Werten sortieren
#1
Hallo Liebe Forenmitglieder,

ich hoffe ihr könnt mir auf meine Frage helfen.

Ich habe meine eigene Excel Tabelle und eine eines Herstellers.

Nun mache ich ein neues excel Fenster auf und kopiere mir meine Artikelnummern in Spalte A.
Diese Spalte A soll weder sortiert noch in der Reihenfolge in der Sie steht geändert werden.

Danach kopiere ich die Artikelnummer und den Bestand der Hersteller Liste in Spalte B und C
B= Artikelnummer Hersteller C= Bestand Hersteller

Soweit so gut, und jetzt stoße ich an meine Excel Grenze.

Nun möchte ich die Spalte B so sortieren, dass es in der Reihenfolge die gleiche
ist wie in Spalte A, wobei der Bestand in Spalte C mit B mitsortiert werden soll.

Es geht darum, dass ich einen Bestand min. 3 mal pro Woche ändern/abgleichen muss, und das bei ca. 1000 Artikeln.
Das heist, nach erfolgreichem Sortieren, kopiere ich den Bestand in Spalte C einfach, und füge Ihn in meine
Originaltabelle und der Bestand ist aktualisiert.

Die Artikelnummern, die nicht in Spalte A vorkommen sollen gelöscht oder ganz unten stehen, denn diese habe ich ja nicht.

So ich hoffe ich hab es einigermaßen vernünftig erklärt und hoffe auf Hilfe Eurerseits.
Anbei noch eine Excel Datei zur besseren Ansicht.

Dank.

Mit freundlichen Grüßen
Christian


Angehängte Dateien
.xlsx   Excel Tabelle.xlsx (Größe: 50,11 KB / Downloads: 10)
to top
#2
Hallo,

das mit der Kopiererei und Sortiererei habe ich nicht verstanden.

Wäre da ein einfacher Sverweis() nicht die Lösung deiner Probleme?

Arbeitsblatt mit dem Namen 'Tabelle1'
 AB
9sollte dann so aussehen. 
10  
11  
12kc1147
13zn1605
14zn2045
15mo95305
16zn3354

ZelleFormel
B12=SVERWEIS(A12;$B$3:$C$7;2;0)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Da der Sverweis auch dateiübergreifend arbeiten kann ist es auch nicht unbedingt notwendig das beide Tabellenblätter in der gleichen Datei stehen.
Gruß
Peter
to top
#3
Hi Peter,

ich lach mich krank..... Jetzt auf die schnelle überprüft DAS STIMMT!!!!
Das nächste 15 geht auf mich.

Vielen Dank
Chris
to top
#4
Hi Peter,

wie geb ich das jetzt ein.
=SVERWEIS(A12;$B$3:$C$7;2;0)

also bei mir =SVERWEIS(A1;Markierung komplett B und C; was bedeutet 2; was bedeutet 0)

Den Anfang versteh ich noch 19

Gruß
Christian
to top
#5
Hi Chirstian,

die 2 bedeutet die zweite Spalte in deiner Matrix B3:C7 (also Spalte C), die 0 ist der 4. Parameter, steht für falsch und verlangt eine genaue Übereinstimmung.

Sieh dir dazu mal die Onlinehilfe zu SVERWEIS an, dort ist die Syntax recht gut erklärt.

Hier findest du ein paar schön ausgearbeitete Erklärungen.
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#6
(10.05.2014, 13:28)chrisp schrieb: Hi Peter,

wie geb ich das jetzt ein.
=SVERWEIS(A12;$B$3:$C$7;2;0)

also bei mir =SVERWEIS(A1;Markierung komplett B und C; was bedeutet 2; was bedeutet 0)

Den Anfang versteh ich noch 19

Gruß
Christian

hi Christian, wo willst du denn deine anfrage behandelt wissen hier oder im CF..?
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#7
Hallo,

(10.05.2014, 13:28)chrisp schrieb: wie geb ich das jetzt ein.
=SVERWEIS(A12;$B$3:$C$7;2;0)

also bei mir =SVERWEIS(A1;Markierung komplett B und C; was bedeutet 2; was bedeutet 0)

=Sverweis(A1;Tabelle2!B:C;2;0)

wobei in diesem Fall davon ausgegangen wird, dass in Tabelle2 die Spalte B durchsucht wird. Bei genauer Übereinstimmung, das ist die 0 als 4. Parameter, wird der Wert aus der zweiten Spalte der Matrix zurückgegeben.

Die Matrix ist definiert durch B:C, d.h. eine 1 würde für die Spalte B und eine 2 für die Spalte C stehen. Beim Sverweis ist es nicht unbedingt notwendig die Matrix auf einen Bereich wie B$1:C$5000 zu beschränken da der Sverweis aufhört zu suchen wenn die erste Übereinstimmung gefunden wird.

Die Hilfe zum Sverweis und die im Beitrag von WillWissen verlinkte Erläuterung sollten dir eigentlich weiterhelfen.

Wenn die Tabelle in einer anderen Datei steht dann würde ich dir vorschlagen beide Dateien zu öffnen, in einer Zelle die Sverweis-Formel einzutragen
Code:
=Sverweis(A1;
und an dieser Stelle einfach in die andere Datei zu wechseln und dort die Spalten B und C zu markieren und die Formel dann mit
Code:
;2;0)
abzuschließen.

Wenn du die Quelldatei dann schließt übernimmt XL automatisch den Pfad und den Namen der Quelldatei. Probier es einfach mal aus - es hört sich schlimmer an als es eigentlich ist.
Gruß
Peter
to top
#8
Hallo Leute,

also hab alles genau eingetragen, jetzt gibts mir aber überall eine 1 ein und nirgends den aktuellen Bestand?
Ist komisch, denn wenn ich den Spaltenindex auf 1 ändere, mir die korrekte Artikelnummer angezeigt wird.

Viele Grüße
Christian
to top
#9
Hallo,

wie sieht denn die von dir verwendete Formel genau aus?

Kannst du einen kleinen Tabellenausschnitt, oder noch besser, eine Beispielsdatei hochladen damit man sich das direkt ansehen kann?
Gruß
Peter
to top
#10
Hallo Peter,

=SVERWEIS(A1;B:C;2;0) genau wie von dir übernommen.

Spalte A ca 900 Artikel, Spalte B ca. 4500 Artikel, Spalte C den Lagerbestand.

Die Formel geb ich in der gleichen Tabelle in Spalte D ein.

Gruß
Christian
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Bestellung/Spalten: nur bestimmte Spalten kopieren teufelchenbs 14 324 25.11.2016, 20:55
Letzter Beitrag: schauan
  Spalte nach Häufigkeit sortieren - INDIREKT zu ineffizient? ak7 10 278 14.11.2016, 15:49
Letzter Beitrag: Jockel
  Nach der Übertragung die Zieltabelle Sortieren DietmarD 21 586 20.10.2016, 21:03
Letzter Beitrag: DietmarD
  Bei gleichen Werten Nachbarzellen kopieren Mikesch 6 137 17.10.2016, 10:31
Letzter Beitrag: Mikesch
  Excel Spalten nach Datum automatisch ausblenden yukie243 2 132 07.10.2016, 08:00
Letzter Beitrag: yukie243
  Spalten nach Tabelle wiederholen McHobi 4 140 07.10.2016, 06:46
Letzter Beitrag: Peter
  Unterschiedliche Anzahl an Messpunkten über gleichen Zeitraum synchronisieren manuel 10 281 03.10.2016, 14:34
Letzter Beitrag: manuel
  Nach zwei Kriterien in zwei Spalten gefilterte Zeilen lückenlos kopieren (oder so) Sommer 2 135 26.09.2016, 12:40
Letzter Beitrag: Sommer
  Sortieren nach Artikel in einem Pfad ModernPixel 2 129 25.09.2016, 07:33
Letzter Beitrag: schauan
  Tabelle durchsuchen nach JA-Werten und Liste daraus erstellen Unicidad 6 133 14.09.2016, 09:17
Letzter Beitrag: steve1da

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste