Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Solldienstplan
#1
Hallo,

Ich möchte einen einfachen Dienstplan schreiben.
Darin sind T wie Tagdienst
N wie Nachtdienst
NR ein spezieller Nachtdienst
X ist Frei
enthalten.

Ich möchte erst mal den Buchstaben eine Zahlenwert zuweisen, So dass
ich dann die Buchstaben in die Tabelle eintrage und die Summe der Stunden
unter Summe der jeweiligen Spalte (AJ) steht.

T = 11 Stunden
N = 11 Stunden
NR = 10,5 Stunden
X = 0 Stunden

Vielen Dank für eure Hilfe
MfG Ben Nevis



http://www.uploadagent.de/show-194557-1399658029.html
to top
#2
Hallo
PHP-Code:
=wenn(Zelle xy=t;11;wenn(Zelle xy=n;11;wenn(Zelle xy=NR;10,5;0))) 
nur so eine Idee
?mage
to top
#3
Hallo,

Also ich habe die Frage leider nicht so ganz verstanden. Soll hinten nur die Gesamtsumme für den Monat gerechnet werden? Das schafft ja z.B. das Summenprodukt. Aber wie gesagt ... ich bin mir noch nicht im klaren, was der TE wünscht.

Gruß
Marcus

Ich arbeite mit Excel 2003!

Wissen ist Macht - es ist aber nicht schlimm nicht alles zu wissen.
Man muss nicht alles wissen - man muss nur wissen wo es steht, oder wo man Hilfe bekommt.


?mage
to top
#4
Hallo,

mach eine Liste in der Art:

Arbeitsblatt mit dem Namen 'Tabelle1'
 AB
1DienstArbeitszeit
2T11
3N11
4NR10,5
5X0
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

dann kannst du die zugehörigen Zeiten per SVERWEIS() eintragen lassen.
Damit das Ganze stimmig wird, sollte noch eine Fehlerabfrage drumherum eingearbeitet werden:

z.B:

Arbeitsblatt mit dem Namen 'Sollplanung'
 D
41.
5T
6 
711

ZelleFormel
D7=WENN(ZÄHLENWENN(Tabelle1!$A$2:$A$5;Sollplanung!D5);SVERWEIS(Sollplanung!D5;Tabelle1!$A$2:$B$5;2;0);"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß Atilla

Excel 2007
to top
#5
Hi,
es soll dann bei Summe die Stundenzahl der Arbeitszeit stehen.

Gruß Mario
to top
#6
Hallo,

oder meinst Du so:

Arbeitsblatt mit dem Namen 'Sollplanung'
 DEFGHIJKLMNOPQRSTUVWXYZAAABACADAEAFAGAHAIAJ
5TTTNNNRXXX                       55
6                                 

ZelleFormel
AJ5=SUMMENPRODUKT((D5:AH5=Tabelle1!$A$2:$A$5)*Tabelle1!$B$2:$B$5)
AJ6=SUMMENPRODUKT((D6:AH6=Tabelle1!$A$2:$A$5)*Tabelle1!$B$2:$B$5)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Auch hier ist eine Liste in Tabelle2 aufgebaut, wie vorhin dargestellt.
Gruß Atilla

Excel 2007
to top
#7
Hallo Atilla,

hier gibt es kleines Problem. Nachschicht = "N" und es gibt "NR"! Es wird nicht richtig gerechnet. Wäre ds "NR" ein "K" oder ein "S" würde die Formel richtig rechnen. Dieses "N" in NR stört!

Gruß
Marcus

Ich arbeite mit Excel 2003!

Wissen ist Macht - es ist aber nicht schlimm nicht alles zu wissen.
Man muss nicht alles wissen - man muss nur wissen wo es steht, oder wo man Hilfe bekommt.


?mage
to top
#8
Hi, und wenn es N1 wäre?

Gruß Mario
to top
#9
Hallo Ben,
das selbe Problem. Das N! stört!

Gruß
Marcus

Ich arbeite mit Excel 2003!

Wissen ist Macht - es ist aber nicht schlimm nicht alles zu wissen.
Man muss nicht alles wissen - man muss nur wissen wo es steht, oder wo man Hilfe bekommt.


?mage
to top
#10
Hallo Marcus,

ok
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste