Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


[Excel] Daten eines bestimmten Kunden in anderes Tabellenblatt kopieren
#1
Hallo,

angenommen die Ausgangstabelle sieht wie folgt aus

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABC
1KundeRgNrSumme
2A1100
3B2200
4C3300
5A4400
6A5500
7B6600
8C7700
9D8800
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Jetzt sollen die Werte des Kunden A in einem separaten Tabellenblatt aufgelistet werden.

Eine Möglichkeit diese Aufgabenstellung ohne Matrixformeln (mit einer zusätzlichen Hilfsspalte) zu lösen könnte so aussehen:

Arbeitsblatt mit dem Namen 'Tabelle2'
 ABCDEFG
1 KundeRgNrSumme KundeA
22A1100   
35A4400   
46A5500   
5#NV#NV#NV#NV   

ZelleFormel
A2=VERGLEICH($G$1;Tabelle1!$A$9:INDEX(Tabelle1!A:A;A1+1);)+A1
B2=INDEX(Tabelle1!A:A;$A2)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Die Formel in A2 wird soweit nach unten kopiert bis die Fehlermeldung #NV erscheint, die Formel in B2 wird nach rechts und nach unten kopiert.

Wenn die Fehlermeldung #NV stört dann könnte man auch beide Formeln mit Wennfehler verbinden:

A2: =WENNFEHLER(VERGLEICH($G$1;Tabelle1!$A$9:INDEX(Tabelle1!A:A;A1+1);)+A1;"")
B2: =WENNFEHLER(INDEX(Tabelle1!A:A;$A2);"")
Gruß
Peter
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  [Excel] Teile eines Arrays können nicht geändert werden WillWissen 0 8.483 11.07.2014, 18:47
Letzter Beitrag: WillWissen
  [Excel] Schnelles Kopieren von Arbeitsblättern WillWissen 0 940 02.06.2014, 07:03
Letzter Beitrag: WillWissen
  [Excel] Animierte *.gif-Dateien im Tabellenblatt anzeigen Kl@us-M. 0 3.908 20.05.2014, 10:03
Letzter Beitrag: Kl@us-M.
  [Excel] Balken"diagramme" im Tabellenblatt Kl@us-M. 0 1.049 14.05.2014, 08:58
Letzter Beitrag: Kl@us-M.
  [Excel] Tabellenblattbereich als Grafik in Zwischenablage kopieren Kl@us-M. 0 822 13.05.2014, 09:33
Letzter Beitrag: Kl@us-M.
  [Excel] Zeile aus Tabellenblatt kopieren Peter 0 971 16.04.2014, 09:13
Letzter Beitrag: Peter

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste