Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Negativwert (Fehlwert) addieren zu neuen Tagsbetrag
#1
Hallo mitnander
>zuerst verschiedenste Abschnitt aus einem alten Thread< [Trennlinie = neuer Text]


.xlsx   fehlbetrag01.xlsx (Größe: 9,83 KB / Downloads: 6)

eine Liste von Spielen beinhaltet
-Anz. Spiele
-Betrag pro Sp.
-gewonnen & verloren
-Höhe des zu zahlenden Betrages alle
-zum einen Gezahlt - Fehlbetrag - Spenden

nur wie den Fehlbetrag in die eigens kreierte kriegen, um das der Teiln. beim nächsten mal den Restbetrag mit zu den neu zu bezahlenden Betrag addiert bekommt.
---------------
wenn der Zahlende weniger als gefordert bezahlt,
sollte der Fehlbetrag im Feld Fehlbetrag gelistet werden
Wenn der Zahlende mehr bezahlt sollte der Betrag in der Spalte Spende auftauchen
Wie verhindern das der Betrag zweimal gelistet wird einmal als Minusbetrag (Fehlbetrag) und dann als Plusbetrag (Spende)
Die Negativzahl soll bei zuviel gezahlt nicht auftauchen
---------------
Der Fehlbetrag erscheint nun bei der addition zum nächsten Abend als Minuswert.

gleicher Aufbau nur 10 Zeilen tiefer
nehm ich mal Zelle F14 =B14+K4 gleiche Tab
hier sollte nun Startgeld F14 + Fehlbetrag K4 eine Summe von 4€ ergeben, aber es sind nur 2€
Wie den Negativwert K4 als Positivwert hinbiegen??

Edit: Bei weiterer Zugabe von Abenden fällt immer wieder der Summenwert (#Wert) auf, was ist verkehrt
in Spalte F sofern Fehlbetrag leer???
---------------
Wie richtig in die erneute Summenrechnung bringen, so das nicht subtrahiert wird sondern der zu zahlende sich um den Fehlbetrag vom vorigen Abend erhöht??
---------------
Mein Gedanke, eventuelle Lösung:

=SUMME(B14-WENN(K4<0;K4;0))

Wäre das so korrekt?

Kann wer helfen

Gruß Frank
?mage
to top
#2
Hallo Frank,

=SUMME(B14;ABS(K4))

Gruß Uwe
to top
#3
hi, ich verstehe nur bahnhof, aber was auffällt: SUMME() tritt inflationär auf... und wenn bei ber sonst_Bedingung "" erscheint ist damit immer schwerer zu weiter zu rechnen als mit 0 (das kann man ja "wegzaubern", wenn's stören sollte...
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#4
(01.05.2014, 21:35)Kuwer schrieb: Hallo Frank,

=SUMME(B14;ABS(K4))

Gruß Uwe

Hallo, läuft bei leeren Zellen in einen Fehler, bitte probieren.

Dank für Hinweis
?mage
to top
#5
(01.05.2014, 21:35)Kuwer schrieb: Hallo Frank,

=SUMME(B14;ABS(K4))

Gruß Uwe

hi Uwe, es geht auch ohne SUMME()... =B14-(K4<0)*K4
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#6
Hallo Frank,

(01.05.2014, 21:22)WergibtmirRat schrieb: Edit: Bei weiterer Zugabe von Abenden fällt immer wieder der Summenwert (#Wert) auf, was ist verkehrt
in Spalte F sofern Fehlbetrag leer???
---------------
Wie richtig in die erneute Summenrechnung bringen, so das nicht subtrahiert wird sondern der zu zahlende sich um den Fehlbetrag vom vorigen Abend erhöht??
---------------
Mein Gedanke, eventuelle Lösung:

=SUMME(B14-WENN(K4<0;K4;0))

Wäre das so korrekt?

Ich würde es so machen:

Tabelle1
ABCDEFGHIJKL
10,20,5 Summe
2 Startbetrag bespielt verloren zu zahlen Gezahlt Fehlbetrag Spende
3 Runden
4 T_1 35231154-10
5 T_2 353311,55,5600,5
6
7 T_1 35231164-20
8 T_2 353311,55,5600,5
9
Schriftart wird in dieser Tabelle nicht dargestellt

 verbundene Zellen
I1:L1
C3: D3
A6:L6
A9:L9

verwendete Formeln
Zelle Formel Bereich N/A
I4:I5=F4+G4+H4
F4:F5,F7:F8=B4
G4:G5,G7:G8=$C$1*C4
H4:H5,H7:H8=D4*$D$1
I7:I8=F7+G7+H7+ABS(K4)
K4:K5,K7:K8=WENN(J4<I4;J4-I4;0)
L4:L5,L7:L8=WENN(J4>I4;J4-I4;0)
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 17.12 einschl. 64 Bit


.xlsx   fehlbetrag.xlsx (Größe: 9,44 KB / Downloads: 2)
Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top
#7
(01.05.2014, 21:38)WergibtmirRat schrieb:
(01.05.2014, 21:35)Kuwer schrieb: Hallo Frank,

=SUMME(B14;ABS(K4))

Gruß Uwe

Hallo, läuft bei leeren Zellen in einen Fehler, bitte probieren.

Dank für Hinweis

dazu hatte ich ja auch was geschrieben... ...ausserdem geht in K4 auch =(J4auch ohne SUMME() und ohne WENN()...
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#8
Hallo Frank,

Hallo, läuft bei leeren Zellen in einen Fehler, bitte probieren.

Kann ich nicht nachvollziehen. Ich vermute mal,
dass Du Leerzellen mit der Leertaste erzeugst,
nur sind die dann nicht leer sondern enthalten eben ein Leerzeichen.

Gruß Uwe
to top
#9
(01.05.2014, 21:39)Jockel schrieb: =B14-(K4<0)*K4
es funktioniert. Danke

@Ralf
@Uwe
auch dir Dank

Dankeuch der schnellen fachlich versierten Hilfe ohne Schmuh und Hochnas' 19
?mage
to top
#10
Hallo Frank,

fairerweise solltest Du im anderen Forum mitteilen, dass Dir hier weiter geholfen wird.
Am besten Du stellst einen Link zu diesem Beitrag, dann können die Helfer dort sehen,
welche Lösungsvorschläge Du erhalten hast.

Das solltest Du auch deswegen machen, weil dort Crossposting nicht gern gesehen wird. 05
Gruß Atilla

Excel 2007
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Zellen prüfen und dann addieren h76469 1 52 05.11.2016, 08:53
Letzter Beitrag: WillWissen
  Jede n-te Zelle Wert um 1 addieren McAnimate 5 90 24.10.2016, 09:37
Letzter Beitrag: WillWissen
  Zahlen in der selben Zelle addieren Rudi12345 13 322 08.10.2016, 10:46
Letzter Beitrag: XOR LX
  Zellen kopieren in neuen Blatt KS20 5 226 01.10.2016, 19:05
Letzter Beitrag: WillWissen
  Diagramme übernehmen mit neuen Daten magnexx 9 380 17.08.2016, 19:44
Letzter Beitrag: magnexx
  addieren, subtrahieren, multiplizieren pariser 5 341 08.07.2016, 06:35
Letzter Beitrag: Rabe
Sad neg. und pos. Werte in Excel addieren und subtrahieren Doosie 7 594 01.05.2016, 17:45
Letzter Beitrag: Castor
Lightbulb Bereich zwischen 2 Sverweisen addieren Merte90 9 601 30.04.2016, 12:30
Letzter Beitrag: GMG-CC
  Werteingabe eines Feldes Tag für Tag in einer neuen Zeile speichern JohnCamus 14 861 19.04.2016, 11:22
Letzter Beitrag: Rabe
  Excel - Summen bestimmter Jahreszahl addieren InaWUSF 2 367 12.04.2016, 17:21
Letzter Beitrag: GMG-CC

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste