Feiertag auf Sonntag vor Sonntag zählen
#1
Hallo miteinander,
da bin ich wieder und benötige Eure Hilfe.
Wie muss die Formel abgeändert oder erweitert werden, dammit wenn ein Feiertag(FT) der auf einen Sonntag fällt(Ostersonntag) die Stunden zu den Feiertagssummen gezählt wird und nicht zu den Sonntagssummen.
April

FGHIJKLMNOPQRSTUVWXYZAAABACADAEAFAGAHAIAJAK
1KarfreitagOstersonntagOstermontag16. KW17. KW18. KW
2FrSaSoMoDiMiDoFrSaSoMoDiMiDoFrSaSoMoDiMiDoFrSaSoMoDiMiDoArbeits-
Stunden
Sonntags
stunden
Feiertags-
stunden
303040506070809101112131415161718192021222324252627282930
4222222222222222666
Formeln der Tabelle
ZelleFormel
F1=WENN(ISTFEHLER(FINDEN(F3;Feiertagsliste));WENN(WOCHENTAG(F3;2)=1;KÜRZEN((F3-WOCHENTAG(F3;2)-DATUM(JAHR(F3+4-WOCHENTAG(F3;2));1;-10))/7); "" );WVERWEIS(F3;Berechnen_der_Feiertage;2;WAHR))
G1=WENN(ISTFEHLER(FINDEN(G3;Feiertagsliste));WENN(WOCHENTAG(G3;2)=1;KÜRZEN((G3-WOCHENTAG(G3;2)-DATUM(JAHR(G3+4-WOCHENTAG(G3;2));1;-10))/7); "" );WVERWEIS(G3;Berechnen_der_Feiertage;2;WAHR))
H1=WENN(ISTFEHLER(FINDEN(H3;Feiertagsliste));WENN(WOCHENTAG(H3;2)=1;KÜRZEN((H3-WOCHENTAG(H3;2)-DATUM(JAHR(H3+4-WOCHENTAG(H3;2));1;-10))/7); "" );WVERWEIS(H3;Berechnen_der_Feiertage;2;WAHR))
I1=WENN(ISTFEHLER(FINDEN(I3;Feiertagsliste));WENN(WOCHENTAG(I3;2)=1;KÜRZEN((I3-WOCHENTAG(I3;2)-DATUM(JAHR(I3+4-WOCHENTAG(I3;2));1;-10))/7); "" );WVERWEIS(I3;Berechnen_der_Feiertage;2;WAHR))
J1=WENN(ISTFEHLER(FINDEN(J3;Feiertagsliste));WENN(WOCHENTAG(J3;2)=1;KÜRZEN((J3-WOCHENTAG(J3;2)-DATUM(JAHR(J3+4-WOCHENTAG(J3;2));1;-10))/7); "" );WVERWEIS(J3;Berechnen_der_Feiertage;2;WAHR))
K1=WENN(ISTFEHLER(FINDEN(K3;Feiertagsliste));WENN(WOCHENTAG(K3;2)=1;KÜRZEN((K3-WOCHENTAG(K3;2)-DATUM(JAHR(K3+4-WOCHENTAG(K3;2));1;-10))/7); "" );WVERWEIS(K3;Berechnen_der_Feiertage;2;WAHR))
L1=WENN(ISTFEHLER(FINDEN(L3;Feiertagsliste));WENN(WOCHENTAG(L3;2)=1;KÜRZEN((L3-WOCHENTAG(L3;2)-DATUM(JAHR(L3+4-WOCHENTAG(L3;2));1;-10))/7); "" );WVERWEIS(L3;Berechnen_der_Feiertage;2;WAHR))
M1=WENN(ISTFEHLER(FINDEN(M3;Feiertagsliste));WENN(WOCHENTAG(M3;2)=1;KÜRZEN((M3-WOCHENTAG(M3;2)-DATUM(JAHR(M3+4-WOCHENTAG(M3;2));1;-10))/7); "" );WVERWEIS(M3;Berechnen_der_Feiertage;2;WAHR))
N1=WENN(ISTFEHLER(FINDEN(N3;Feiertagsliste));WENN(WOCHENTAG(N3;2)=1;KÜRZEN((N3-WOCHENTAG(N3;2)-DATUM(JAHR(N3+4-WOCHENTAG(N3;2));1;-10))/7); "" );WVERWEIS(N3;Berechnen_der_Feiertage;2;WAHR))
O1=WENN(ISTFEHLER(FINDEN(O3;Feiertagsliste));WENN(WOCHENTAG(O3;2)=1;KÜRZEN((O3-WOCHENTAG(O3;2)-DATUM(JAHR(O3+4-WOCHENTAG(O3;2));1;-10))/7); "" );WVERWEIS(O3;Berechnen_der_Feiertage;2;WAHR))
P1=WENN(ISTFEHLER(FINDEN(P3;Feiertagsliste));WENN(WOCHENTAG(P3;2)=1;KÜRZEN((P3-WOCHENTAG(P3;2)-DATUM(JAHR(P3+4-WOCHENTAG(P3;2));1;-10))/7); "" );WVERWEIS(P3;Berechnen_der_Feiertage;2;WAHR))
Q1=WENN(ISTFEHLER(FINDEN(Q3;Feiertagsliste));WENN(WOCHENTAG(Q3;2)=1;KÜRZEN((Q3-WOCHENTAG(Q3;2)-DATUM(JAHR(Q3+4-WOCHENTAG(Q3;2));1;-10))/7); "" );WVERWEIS(Q3;Berechnen_der_Feiertage;2;WAHR))
R1=WENN(ISTFEHLER(FINDEN(R3;Feiertagsliste));WENN(WOCHENTAG(R3;2)=1;KÜRZEN((R3-WOCHENTAG(R3;2)-DATUM(JAHR(R3+4-WOCHENTAG(R3;2));1;-10))/7); "" );WVERWEIS(R3;Berechnen_der_Feiertage;2;WAHR))
S1=WENN(ISTFEHLER(FINDEN(S3;Feiertagsliste));WENN(WOCHENTAG(S3;2)=1;KÜRZEN((S3-WOCHENTAG(S3;2)-DATUM(JAHR(S3+4-WOCHENTAG(S3;2));1;-10))/7); "" );WVERWEIS(S3;Berechnen_der_Feiertage;2;WAHR))
T1=WENN(ISTFEHLER(FINDEN(T3;Feiertagsliste));WENN(WOCHENTAG(T3;2)=1;KÜRZEN((T3-WOCHENTAG(T3;2)-DATUM(JAHR(T3+4-WOCHENTAG(T3;2));1;-10))/7); "" );WVERWEIS(T3;Berechnen_der_Feiertage;2;WAHR))
U1=WENN(ISTFEHLER(FINDEN(U3;Feiertagsliste));WENN(WOCHENTAG(U3;2)=1;KÜRZEN((U3-WOCHENTAG(U3;2)-DATUM(JAHR(U3+4-WOCHENTAG(U3;2));1;-10))/7); "" );WVERWEIS(U3;Berechnen_der_Feiertage;2;WAHR))
V1=WENN(ISTFEHLER(FINDEN(V3;Feiertagsliste));WENN(WOCHENTAG(V3;2)=1;KÜRZEN((V3-WOCHENTAG(V3;2)-DATUM(JAHR(V3+4-WOCHENTAG(V3;2));1;-10))/7); "" );WVERWEIS(V3;Berechnen_der_Feiertage;2;WAHR))
W1=WENN(ISTFEHLER(FINDEN(W3;Feiertagsliste));WENN(WOCHENTAG(W3;2)=1;KÜRZEN((W3-WOCHENTAG(W3;2)-DATUM(JAHR(W3+4-WOCHENTAG(W3;2));1;-10))/7); "" );WVERWEIS(W3;Berechnen_der_Feiertage;2;WAHR))
X1=WENN(ISTFEHLER(FINDEN(X3;Feiertagsliste));WENN(WOCHENTAG(X3;2)=1;KÜRZEN((X3-WOCHENTAG(X3;2)-DATUM(JAHR(X3+4-WOCHENTAG(X3;2));1;-10))/7); "" );WVERWEIS(X3;Berechnen_der_Feiertage;2;WAHR))
Y1=WENN(ISTFEHLER(FINDEN(Y3;Feiertagsliste));WENN(WOCHENTAG(Y3;2)=1;KÜRZEN((Y3-WOCHENTAG(Y3;2)-DATUM(JAHR(Y3+4-WOCHENTAG(Y3;2));1;-10))/7); "" );WVERWEIS(Y3;Berechnen_der_Feiertage;2;WAHR))
Z1=WENN(ISTFEHLER(FINDEN(Z3;Feiertagsliste));WENN(WOCHENTAG(Z3;2)=1;KÜRZEN((Z3-WOCHENTAG(Z3;2)-DATUM(JAHR(Z3+4-WOCHENTAG(Z3;2));1;-10))/7); "" );WVERWEIS(Z3;Berechnen_der_Feiertage;2;WAHR))
AA1=WENN(ISTFEHLER(FINDEN(AA3;Feiertagsliste));WENN(WOCHENTAG(AA3;2)=1;KÜRZEN((AA3-WOCHENTAG(AA3;2)-DATUM(JAHR(AA3+4-WOCHENTAG(AA3;2));1;-10))/7); "" );WVERWEIS(AA3;Berechnen_der_Feiertage;2;WAHR))
AB1=WENN(ISTFEHLER(FINDEN(AB3;Feiertagsliste));WENN(WOCHENTAG(AB3;2)=1;KÜRZEN((AB3-WOCHENTAG(AB3;2)-DATUM(JAHR(AB3+4-WOCHENTAG(AB3;2));1;-10))/7); "" );WVERWEIS(AB3;Berechnen_der_Feiertage;2;WAHR))
AC1=WENN(ISTFEHLER(FINDEN(AC3;Feiertagsliste));WENN(WOCHENTAG(AC3;2)=1;KÜRZEN((AC3-WOCHENTAG(AC3;2)-DATUM(JAHR(AC3+4-WOCHENTAG(AC3;2));1;-10))/7); "" );WVERWEIS(AC3;Berechnen_der_Feiertage;2;WAHR))
AD1=WENN(ISTFEHLER(FINDEN(AD3;Feiertagsliste));WENN(WOCHENTAG(AD3;2)=1;KÜRZEN((AD3-WOCHENTAG(AD3;2)-DATUM(JAHR(AD3+4-WOCHENTAG(AD3;2));1;-10))/7); "" );WVERWEIS(AD3;Berechnen_der_Feiertage;2;WAHR))
AE1=WENN(ISTFEHLER(FINDEN(AE3;Feiertagsliste));WENN(WOCHENTAG(AE3;2)=1;KÜRZEN((AE3-WOCHENTAG(AE3;2)-DATUM(JAHR(AE3+4-WOCHENTAG(AE3;2));1;-10))/7); "" );WVERWEIS(AE3;Berechnen_der_Feiertage;2;WAHR))
AF1=WENN(AF3="";"";WENN(ISTFEHLER(FINDEN(AF3;Feiertagsliste));WENN(WOCHENTAG(AF3;2)=1;KÜRZEN((AF3-WOCHENTAG(AF3;2)-DATUM(JAHR(AF3+4-WOCHENTAG(AF3;2));1;-10))/7); "" );WVERWEIS(AF3;Berechnen_der_Feiertage;2;WAHR)))
AG1=WENN(AG3="";"";WENN(ISTFEHLER(FINDEN(AG3;Feiertagsliste));WENN(WOCHENTAG(AG3;2)=1;KÜRZEN((AG3-WOCHENTAG(AG3;2)-DATUM(JAHR(AG3+4-WOCHENTAG(AG3;2));1;-10))/7); "" );WVERWEIS(AG3;Berechnen_der_Feiertage;2;WAHR)))
AH1=WENN(AH3="";"";WENN(ISTFEHLER(FINDEN(AH3;Feiertagsliste));WENN(WOCHENTAG(AH3;2)=1;KÜRZEN((AH3-WOCHENTAG(AH3;2)-DATUM(JAHR(AH3+4-WOCHENTAG(AH3;2));1;-10))/7); "" );WVERWEIS(AH3;Berechnen_der_Feiertage;2;WAHR)))
F2=F3
G2=G3
H2=H3
I2=I3
J2=J3
K2=K3
L2=L3
M2=M3
N2=N3
O2=O3
P2=P3
Q2=Q3
R2=R3
S2=S3
T2=T3
U2=U3
V2=V3
W2=W3
X2=X3
Y2=Y3
Z2=Z3
AA2=AA3
AB2=AB3
AC2=AC3
AD2=AD3
AE2=AE3
AF2=AF3
AG2=AG3
AH2=AH3
F3=E3+1
G3=F3+1
H3=G3+1
I3=H3+1
J3=I3+1
K3=J3+1
L3=K3+1
M3=L3+1
N3=M3+1
O3=N3+1
P3=O3+1
Q3=P3+1
R3=Q3+1
S3=R3+1
T3=S3+1
U3=T3+1
V3=U3+1
W3=V3+1
X3=W3+1
Y3=X3+1
Z3=Y3+1
AA3=Z3+1
AB3=AA3+1
AC3=AB3+1
AD3=AC3+1
AE3=AD3+1
AF3=WENN(AE3>=DATUM(JAHR($B$3);MONAT($B$3)+1;TAG($B$3))-1;"";WENN(AE3=0;0;AE3+1))
AG3=WENN(AF3>=DATUM(JAHR($B$3);MONAT($B$3)+1;TAG($B$3))-1;"";WENN(AF3=0;0;AF3+1))
AH3=WENN(AG3>=DATUM(JAHR($B$3);MONAT($B$3)+1;TAG($B$3))-1;"";WENN(AG3=0;0;AG3+1))
AI4=SUMME(D4:AG4)-AJ4
AJ4=SUMMENPRODUKT((REST($D$2:$AG$2;7)=1)*1;D4:AG4)
AK4=SUMMENPRODUKT(($D$47:$AH$47=1)*1;$D4:$AH4)
Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
F21. / Formel ist = WOCHENTAG(D2;2) > 5Abc
G21. / Formel ist = WOCHENTAG(D2;2) > 5Abc
H21. / Formel ist = WOCHENTAG(D2;2) > 5Abc
I21. / Formel ist = WOCHENTAG(D2;2) > 5Abc
J21. / Formel ist = WOCHENTAG(D2;2) > 5Abc
K21. / Formel ist = WOCHENTAG(D2;2) > 5Abc
L21. / Formel ist = WOCHENTAG(D2;2) > 5Abc
M21. / Formel ist = WOCHENTAG(D2;2) > 5Abc
N21. / Formel ist = WOCHENTAG(D2;2) > 5Abc
O21. / Formel ist = WOCHENTAG(D2;2) > 5Abc
P21. / Formel ist = WOCHENTAG(D2;2) > 5Abc
Q21. / Formel ist = WOCHENTAG(D2;2) > 5Abc
R21. / Formel ist = WOCHENTAG(D2;2) > 5Abc
S21. / Formel ist = WOCHENTAG(D2;2) > 5Abc
T21. / Formel ist = WOCHENTAG(D2;2) > 5Abc
U21. / Formel ist = WOCHENTAG(D2;2) > 5Abc
V21. / Formel ist = WOCHENTAG(D2;2) > 5Abc
W21. / Formel ist = WOCHENTAG(D2;2) > 5Abc
X21. / Formel ist = WOCHENTAG(D2;2) > 5Abc
Y21. / Formel ist = WOCHENTAG(D2;2) > 5Abc
Z21. / Formel ist = WOCHENTAG(D2;2) > 5Abc
AA21. / Formel ist = WOCHENTAG(D2;2) > 5Abc
AB21. / Formel ist = WOCHENTAG(D2;2) > 5Abc
AC21. / Formel ist = WOCHENTAG(D2;2) > 5Abc
AD21. / Formel ist = WOCHENTAG(D2;2) > 5Abc
AE21. / Formel ist = WOCHENTAG(D2;2) > 5Abc
AF21. / Formel ist = WOCHENTAG(D2;2) > 5Abc
AG21. / Formel ist = WOCHENTAG(D2;2) > 5Abc
AH21. / Formel ist = WOCHENTAG(D2;2) > 5Abc
F31. / Formel ist = WOCHENTAG(D2;2) > 5Abc
G31. / Formel ist = WOCHENTAG(D2;2) > 5Abc
H31. / Formel ist = WOCHENTAG(D2;2) > 5Abc
I31. / Formel ist = WOCHENTAG(D2;2) > 5Abc
J31. / Formel ist = WOCHENTAG(D2;2) > 5Abc
K31. / Formel ist = WOCHENTAG(D2;2) > 5Abc
L31. / Formel ist = WOCHENTAG(D2;2) > 5Abc
M31. / Formel ist = WOCHENTAG(D2;2) > 5Abc
N31. / Formel ist = WOCHENTAG(D2;2) > 5Abc
O31. / Formel ist = WOCHENTAG(D2;2) > 5Abc
P31. / Formel ist = WOCHENTAG(D2;2) > 5Abc
Q31. / Formel ist = WOCHENTAG(D2;2) > 5Abc
R31. / Formel ist = WOCHENTAG(D2;2) > 5Abc
S31. / Formel ist = WOCHENTAG(D2;2) > 5Abc
T31. / Formel ist = WOCHENTAG(D2;2) > 5Abc
U31. / Formel ist = WOCHENTAG(D2;2) > 5Abc
V31. / Formel ist = WOCHENTAG(D2;2) > 5Abc
W31. / Formel ist = WOCHENTAG(D2;2) > 5Abc
X31. / Formel ist = WOCHENTAG(D2;2) > 5Abc
Y31. / Formel ist = WOCHENTAG(D2;2) > 5Abc
Z31. / Formel ist = WOCHENTAG(D2;2) > 5Abc
AA31. / Formel ist = WOCHENTAG(D2;2) > 5Abc
AB31. / Formel ist = WOCHENTAG(D2;2) > 5Abc
AC31. / Formel ist = WOCHENTAG(D2;2) > 5Abc
AD31. / Formel ist = WOCHENTAG(D2;2) > 5Abc
AE31. / Formel ist = WOCHENTAG(D2;2) > 5Abc
AF31. / Formel ist = WOCHENTAG(D2;2) > 5Abc
AG31. / Formel ist = WOCHENTAG(D2;2) > 5Abc
AH31. / Formel ist = WOCHENTAG(D2;2) > 5Abc
F41. / Formel ist =ODER(WOCHENTAG(D$3;2)=7;WOCHENTAG(D$3;2)=6)Abc
G41. / Formel ist =ODER(WOCHENTAG(D$3;2)=7;WOCHENTAG(D$3;2)=6)Abc
H41. / Formel ist =ODER(WOCHENTAG(D$3;2)=7;WOCHENTAG(D$3;2)=6)Abc
I41. / Formel ist =ODER(WOCHENTAG(D$3;2)=7;WOCHENTAG(D$3;2)=6)Abc
J41. / Formel ist =ODER(WOCHENTAG(D$3;2)=7;WOCHENTAG(D$3;2)=6)Abc
K41. / Formel ist =ODER(WOCHENTAG(D$3;2)=7;WOCHENTAG(D$3;2)=6)Abc
L41. / Formel ist =ODER(WOCHENTAG(D$3;2)=7;WOCHENTAG(D$3;2)=6)Abc
M41. / Formel ist =ODER(WOCHENTAG(D$3;2)=7;WOCHENTAG(D$3;2)=6)Abc
N41. / Formel ist =ODER(WOCHENTAG(D$3;2)=7;WOCHENTAG(D$3;2)=6)Abc
O41. / Formel ist =ODER(WOCHENTAG(D$3;2)=7;WOCHENTAG(D$3;2)=6)Abc
P41. / Formel ist =ODER(WOCHENTAG(D$3;2)=7;WOCHENTAG(D$3;2)=6)Abc
Q41. / Formel ist =ODER(WOCHENTAG(D$3;2)=7;WOCHENTAG(D$3;2)=6)Abc
R41. / Formel ist =ODER(WOCHENTAG(D$3;2)=7;WOCHENTAG(D$3;2)=6)Abc
S41. / Formel ist =ODER(WOCHENTAG(D$3;2)=7;WOCHENTAG(D$3;2)=6)Abc
T41. / Formel ist =ODER(WOCHENTAG(D$3;2)=7;WOCHENTAG(D$3;2)=6)Abc
U41. / Formel ist =ODER(WOCHENTAG(D$3;2)=7;WOCHENTAG(D$3;2)=6)Abc
V41. / Formel ist =ODER(WOCHENTAG(D$3;2)=7;WOCHENTAG(D$3;2)=6)Abc
W41. / Formel ist =ODER(WOCHENTAG(D$3;2)=7;WOCHENTAG(D$3;2)=6)Abc
X41. / Formel ist =ODER(WOCHENTAG(D$3;2)=7;WOCHENTAG(D$3;2)=6)Abc
Y41. / Formel ist =ODER(WOCHENTAG(D$3;2)=7;WOCHENTAG(D$3;2)=6)Abc
Z41. / Formel ist =ODER(WOCHENTAG(D$3;2)=7;WOCHENTAG(D$3;2)=6)Abc
AA41. / Formel ist =ODER(WOCHENTAG(D$3;2)=7;WOCHENTAG(D$3;2)=6)Abc
AB41. / Formel ist =ODER(WOCHENTAG(D$3;2)=7;WOCHENTAG(D$3;2)=6)Abc
AC41. / Formel ist =ODER(WOCHENTAG(D$3;2)=7;WOCHENTAG(D$3;2)=6)Abc
AD41. / Formel ist =ODER(WOCHENTAG(D$3;2)=7;WOCHENTAG(D$3;2)=6)Abc
AE41. / Formel ist =ODER(WOCHENTAG(D$3;2)=7;WOCHENTAG(D$3;2)=6)Abc
AF41. / Formel ist =ODER(WOCHENTAG(D$3;2)=7;WOCHENTAG(D$3;2)=6)Abc
AG41. / Formel ist =ODER(WOCHENTAG(D$3;2)=7;WOCHENTAG(D$3;2)=6)Abc
AH41. / Formel ist =ODER(WOCHENTAG(D$3;2)=7;WOCHENTAG(D$3;2)=6)Abc

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Ich häng auch mal die Datei an.
Schon jetzt ganz viel Dank für Eure HIlfe.


Angehängte Dateien
.xlsm   Freier Dienstplan.xlsm (Größe: 115,16 KB / Downloads: 8)
freundlich grüßt
R@1ner

Excel 2013
to top
#2
Hallo,

1. muß man nicht die ganzen Formeln und Formatierungen darstellen, das reicht für eine Zelle pro Formel!
2. Ist es unsinnig eine Passwort-geschützte Datei einzustellen!
3. Ist es völlig daneben eine Feiertagsliste zu erstellen, wie Du es gemacht hast!
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#3
Hallo R@1ner, ich gebe Edgar in allen Punkten recht, das mit der Feiertagsliste hatte ich auch schon mal erwähnt, die geht gar nicht; das tut den Augen weh. Aber egal, ich habe mir deine "alte" Version angesehen, und hätte ff. Vorschlag..:

Arbeitsblatt mit dem Namen 'März'
ABACADAEAFAGAHAIAJAK
1Karfreitag OstersonntagOstermontag
2FrSaSoMoDiMiDoArbeits-

Stunden
Sonntags
stunden
Feiertags-
stunden
325262728293031
4 2 223252
5 22284

ZelleFormel
AJ4=SUMMENPRODUKT((REST($D$2:$AH$2;7)=1)*1;D4:AH4)-SUMMENPRODUKT((REST($D$2:$AH$2;7)=1)*(D47:AH47=1);D4:AH4)
AK4=SUMMENPRODUKT(($D$47:$AH$47=1)*1;$D4:$AH4)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#4
(19.05.2015, 12:45)Jockel schrieb: Hallo R@1ner, ich gebe Edgar in allen Punkten recht, das mit der Feiertagsliste hatte ich auch schon mal erwähnt, die geht gar nicht; das tut den Augen weh. Aber egal, ich habe mir deine "alte" Version angesehen, und hätte ff. Vorschlag..:

Arbeitsblatt mit dem Namen 'März'
ABACADAEAFAGAHAIAJAK
1Karfreitag OstersonntagOstermontag
2FrSaSoMoDiMiDoArbeits-

Stunden
Sonntags
stunden
Feiertags-
stunden
325262728293031
4 2 223252
5 22284

ZelleFormel
AJ4=SUMMENPRODUKT((REST($D$2:$AH$2;7)=1)*1;D4:AH4)-SUMMENPRODUKT((REST($D$2:$AH$2;7)=1)*(D47:AH47=1);D4:AH4)
AK4=SUMMENPRODUKT(($D$47:$AH$47=1)*1;$D4:$AH4)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

War beruflich unterwegs deshalb erst jetzt meine Entschuldigung.
Zunächst an Alle entschuldigung für die Passwortgeschützte Datei. Hab ich übersehen, es musste schnell gehen.
Was Ihr mit der Feiertagsliste meint versteh ich nich, bin kein Fachmann und habe diese Lösung mal im Netz gefunden und da sie funktioniert habe ich sie übernommen.
Die Formel für AJ4 zeigt mir #Wert! an; die Formel für AK4 ist Ok. Woran kann das liegen?
Bitte nochmal um Unterstützung.
Danke
freundlich grüßt
R@1ner

Excel 2013
to top
#5
Hallo R@1ner, ich hatte ja nur die alte Datei zur Hand, dort habe ich getestet, in deine neue (da nehme ich an hast du die Formel reingezaubert) kann ich ja nicht gucken...
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#6
(22.05.2015, 14:25)Jockel schrieb: Hallo R@1ner, ich hatte ja nur die alte Datei zur Hand, dort habe ich getestet, in deine neue (da nehme ich an hast du die Formel reingezaubert) kann ich ja nicht gucken...

Hallo Jockel,
Hab jetzt die Datei ohne Pwd angehängt.
Bestimmt hilft es so mehr.
Schon jetzt danke


Angehängte Dateien
.xlsm   Freier Dienstplan.xlsm (Größe: 36,45 KB / Downloads: 5)
freundlich grüßt
R@1ner

Excel 2013
to top
#7
Hallo,

da ist teilweise noch ein Blattschutz drin, das ist Mist!
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#8
Hallo,

hier mal meine Version:


.xlsm   Freier Dienstplan.xlsm (Größe: 34,96 KB / Downloads: 9)
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • freiminute
to top
#9
(22.05.2015, 16:08)BoskoBiati schrieb: Hallo,

hier mal meine Version:

Hallo Edgar,
vielen Dank für Deine Mühe.
So hatte ich mir das Ergebnisvorgestellt.
Schönes Wochenende und Feiertage
freundlich grüßt
R@1ner

Excel 2013
to top
#10
(22.05.2015, 16:08)BoskoBiati schrieb: Hallo,

hier mal meine Version:

Hallo Edgar,
nochmals vielen Dank für Deine Unterstützung.
Dank Dir habe ich den Dienstplan für das ganze Jahr zusammen gebastelt.
Nur mit dem Februar komme ich nicht klar.
Hab keine Ahnung............
Kannst du bitte mal da drüber gucken?
Schon jetzt vielen Dank


Angehängte Dateien
.xlsm   Freier Dienstplan 010615.xlsm (Größe: 239,82 KB / Downloads: 7)
freundlich grüßt
R@1ner

Excel 2013
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste