Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Kassensystem mit Budget
#1
Guten Abend,

für einen kleinen Laden im Zeltlager wollen wir in Excel ein "Kassensystem" machen, in dem jeder Teilnehmer eine feste Nummer hat und jeder Artikel eine feste Nummer hat.
Da die Teilnehmer das Geld am Anfang des Zeltlagers abgeben, hat jeder ein Budget, das der festen Teilnehmernummer zugeordnet werden soll.
Ich habe das mit einem Teilnehmer auch schön und übersichtlich hinbekommen, aber leider scheitere ich daran, dass die Tabelle ja mit insgesamt 40 Teilnehmern arbeiten muss.

Vielen Dank schon mal, ich hoffe das geht irgendwie!
Gruß, Andreas
to top
#2
Hallo Andreas,


Zitat:Vielen Dank schon mal, ich hoffe das geht irgendwie!

ja, das geht irgendwie. Wink

Spaß beiseite, eine Lösung kann dir nur angeboten werden, wenn deine Tabelle bekannt ist. So, wie du das Problem beschrieben hast, sind die Information einfach zu wenig.

Schau doch mal diesen Beitrag an, hier kannst du nachlesen, wie du eine Tabelle hochlädtst. Sie sollte deinem Original gleichen - sensible Daten, wie z.B. Namen, Adressen, usw. anonymisierst du einfach. (Statt Peter Müller z.B. Gustav Gans, Micky Mouse, Name1, Name2 usw.)
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#3
Hallo,

interessant wäre auch ob das Budget bei jedem gleich ist.
Gruß
Peter
to top
#4
Hallo,

im Anhang die Mappe.
Man hat unter Benutzer eine Benutzerübersicht und unter Artikel eine Artikelübersicht, die unter Kasse mithilfe von INDEX ausgelesen wird.
Kann natürlich alles geändert werden, wenn nötig Smile 
Das Budget ist nicht bei jedem gleich, da die Teilnehmer unterschiedlich Geld dabei haben.

Gruß, Andreas


Angehängte Dateien
.xlsx   Lagerladen.xlsx (Größe: 17 KB / Downloads: 18)
to top
#5
Hallo Andreas, du musst die Bezüge absolut setzten... ... also für B11:=INDEX(Artikel!$B$2:$B$101;A11) Du kannst auch in dieser Situation mit einem einfachen VERWEIS() arbeiten... .... bspw. für B4:=VERWEIS(B3;Benutzer!A:B) 
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#6
Hallo Andreas, aber auch ein SVERWEIS() ist möglich..:


Arbeitsblatt mit dem Namen 'Kasse'
ABCDE
10NummerArtikelPreis/StkAnzahlPreis
111Haribo0,05 €10,05 €

ZelleFormel
B11=SVERWEIS($A11;Artikel!$A$2:$D$101;SPALTE(B$1);0)
C11=SVERWEIS($A11;Artikel!$A$2:$D$101;SPALTE(C$1);0)
E11=C11*D11
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
AndiVogt
to top
#7
Hi Andreas,

hab' mir deine Tabelle angesehen. Den Tipp des Absolutierens hat dir Jörg ja schon gegeben. Was genau willst du jetzt erreichen? - das habe ich noch nicht verstanden.
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#8
Hallo Andi

Statt 'Kasse' habe ich ein Tabellenblatt 'Transaktionen'.
Es werden Excel-Tabellen verwendet (STRG-T).
Arbeitsblatt mit dem Namen 'Transaktionen'
 ABCDEF
1BenutzerArtikelEinzel-BetragAnzahlGesamt-BetragRest-Budget >=0?
2131,2545WAHR
3121,122,2WAHR

ZelleFormel
C2=SVERWEIS([Artikel];Artikel;3;FALSCH)
E2=[Einzel-Betrag]*[Anzahl]
F2=SVERWEIS([@Benutzer];Benutzer;3;FALSCH)-SUMMEWENN([Benutzer];[@Benutzer];[Gesamt-Betrag])>=0
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
to top
#9
Hallo Andreas,

meinst du so ?


Angehängte Dateien
.xlsx   Lagerladen neu.xlsx (Größe: 21,66 KB / Downloads: 12)
Gruß Conny Smile
_______________________________________________________________

Ich habe keine Lösung, aber ich bewundere dein Problem !
to top
#10
(04.05.2015, 17:58)WillWissen schrieb: Was genau willst du jetzt erreichen? - das habe ich noch nicht verstanden.
Also es soll eigentlich eine Excel-Tabelle für einen kleinen Laden sein, in dem die Teilnehmer Sachen einkaufen können. Da wird das die Jahre davor immer sehr umständlich gemacht haben, wollen wir das jetzt vereinfachen (wahrscheinlich auch mit Barcode-Scanner), so dass es einfach schneller geht.

(04.05.2015, 18:19)coemm schrieb: meinst du so ?
Eigentlich wollte ich, dass, wenn möglich, ich immer nur die Daten des einzelnen Teilnehmer sehe. Wenn das nicht geht ist es natürlich auch so möglich.

Habe das alles mal mit SVERWEIS() gemacht, so wie Jockel vorgeschlagen hat Smile

Gruß, Andreas
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste