Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


immer wieder die wenn dann Probleme
#1
Hallo alle beisammen an dem verregneten Feiertag,

habe mal wieder eine Frage.
an meiner Tabelle habe Ich folgendes Problem:

In der Spalte P Zelle B10 wird die Gerüstfläche berechnet. Die Formel stimmt soweit bis auf folgendes.
wenn Ich in Spalte B10 "brw" eingebe soll keine Fassadenfläche in "K10" ausgeworfen werden, das stimmt. jetzut bräuchte aber eine ergänzung in Spalte P Zelle B10 das er mir die Gerüstfläche berechnet und zwar aus der Spalte AG 10 .

Habe versucht folgendes einzugeben
wenn(B10="brw";AG10;0)

das klappt irgendwie nicht.

habe zur Orientierung die Zeile 11 so belassen wenn k11 als Fläche angezeigt wird.

Gehe mal wieder davon aus dass es nicht so schwer ist wie Ich mir das mir vorstelle.

Kann man eigentlich die Formel im Zelle P10 vereinfachen mit geschwungenen Klammern.



für alle noch einen schönen Feiertag   05


Angehängte Dateien
.xlsm   WDVS 2_0_0_2015mGerüst.xlsm (Größe: 45,59 KB / Downloads: 6)
to top
#2
(01.05.2015, 09:49)wavemaster schrieb: Hallo alle beisammen an dem verregneten Feiertag,

den ersten Teil habe Ich geschaft die Formel übersichtlicher zu gestalten.

Jetzt nur noch

"In der Spalte P Zelle B10 wird die Gerüstfläche berechnet. Die Formel stimmt soweit bis auf folgendes.

wenn Ich in Spalte B10 "brw" eingebe soll keine Fassadenfläche in "K10" ausgeworfen werden, das stimmt. jetzut bräuchte aber eine ergänzung in Spalte P Zelle B10 das er mir die Gerüstfläche berechnet und zwar aus der Spalte AG 10 .

Habe versucht folgendes einzugeben
wenn(B10="brw";AG10;0)

das klappt irgendwie nicht.

habe zur Orientierung die Zeile 11 so belassen wenn k11 als Fläche angezeigt wird."


Angehängte Dateien
.xlsm   WDVS 2_0_0_2015mGerüst_a.xlsm (Größe: 45,35 KB / Downloads: 6)
to top
#3
 Hallo.

habe nun den ganzen Morgen an der Formel gebastelt.

Komme einfach nicht weiter.

das ist mein letzter Versuch der nätürlich auch nicht funktioniert.


=WENN(UND(B10={"fbk";"de";"kg";"ab";"f";"br";"s";""});WENN(B10="brw";AG10);WENN(und(B10={"ft";"gr";"gl";"r"});H10*J10*i10;"0"))

dieser funktioniert
=WENN(UND(B10={"fbk";"de";"kg";"ab";"f";"br";"s";""});"0";WENN(K10="";"0";K10))

benötige folgende Zusammensetzung der Formel

=WENN(UND(B10={"fbk";"de";"kg";"ab";"f";"br";"s";""});"0"
WENN(B10="brw";AG10)= den Wert aus Zelle AG10 , wenn AG 10 leer dann 0
WENN(und(B10={"ft";"gr";"gl";"r"});H10*J10*i10;"0"

hoffe es kann sich jemand erbarmen bei dem scheußlichen Wetter , mir die Formel so zurechtzurücken dass diese Passt.

Danke
to top
#4
Hallo,

Du hast immer noch einige Dinge nicht verinnerlicht:

Zahlen in "" sind keine Zahlen mehr und führen irgendwann zu Fehlern!
Mit UND(B10={"ft";"gr";"gl";"r"}) verlangst Du das alle diese Buchstabenkombinationen gleichzeitig alleine in der Zelle stehen, das ist unmöglich!

Hier mal eine Formel für K10:


Code:
=WENN(ODER(B10={"";"süd";"west";"ost";"nord";"pz";"achse";"de";"se";"Brw"});0;WENN(ODER(B10={"s";"br"});-H10*I10*J10;WENN(LINKS(B10;1)="g";H10*I10/2*(1-(B10="gs-")*2);WENN(B10="f";WENN(H10*I10<2,5;0;-H10*I10*J10+O10);WENN(B10="fk";WENN(H10^2*0,785<2,5;0;-0,785*H10^2*J10+O10);H10*I10*J10)*(1-(ODER(B10={"fa";"ab"})*2))))))


und das für P10:


PHP-Code:
=WENN(B10="brw";AG10;WENN(oder(B10={"ft";"gr";"gl";"r"});H10*J10*i10;0))) 
Gruß


Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#5
Hallo

Da nicht alle Formeln gezeigt wurden, kann ich nur vermuten dass eine ganzheitliche Lösung angesagt ist: mit einer Hilfstabelle und SVERWEIS() und WAHL().
Und als I-Tüpfelchen könnte man noch Namen verwenden.
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
to top
#6
Hallo Detlef,


am Anfang sah das mal so aus:

http://www.clever-excel-forum.de/thread-...e=threaded

und zieht sich schon mehr als einen Monat hin.
Gruß


Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#7
Hallo Edgar

Wenn ich das hier lese ...
Zitat:Doch meine erste Idee (siehe Anhang ist voll funktionsfähig jedoch ist Sie etwas unübersichtlich) war schon bzw ist gut. Werde in Zukunft meine Exceltabellen die Ich einstelle so verfremden das daraus nicht abgeeitet werden kann für was diese gebraucht wird.
... dann vermute ich dass eine ganzheitliche Lösung nicht gewünscht ist.
Dann munteres Weiterwurschteln mit WENN(), UND() und ODER().
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
to top
#8
(02.05.2015, 05:53)BoskoBiati schrieb: Hallo,

Du hast immer noch einige Dinge nicht verinnerlicht:

Zahlen in "" sind keine Zahlen mehr und führen irgendwann zu Fehlern!
Mit UND(B10={"ft";"gr";"gl";"r"}) verlangst Du das alle diese Buchstabenkombinationen gleichzeitig alleine in der Zelle stehen, das ist unmöglich!

Hier mal eine Formel für K10:



Code:
=WENN(ODER(B10={"";"süd";"west";"ost";"nord";"pz";"achse";"de";"se";"Brw"});0;WENN(ODER(B10={"s";"br"});-H10*I10*J10;WENN(LINKS(B10;1)="g";H10*I10/2*(1-(B10="gs-")*2);WENN(B10="f";WENN(H10*I10<2,5;0;-H10*I10*J10+O10);WENN(B10="fk";WENN(H10^2*0,785<2,5;0;-0,785*H10^2*J10+O10);H10*I10*J10)*(1-(ODER(B10={"fa";"ab"})*2))))))



und das für P10:



PHP-Code:
=WENN(B10="brw";AG10;WENN(oder(B10={"ft";"gr";"gl";"r"});H10*J10*i10;0))) 

Hallo Edgar,


werde mir das zu Herzen nehmen,mit den "" Strichen,

ein Teil der Formel kapiere Ich noch nicht ganz


Code:
WENN(LINKS(B10;1)="g";H10*I10/2*(1-(B10="gs-")*2)


was bewirkt diese Formel genau.

Danke
to top
#9
Hallo,

schon mal was von Formelauswertung gehört??? Benutze die mal, dann kannst Du es nachvollziehen.
Gruß


Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  CSV Export immer mit Unterstrich im Text ace16vitamine 12 189 13.01.2017, 18:57
Letzter Beitrag: ace16vitamine
  Dropdownliste 2. Pfeil immer da R2D2 13 165 13.01.2017, 18:54
Letzter Beitrag: schauan
  WENN DANN mit Abfragewert < 1 einmalrund 4 77 13.01.2017, 15:23
Letzter Beitrag: Jockel
  Wenn-Dann in einer Summe Weylin 12 208 26.12.2016, 20:46
Letzter Beitrag: Jockel
  Wenn Dann Funktion trotz Dropdown Jenny Ring 2 108 19.12.2016, 16:31
Letzter Beitrag: Rabe
  Wenn in Zeile X steht dann in Zeile Y folgendes technoente 11 154 14.12.2016, 16:15
Letzter Beitrag: BoskoBiati
  Wenn-Dann funktion an Nachkommastellen einer Zahl knüpfen ako82 4 102 13.12.2016, 16:27
Letzter Beitrag: BoskoBiati
  Wenn dann Funktion Jenny Ring 2 80 13.12.2016, 15:47
Letzter Beitrag: BoskoBiati
Exclamation Problem:Zwei Spalten vergleichen wenn wahr dann bereich kopieren und einfügen CherryX 5 118 12.12.2016, 09:18
Letzter Beitrag: steve1da
  Userform immer im Vordergrund bei mehreren offenen Arbeitsmappen felix2000 7 188 11.12.2016, 16:11
Letzter Beitrag: Kuwer

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste