Suche in Excel sheets nach Duplikaten und gebe % Anzahl an.
#1
Hallo,

mein erster Post!  :-)

Ich habe eine .xlsx mit mehreren Sheets mit Datum benamt. (z.B. 24.05.2015)

In jedem sheet sind einige Daten pro Spalte, unter anderem auch eine Spalte mit einer Seriennummer.

Ich möchte gerne in allen Sheets suchen und Prozentuell ermittel wie oft die einzelnen Seriennummern auftauchen.


Genauer gesagt möchte ich suchen...

% Angabe für Seriennummern, welche jeden Tag auftauchen.

% Angabe für Seriennummern, welche an mehr wie einem Tag auftauchen.

% Angabe für Seriennummern, welche nur an einem Tag auftreten.



Ich bin leider nicht fündig geworden im Netz, somit wende ich mich an euch.

Für jeden Tipp bin ich dankbar!

Besten Dank!

Grüße,

miro
to top
#2
Hi Miro,

(29.04.2015, 17:09)miro schrieb: Genauer gesagt möchte ich suchen...

% Angabe für Seriennummern, welche jeden Tag auftauchen.

% Angabe für Seriennummern, welche an mehr wie einem Tag auftauchen.

% Angabe für Seriennummern, welche nur an einem Tag auftreten.

Ich würde das mit einer Pivot-Tabelle lösen, da kann man das Datum schön gruppieren und auch die Daten schön summieren lassen. Alles automatisch bei Änderungen.
to top
#3
(30.04.2015, 09:11)Rabe schrieb: Hi Miro,

(29.04.2015, 17:09)miro schrieb: Genauer gesagt möchte ich suchen...

% Angabe für Seriennummern, welche jeden Tag auftauchen.

% Angabe für Seriennummern, welche an mehr wie einem Tag auftauchen.

% Angabe für Seriennummern, welche nur an einem Tag auftreten.

Ich würde das mit einer Pivot-Tabelle lösen, da kann man das Datum schön gruppieren und auch die Daten schön summieren lassen. Alles automatisch bei Änderungen.

Danke für die Info! Könntest Du mir bitte noch weitere Infos geben? Habe noch nie eine Pivot Tabelle erstellt.
Danke!

Grüße,Miro
to top
#4
Hi Miro,

(30.04.2015, 09:57)miro schrieb: Danke für die Info! Könntest Du mir bitte noch weitere Infos geben? Habe noch nie eine Pivot Tabelle erstellt.    
Danke!

doch kann ich schon, dann sollte ich aber eine Beispieldatei (und zwar kein Bildchen) haben.
to top
#5
Hallo Miro,

wenn Du mit einer Liste aller Seriennummern arbeiten kannst, wäre das ein Formelansatz. Mit Pivot kann Dir sicher Ralf weiterhelfen. 

In Spalte E siehst Du, in wie viel Bereichen die jeweilige Seriennummer vorkommt. Ich hab die Bereiche jetzt mal auf ein Blatt gelegt, dass geht natürlich auch mit Deinen verschiedenen Datenblättern. Der Rest der Aufgabe ist nur noch Prozentrechnung ...

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFGH
1Seriennummernin Bereich1in Bereich2in Bereich3SummeBereich1Bereich2Bereich3
21100115588
3211022299
431113333
5331001336611
6441001447722
7550101   
8660101   
9770101   
10880011   
11990011   
12110011   
13220011   

NameBezug
Bereich1=Tabelle1!$F$2:$F$6
Bereich2=Tabelle1!$G$2:$G$6
Bereich3=Tabelle1!$H$2:$H$6

ZelleFormel
B2=N(ZÄHLENWENN(Bereich1;$A2)>0)
C2=N(ZÄHLENWENN(Bereich2;$A2)>0)
D2=N(ZÄHLENWENN(Bereich3;$A2)>0)
E2=SUMME(B2:D2)
Diese Tabelle wurde mit Tab2Html (v2.5.0) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste