Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


wenn - dann - sonst problem
#1
guten abend zusammen

ich habe ein kleines Problem mit der wenn formel

ich habe in der zelle A1 (stunden formatierung) 13:00 stehen
und in der zelle A2 (stunden formattierung) die geleistete Arbeitszeit errechnen lassen mit =24-A1
und in der zelle A3 soll er mir jetzt anzeigen wenn mehr als 12std gearbeitet wurden eine 1 und wenn nicht 0,5

meine formel dafür wäre so
=(A3<12:00;"1";"0,5")

aber leider schreibt er mir immer in der zelle A3 eins an ich weiß leider nicht warum

könnt ihr mir bitte helfen

vielen dank im voraus

PS: zelle a§ ist als zahl mit einer stelle hinterm komma formatiert
to top
#2
Hallo

Zitat:=24-A1
Ändere das mal auf
Code:
=1-A1

Zitat:=(A3<12:00;"1";"0,5")
Kein Kommentar.  Huh
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
to top
#3
Hi,

so ganz verstehe ich nicht, was du genau bezwecken willst.

Was ist 13:00? Ist das eine Uhrzeit oder sind das Gesamtstunden?
Am besten wäre, du würdest uns einen Tabellenausschnitt zeigen, mit dem du dann beschreibst, was du wo erreichen willst.
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#4
Hi easy,

mal ein Versuch, so wie ich dein Problem verstehe. Ich baue mal deine Vorgaben etwas um.

Tabelle2

ABC
1BeginnEnde
207:0019:000,5
307:0020:001
407:0016:000,5
507:0019:051
Formeln der Tabelle
ZelleFormel
C2=WENN((B2-A2)>0,5;1;0,5)
C3=WENN((B3-A3)>0,5;1;0,5)
C4=WENN((B4-A4)>0,5;1;0,5)
C5=WENN((B5-A5)>0,5;1;0,5)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Passt das so?

Zu deinen etwas abenteuerlichen Angaben in deiner Formel:
ich gehe davon aus, dass du bisher mit Uhrzeit und/oder Stunden in Excel noch nicht allzuviel am Hut hattest. Schau dir doch dazu mal diesen Link und den am Ende der Seite angegebenen für den zweiten Teil der Grundlagen an.
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#5
erstmal vielen dank für die schnellen antworten

ich versuche es mal anders zu erläutern

ich möchte die Arbeitszeit ausrechnen wieviele std. man gearbeitet hat und das dann der Faktor volle Belohnung oder nur die halbe Belohnung man erhält

Zitat:´
Zelle A1 ist das arbeits beginn z.b 13:00 uhr
Zitat:in der zelle A2 wird berechne wieviele stunden er nun gearbeite hat
Zitat:als in A1 wird 13:00 Arbeitsbeginn eingetragen und in der zelle A2 errechnet Excel die geleisteten stunden
11:00
Zitat:wenn er nun um 11:30 beginn steht dann in der zelle 12:30
Zitat:jetzt möchte ich das in der zelle A3 eine formel drin steht ob er den vollen Bonus bekommt = 1
oder nur den halben bonusbekommt =0,5
laut vieler verschiedene Beispiele habe ich es so verstanden
Zitat:=WENN(A2<12:00;"1";"0,5")
wenn a2
größer als 12:00 schreibe eine 1 in der zelle A3
sonst schreibe eine 0,5 in der zelle A3

habe ich es falsch verstanden und es geht nur mit richtig oder falsch?

vielen dank
to top
#6
Hi,
Zitat:ich versuche es mal anders zu erläutern


ich möchte die Arbeitszeit ausrechnen wieviele std. man gearbeitet hat und das dann der Faktor volle Belohnung oder nur die halbe Belohnung man erhält

lies dir doch die Antworten erst einmal richtig durch und beachte die Hinweise der Helfer.
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#7
vielen dank WillWissen

so klappt es

also ein kleiner denk fehler von mir das man nicht den arbeits beginn - 24std rechnen lassen kann

und die Arbeitszeit rechnung teilen muß wenn jemand erst nach 23:59 Feierabend macht


vielen dank für die super hilfe

gruß easy83
to top
#8
Hallo,

vielleicht solltest Du erst einmal das durcharbeiten:


http://www.online-excel.de/excel/singsel.php?f=128
http://www.online-excel.de/excel/singsel.php?f=129
Gruß


Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#9
Hi easy,

Zitat:und die Arbeitszeit rechnung teilen muß wenn jemand erst nach 23:59 Feierabend macht

Arbeitszeiten über Mitternacht hinaus kannst du einfach mit =REST(B2-A2;1) ausrechnen. Umgemünzt auf das vorige Beispiel müsstest du diese Formel eingeben:

Code:
=WENN(REST(B2-A2;1)>0,5;1;0,5)
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#10
Hi Edgar,

Zitat:vielleicht solltest Du erst einmal das durcharbeiten:

http://www.online-excel.de/excel/singsel.php?f=128
http://www.online-excel.de/excel/singsel.php?f=129



guckst du in den Beitrag #4:

Zitat:Schau dir doch dazu mal diesen Link und den am Ende der Seite angegebenen für den zweiten Teil der Grundlagen an.
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  WENN 5 Zellen ISTLEER dann... Argre 7 98 03.12.2016, 22:48
Letzter Beitrag: schauan
  WENN/DANN Bedingung möglich? stella_gen 22 203 02.12.2016, 00:01
Letzter Beitrag: stella_gen
  WENN/DANN Gesamtsumme nach Kriterien Baldi 5 80 28.11.2016, 16:53
Letzter Beitrag: Baldi
  Wenn Zelleninhalt > 0 dann die 5 linken Zellen farbig Daniel Albert 5 81 22.11.2016, 18:48
Letzter Beitrag: Daniel Albert
  Wenn Dann Funktion in Komb. mit Bedingter Formatierung snoopy4000_0 9 90 21.11.2016, 16:19
Letzter Beitrag: snoopy4000_0
  wenn in tabelle wert in spalte dann neue spalte in neuer tabelle merzens 4 88 16.11.2016, 13:44
Letzter Beitrag: schauan
  VBA: Wenn Datei offen dann schließen mit Speicherabfrage Kash 1 63 15.11.2016, 23:24
Letzter Beitrag: AlterDresdner
Question Zeiterfassung mit "wenn;und;dann;sonst">als;<als falsch durchdacht thoju 8 243 19.10.2016, 14:24
Letzter Beitrag: BoskoBiati
Video SVerweis mit Wenn Dann Sonst Funktion Verknüpfung HollyBoy 16 432 14.10.2016, 05:56
Letzter Beitrag: WillWissen
  Wenn-dann-Formel Tukan 6 126 11.10.2016, 14:55
Letzter Beitrag: Tukan

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste