Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Funktion LINKS kombinieren
#1
Hallo,

ich habe längere Zeit nicht mehr ge"excelt" und bin etwas raus.
Daher möchte ich euch bitten mir einen kurzen Denkanstoß zu geben.
Wie kann ich die Funktion LINKS kombinieren mit 2 Bedingungen.
Es soll: 1) Text ausgelesen werden bis zum ersten Komma ODER bis zur ersten Leerzeile

Ich sag schon mal ganz vielen Dank.

Grüße
to top
#2
Hallo, eine Möglichkeit wäre..:
=WENNFEHLER(LINKS(WECHSELN(WECHSELN(A1;",";"#");" ";"#");SUCHEN("#";WECHSELN(WECHSELN(A1;",";"#");" ";"#"))-1);A1)
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#3
Hallo Jockel

tausend Dank, das hätte ich nie alleine hinbekommen, funktioniert bestens.
Jetzt kann ich endlich weiterbasteln...

Danke und Grüße
Bea die erste
to top
#4
Hi,

ginge auch etwas kürzer:


Code:
=WENNFEHLER(LINKS(A1;SUCHEN("#";WECHSELN(WECHSELN(A1;" ";"#");",";"#"))-1);"")
Gruß


Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#5
Hallo,

hier noch zwei weitere Möglichkeiten:

=TEIL(A1;1;MIN(SUCHEN(",";A1&",");SUCHEN(" ";A1&" "))-1)
=LINKS(A1;MIN(SUCHEN(",";A1&",");SUCHEN(" ";A1&" "))-1)

Gruß Uwe
to top
#6
(17.04.2015, 11:21)Kuwer schrieb: Hallo,

hier noch zwei weitere Möglichkeiten:

=TEIL(A1;1;MIN(SUCHEN(",";A1&",");SUCHEN(" ";A1&" "))-1)
=LINKS(A1;MIN(SUCHEN(",";A1&",");SUCHEN(" ";A1&" "))-1)

Gruß Uwe

Hi Uwe, gefällt mir sehr gut... (^_-)
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#7
Thumps_up Cool Cool
Gruß


Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#8
Hi,

(17.04.2015, 09:46)bea die erste schrieb: Es soll: 1) Text ausgelesen werden bis zum ersten Komma ODER bis zur ersten Leerzeile

ich hatte da ein Problem, in der Zelle die erste Leerzeile zu finden, das ist ja was anderes als eine Leerstelle.

Darum bin ich auf keine Formel gekommen.
Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top
#9
Hallo Rabe,

ich habe mich falsch ausgedrückt - bis zur ersten Leerstelle war schon richtig.
Manchmal klappt es mit dem Denken nicht mehr so gut :-(

Danke fürs Lesen
Grüße und schönen Samstag
Bea die erste und ihr Schlauch, auf dem sie bei der Beschreibung definitiv stand...und immer noch steht...
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Mischung zwischen SVERWEIS/MATCH/LINKS/FINDEN/SUCHEN th0m45 4 128 18.12.2016, 23:13
Letzter Beitrag: Ego
Exclamation sverweis nach links - mehr Treffer erwünscht WergibtmirRat 15 378 13.11.2016, 20:32
Letzter Beitrag: Jockel
  Artikeldaten aus versch. Tabellen kombinieren Adrianos 9 365 01.10.2016, 20:10
Letzter Beitrag: IchBinIch
  Dropdown-Liste mit Sverweis und Dropdown kombinieren Amcor 1 242 26.08.2016, 12:19
Letzter Beitrag: steve1da
  Bei "9" die Spalte links davon angeben IchDie 20 603 27.07.2016, 18:04
Letzter Beitrag: RPP63
  Zwei Diagrammtypen kombinieren!? Larne 4 296 13.07.2016, 20:40
Letzter Beitrag: Larne
  Alle 6 Felder links von hier gucken, ob etwas drinsteht o0Julia0o 12 557 09.07.2016, 09:46
Letzter Beitrag: Luffy
  Bedingungen kombinieren blownlightbulb 1 287 13.06.2016, 18:36
Letzter Beitrag: WillWissen
  Wörter kombinieren, Textkette erstellen snoergel 2 276 02.06.2016, 14:49
Letzter Beitrag: BoskoBiati
  Zählen-Funktion in Kombination mit Wenn-Funktion? veve 22 1.331 09.05.2016, 08:02
Letzter Beitrag: steve1da

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste