Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

Funktion LINKS kombinieren
#1
Hallo,

ich habe längere Zeit nicht mehr ge"excelt" und bin etwas raus.
Daher möchte ich euch bitten mir einen kurzen Denkanstoß zu geben.
Wie kann ich die Funktion LINKS kombinieren mit 2 Bedingungen.
Es soll: 1) Text ausgelesen werden bis zum ersten Komma ODER bis zur ersten Leerzeile

Ich sag schon mal ganz vielen Dank.

Grüße
to top
#2
Hallo, eine Möglichkeit wäre..:
=WENNFEHLER(LINKS(WECHSELN(WECHSELN(A1;",";"#");" ";"#");SUCHEN("#";WECHSELN(WECHSELN(A1;",";"#");" ";"#"))-1);A1)
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#3
Hallo Jockel

tausend Dank, das hätte ich nie alleine hinbekommen, funktioniert bestens.
Jetzt kann ich endlich weiterbasteln...

Danke und Grüße
Bea die erste
to top
#4
Hi,

ginge auch etwas kürzer:


Code:
=WENNFEHLER(LINKS(A1;SUCHEN("#";WECHSELN(WECHSELN(A1;" ";"#");",";"#"))-1);"")
Gruß


Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#5
Hallo,

hier noch zwei weitere Möglichkeiten:

=TEIL(A1;1;MIN(SUCHEN(",";A1&",");SUCHEN(" ";A1&" "))-1)
=LINKS(A1;MIN(SUCHEN(",";A1&",");SUCHEN(" ";A1&" "))-1)

Gruß Uwe
to top
#6
(17.04.2015, 11:21)Kuwer schrieb: Hallo,

hier noch zwei weitere Möglichkeiten:

=TEIL(A1;1;MIN(SUCHEN(",";A1&",");SUCHEN(" ";A1&" "))-1)
=LINKS(A1;MIN(SUCHEN(",";A1&",");SUCHEN(" ";A1&" "))-1)

Gruß Uwe

Hi Uwe, gefällt mir sehr gut... (^_-)
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#7
Thumps_up Cool Cool
Gruß


Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#8
Hi,

(17.04.2015, 09:46)bea die erste schrieb: Es soll: 1) Text ausgelesen werden bis zum ersten Komma ODER bis zur ersten Leerzeile

ich hatte da ein Problem, in der Zelle die erste Leerzeile zu finden, das ist ja was anderes als eine Leerstelle.

Darum bin ich auf keine Formel gekommen.
Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top
#9
Hallo Rabe,

ich habe mich falsch ausgedrückt - bis zur ersten Leerstelle war schon richtig.
Manchmal klappt es mit dem Denken nicht mehr so gut :-(

Danke fürs Lesen
Grüße und schönen Samstag
Bea die erste und ihr Schlauch, auf dem sie bei der Beschreibung definitiv stand...und immer noch steht...
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Summenprodukt und Zählenwenns kombinieren Zholvar 8 156 06.03.2017, 12:03
Letzter Beitrag: BoskoBiati
  Matrix Erstellen: SUMMEWENNS mit SUMME(Ax*Cx) kombinieren dimenhydrinate 14 249 04.02.2017, 19:47
Letzter Beitrag: BoskoBiati
  Excel, Nur die links stehende Zahl ändern nils9364 24 530 03.02.2017, 11:03
Letzter Beitrag: Kuwer
  2 Dateien kombinieren Dubsepp 2 98 31.01.2017, 16:37
Letzter Beitrag: schauan
  Alle Zellen farbig die links von zelle stehen Hagen 4 121 29.01.2017, 11:19
Letzter Beitrag: Peter
  Seit Test mit Arabisch schreibt Excel nur noch von rechts nach links Onkel 6 191 21.01.2017, 13:05
Letzter Beitrag: Onkel
  Mischung zwischen SVERWEIS/MATCH/LINKS/FINDEN/SUCHEN th0m45 4 270 18.12.2016, 23:13
Letzter Beitrag: Ego
Exclamation sverweis nach links - mehr Treffer erwünscht WergibtmirRat 15 625 13.11.2016, 20:32
Letzter Beitrag: Jockel
  Artikeldaten aus versch. Tabellen kombinieren Adrianos 9 502 01.10.2016, 20:10
Letzter Beitrag: IchBinIch
  Dropdown-Liste mit Sverweis und Dropdown kombinieren Amcor 1 369 26.08.2016, 12:19
Letzter Beitrag: steve1da

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste