Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Zahlenbeträge in Feldbezüge umwandeln
#1
Hallo,
 
ich benötige eine Idee mit einer "=WENN"-Formel. Die Formel die umgestellt werden soll ist ellenlang und ich versuche es daher anders zu erfragen und nehme mir einfach ein Stück heraus: +WENN(ODER(G60="";0;G60>5);7,30;  
 
Ich habe 5 und 7,30 als die Werte die ich ändern will, dabei will ich beide Werte einem Feld zuordnen, z.B. B1 und B2. Wie muss die Formel aussehen, wenn statt 5 und 7,30 als Zahl nun Feld B1 und B2 drinnen verknüpft werden ?  
Man kann dann nämlich besser die Zahlen besser anpassen ohne jedes mal in die Formel eingreifen zu müssen.
 
Die Formel soll sagen, dass ein Produkt 7,30€ kostet wenn man mehr als 5 Stück nimmt.
Diese Preisangaben und Stückzahlangaben sollen dann in B1 oder B2 bedienfreundlich eingetragen werden.

Von so:
+WENN(ODER(G60="";0;G60>5);7,30;  
 
etwa so meine ich das, das hier ist aber falsch:
+WENN(ODER(G60="";0;G60> =B1);=B2;  

Grüße
to top
#2
Hallo,

ersetze einfach die Werte 5 bzw. 7,30 durch B1 und B2:

WENN(ODER(G60="";0;G60>B1);B2

Vermutung: Vielleicht solltest du dir auch mal die Funktion Sverweis() ansehen. Damit könnte man eine ellenlange Wenn-Formel deutlich verkürzen.
Gruß
Peter
[-] Folgende(r) 1 Benutzer sagt Danke an Peter für diesen Beitrag:
Metalli
to top
#3
Hallo,

das hat ja prima geklappt. Nun hätte ich noch eine kleine Ergänzung, wo mir mit z.B. einem "x" angezeigt wird, welche Staffel schlussendlich bei jener Bestellmenge genommen wird. Dass muss man dann wohl beschränken mit   < >

  1    kg    11    €    
  2    kg    10    €    
  4    kg      9    €    
  8    kg      8    €    x
20    kg      5    €    


Nehmen wir dabei mal an dass 1kg = A1 ist und 11€ = D1 ist.

Das "x" steht in F drin, womit ich dann selbige Formel 5x eintragen muss.

Grüße
to top
#4
Hallo,

erläutere das mal ein wenig genauer. Soll der Wert der mit x gekennzeichnet wird in B1 und B2 eingetragen werden?

Wenn ja, dann würde ich mit Index/Vergleich arbeiten:

Arbeitsblatt mit dem Namen 'Tabelle1'
 BCDEFGHI
1210   kgPreis 
2     111 
3     210x
4     49 
5     88 
6     205 

ZelleFormel
B1=INDEX(G1:G10;VERGLEICH("X";$I1:$I10;0))
C1=INDEX(H1:H10;VERGLEICH("X";$I1:$I10;0))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Die Formel in B1 kannst du einfach nach rechts kopieren.

Wenn das nicht deine Zielsetzung ist, dann solltest du das noch etwas näher erklären.

Nachtrag: Als ich mein Posting abgesendet habe stand das
Zitat:Nehmen wir dabei mal an dass 1kg = A1 ist und 11€ = D1 ist.
Das "x" steht in F drin, womit ich dann selbige Formel 5x eintragen muss.
noch nicht im Beitrag. Das ist mir erst jetzt aufgefallen. Aber die Anpassung solltest du selbst hinbekommen.

Und der zweite Halbsatz dieser Aussage
Zitat:Das "x" steht in F drin, womit ich dann selbige Formel 5x eintragen muss.
verstehe ich nicht.
Gruß
Peter
[-] Folgende(r) 1 Benutzer sagt Danke an Peter für diesen Beitrag:
Metalli
to top
#5
Hallo,
also das mit der Formel oben habe ich fertig und erfolgreich hinbekommen und gilt als erledigt. Das Feld mit der Bestellmenge, dem entsprechenden Kilopreis steht neben der Rabatttabelle, welche ja nur veranschaulichen soll, welche Möglichkeiten man hat.

Wir haben also diese Tabelle, und irgendwo noch das Feld wo der Kunde Stückzahlen einträgt, des weiteren das Feld was ihm den richtigen Kilopreis anhand der Staffel zeigt, also diese 5-11€.


Damit der Besteller noch mal sehen kann, welche Rabattstufe wirklich genommen wurde, kann man ja ein "x" oder einen Text der Schönheit wegen hinten noch "anbammeln".
Die Formel die nur in das Feld des "x" kommt, in dem Fall 5x, also 1x hinter das Feld wo"€" drin steht, muss jedes mal feststellen ob der Wert im Bestellstückfeld mit 1,2,4,8 und 20 im Verhältnis steht und sich als Leerfeld oder "x" dann eintragen.
in dem Feld des "x" bei der 4kg-Spalte müsste dann in der Formel des "x" stehen, "wenn 4 aber kleiner als 8, dann zeige bitte das x", damit das "x" kommt


Bestellmenge :   1

errechneter
Kilopreis:      11€


1    kg    11    €       x    
2    kg    10    €    
4    kg    9    €    
8    kg    8    €    
20    kg    5    €    

oder


Bestellmenge :   9
errechneter
Kilopreis:      8€


1    kg    11    €    
2    kg    10    €    
4    kg    9    €    
8    kg    8    €    x
20    kg    5    €   

Mit "F" für das "x" gemeint, meine ich irgend eine Spalte hinter der Rabattabelle, muss nicht F sein, aber eben hinter €. Diese kann auch heißen "genutzter Rabatt" oder "<-". Soll also nur optisch auf die Zeile des genutzten Rabattes zeigen.



Grüße
to top
#6
Hallo,

gelöscht - nach dem Absenden habe ich gesehen, dass der Vorgängerbeitrag wieder geändert wurde.

Ich warte jetzt einfach mal eine halbe Stunde.
Gruß
Peter
[-] Folgende(r) 1 Benutzer sagt Danke an Peter für diesen Beitrag:
Metalli
to top
#7
Hallo,

ich merks. In deinem Bild dreht es sich also nur um Zelle C1- C5.

Bei C1 müsste drin stehen: wenn G1 >=A1 ist, aber kleiner als A2, dann zeige bitte das x, ansonsten " "     (leer)
Bei C3 müsste drin stehen: wenn G1 >=A3 ist, aber kleiner als A4, dann zeige bitte das x, ansonsten " "     (leer)


der Vorgängerbeitrag wurde nur ergänzt oder RS-Fehler korrigiert.


(Bei G1 müsste bestimmt das KG raus und nur die Zahl drin stehen, damit es sie verrechnen kann.)

Grüße
to top
#8
Hi,

was hältst du von dieser Lösung? Falls du Peters Beiträge richtig gelesen hast, dann weißt du ja um seinen SVERWEIS-Vorschlag sicher Bescheid?

Tabelle1

ABCDEF
1Bestellmenge9 kg1 kg       11,00 €
2Kilopreis         8,00 € 2 kg       10,00 €
34 kg         9,00 €
48 kg         8,00 € x
520 kg         5,00 €
Formeln der Tabelle
ZelleFormel
F1=WENN($B$2=E1;"x";"")
B2=SVERWEIS($B$1;$D$1:$E$5;2;1)
F2=WENN($B$2=E2;"x";"")
F3=WENN($B$2=E3;"x";"")
F4=WENN($B$2=E4;"x";"")
F5=WENN($B$2=E5;"x";"")

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
Metalli
to top
#9
Hi,

mir ist gerade noch deine Bemerkung

Zitat:(Bei G1 müsste bestimmt das KG raus und nur die Zahl drin stehen, damit es sie verrechnen kann.)
aufgefallen.

Was meinst du damit? Du wirst du nicht etwa die Bezeichnungen in eine eigene Spalte stecken? So etwas kannst du bequem mit der benutzerdefinierten Formatierung machen. Excel rechnet trotzdem korrekt.
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
Metalli
to top
#10
Hallo,
mit der Tabelle kommen wir ein Stück näher, nur muss sich die Spalte E nicht auf B2 sondern auf B1 beziehen. Des weiteren können auch 5 kg eingetragen werden, womit das dann das "x" in 4 aktivieren muss.

Bisher würde er nur bei genauer Angabe von 1,2,4 ,8,oder 20 ein "x" eintragen, bei 3,5,11 usw. aber nichts.  Das "x" muss sich also aber auch wieder löschen, wenn der nächst höhrere Betrag gewählt wird.

Grüße
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Umwandeln von Kleinbuchstaben in Großbuchstaben Matt87 14 163 18.11.2016, 13:28
Letzter Beitrag: Matt87
  Zahl umwandeln herbert0803 11 220 21.10.2016, 16:07
Letzter Beitrag: herbert0803
  Datum umwandeln mabis 13 278 12.10.2016, 08:03
Letzter Beitrag: Jockel
  Tilgungsrechner in Jahre statt Monate umwandeln konstantin 3 327 29.06.2016, 10:27
Letzter Beitrag: konstantin
  Datum zurück in eine Zahl umwandeln crichton 8 480 25.05.2016, 14:28
Letzter Beitrag: Jockel
  Datum umwandeln Baltic86 9 529 10.05.2016, 13:38
Letzter Beitrag: coemm
  Makro umwandeln und erweitern sveninho11 4 433 31.03.2016, 13:12
Letzter Beitrag: Rabe
  Umwandeln Kanonisches Datum FloKo 9 641 30.03.2016, 20:14
Letzter Beitrag: Castor
  nur 5stellige Texte in Zahlen umwandeln PhilippB. 11 1.064 07.03.2016, 16:38
Letzter Beitrag: PhilippB.
  Zeilen in Spalten umwandeln Günther L. 1 584 03.03.2016, 09:27
Letzter Beitrag: atilla

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste