Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

Verweis zu anderer Tabelle unverändert kopieren
#1
Hallo,

in Tabelle1 ist eine Formel mit einem Verweis zu einem Wert in Tabelle2.
Tabelle1 wird zu Tabelle1_2 kopiert.
Nun bezieht der Bezug in Tabelle1_2 nicht mehr zu Tabelle 2, sondern zu Tabelle0.
Wie können Tabellen so kopiert werden, damit die Bezüge zu anderen Tabellen die selben bleiben?
Nutze OpenOffice.

Danke.


.xls   Frage Tabellenbezug.xls (Größe: 7,5 KB / Downloads: 5)

Crossposting in Herber Excel Forum.
to top
#2
Hola,

kennste ja schon:

http://www.herber.de/forum/messages/1418326.html

Gruß,
steve1da
to top
#3
Hi,

dein Problem kann ich aktuell nicht nachvollziehen. Ich habe dir im Anhang eine OO-Tabelle, so, wie du es beschrieben hast, hochgeladen. Egal, wieviele Kopien des Tabellenblattes ich auch anfertige, der Bezug zum Blatt 2 ist immer noch vorhanden.


.ods   MDGGB_Tabelle_kopieren.ods (Größe: 7,79 KB / Downloads: 3)

Du hast die eingestellte Mustertabelle in das XL-Format konvertiert. Liegt es eventuell daran? Das habe ich jetzt nicht getestet.
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#4
(01.04.2015, 18:43)WillWissen schrieb: Hi,

dein Problem kann ich aktuell nicht nachvollziehen. Ich habe dir im Anhang eine OO-Tabelle, so, wie du es beschrieben hast, hochgeladen. Egal, wieviele Kopien des Tabellenblattes ich auch anfertige, der Bezug zum Blatt 2 ist immer noch vorhanden.



Du hast die eingestellte Mustertabelle in das XL-Format konvertiert. Liegt es eventuell daran? Das habe ich jetzt nicht getestet.

Hallo,
habe bei deiner Datei die Tabelle1 kopiert zu Tabelle1_4, und der Bezug ist nun nicht mehr zu Blatt 2, sondern zu Tabelle1_3.
Wenn ich einen absoluten Bezug zu der Tabelle mache, ist das beim Kopieren nicht so, aber ohne verschiebt sich der Bezug immer um eine Tabelle.

Gruß


.ods   MDGGB_Tabelle_kopieren 2.ods (Größe: 8,07 KB / Downloads: 1)
to top
#5
Hi,

diesmal konnte ich es nachvollziehen. Folgendes habe ich gemacht (vielleicht hilft dir das ein Stückchen weiter):

Tabelle anfassen und nach rechts ziehen - dabei die STRG-Taste gedrückt lassen, dann wird das Blatt kopiert. Solange ich die Kopie unmittelbar rechts neben der Originaltabelle ablege, werden die Bezüge bei mir ordentlich übernommen. In meiner Mustertabelle hast du das ja gesehen. Sobald aber die Kopie an anderer Stelle abgelegt wird, erhalte ich #REF! Das selbe Phänomen erhalte ich auch beim "klassischen" Kopieren durch Rechtsklick auf den Tabellenreiter.


PHP-Code:
=SVERWEIS(A1;#REF!.A1:B2;2;0) 

Aber ich weiß leider nicht, warum.

Probiere doch mal aus, ob meine Methode bei dir geht. Dann kannst du wenigstens dein Blatt kopieren und erst anschließend an die Stelle ziehen, an der du das Blatt haben willst. Beim normalen Verschieben bleiben bei mir die Bezüge bestehen,
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#6
(01.04.2015, 20:52)WillWissen schrieb: Hi,

diesmal konnte ich es nachvollziehen. Folgendes habe ich gemacht (vielleicht hilft dir das ein Stückchen weiter):

Tabelle anfassen und nach rechts ziehen - dabei die STRG-Taste gedrückt lassen, dann wird das Blatt kopiert. Solange ich die Kopie unmittelbar rechts neben der Originaltabelle ablege, werden die Bezüge bei mir ordentlich übernommen. In meiner Mustertabelle hast du das ja gesehen. Sobald aber die Kopie an anderer Stelle abgelegt wird, erhalte ich #REF! Das selbe Phänomen erhalte ich auch beim "klassischen" Kopieren durch Rechtsklick auf den Tabellenreiter.





PHP-Code:
=SVERWEIS(A1;#REF!.A1:B2;2;0) 

Aber ich weiß leider nicht, warum.

Probiere doch mal aus, ob meine Methode bei dir geht. Dann kannst du wenigstens dein Blatt kopieren und erst anschließend an die Stelle ziehen, an der du das Blatt haben willst. Beim normalen Verschieben bleiben bei mir die Bezüge bestehen,

Danke, hast mir mit diesem Tipp geholfen, kopiere nun mit der STRG-Taste wie beschrieben.
Smile
Gruß
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Tabelle 1:1 automatisch kopieren Aritmatos 17 362 24.03.2017, 18:46
Letzter Beitrag: Gast 123
  Verweis auf externe Tabelle/bestimmter Tab Marquee 29 429 22.03.2017, 15:59
Letzter Beitrag: Marquee
  wert aus anderer tabelle auslesen Rjinxil 6 74 22.03.2017, 14:43
Letzter Beitrag: Rjinxil
  bestimmte Zeile aus mehreren Dateien in eine Tabelle kopieren Fabian1208 3 55 22.03.2017, 13:07
Letzter Beitrag: Fabian1208
  Zelleninhalte aus Tabelle 1 in Tabelle 2 kopieren J66 3 92 04.03.2017, 14:27
Letzter Beitrag: J66
Question Zellwert zu Formel in anderer Zelle machen -> 4x4 zu =4x4 o0Julia0o 38 976 23.02.2017, 11:26
Letzter Beitrag: Rabe
Question Wert aus anderer Datei per Feldnamen übernehmen o0Julia0o 12 245 16.02.2017, 12:44
Letzter Beitrag: Peter
  Smarte Tabelle Problem beim Kopieren/Einfügen soky001 1 85 10.02.2017, 22:06
Letzter Beitrag: soky001
  Tabellenblatt 1:1 in anderer Datei inkl. Aktualisierung kazzz 3 154 08.02.2017, 12:28
Letzter Beitrag: Palomino
  2 Tabellen zusammenführen / S-Verweis? TomTom74 8 264 01.02.2017, 19:58
Letzter Beitrag: schauan

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste