Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Automatische Nummerierung
#1
Hallo Liebe Forenmitglieder.


Ich habe da ein Problem mit einer Nummerierung und ich komme einfach nicht dahinter.

Folgende Themenstellung:
Habe in einem Tabellenblatt eine Liste, die ab und an mal mit neuen Produkten "gefüttert" wird - sprich, gibt es ein neues Produkt so wird dieses in die Tabelle eingetragen.

Jedes Produkt hat eine fortlaufende Nummer, das Produkt welches als letztes eingetragen wird besitzt die höchste Nummer.

(z.B. Es sind 103 Produkte eingetragen, kommt nun ein neues hinzu, muss dieses mit Nummer 104 gekennzeichnet sein, usw.) Das muss sein da sonst die zugeordneten Bilder nicht angezeigt werden können.

Ich möchte nun diese Nummerierung automatisieren.
Das stelle ich mir so vor: Bei Eintrag eines neuen Produktes in Spalte A soll automatisch in Spalte B die nächst höhere Nummer erscheinen.

Mit der Formel =WENN(A2<>"";MAX($B$1:B1)+1;"") funktioniert das aber leider nur wenn ich ein neues Produkt immer an letzter Stelle der Liste eintrage.

Damit meine ich:
Ich habe einen Hersteller "A" (in Zeile A1)
Alle Produkte vom Hersteller "A" sind unterhalb eingetragen. (also von A2-A20)
Hersteller "B" fängt dann in Zelle A21 an, darunter wieder alle Produkte von Hersteller "B"
Und so geht das dahin bis Hersteller "Z"

Soll nun ein Produkt bei Hersteller "C" eingetragen werden, bekommt dieser nicht die höchste Nummer, sondern alle Nummern welche unterhalb von Hersteller "C" eingetragen wurden rücken um eins nach hinten, sodass das letzte Produkt von Hersteller "Z" immer die höchste Nummer hat.

Ich hoffe irgendjemand kann mir schnellstmöglich helfen.

Vielen Dank schon mal im Voraus!
to top
#2
Hallo,

teste mal folgendes:
MAX($B$1:B1;B3:$B$1000)+1

Sonst wäre es per Vba einfach umsetzbar.
Gruß Atilla

Excel 2007
to top
#3
(31.03.2015, 13:34)atilla schrieb: Hallo,

teste mal folgendes:
MAX($B$1:B1;B3:$B$1000)+1

Sonst wäre es per Vba einfach umsetzbar.

Hallo Atilla,

Hab diese Formel probiert, leider vergebens - ich hab mal die Tabelle hochgeladen, zur besseren Vorstellung

Wie würdest du das mit VBA Lösen? bin eine gewaltige Niete in VBA!

Danke vorab!


Angehängte Dateien
.xlsx   Mappe1.xlsx (Größe: 11,43 KB / Downloads: 13)
to top
#4
Hallo Chris,

eine Lösung per Vba kann ich erst heute Abend aufzeigen.
Vom Prinzip her würde ich in einer Hilfszelle die zuletzt benutzte Nummer ablegen und dann bei neu Eingabe diese Nummer um eins erhöhen. Dann können Nummern auch nur einmal vergeben werden,
auch wenn in der Datentabelle Nummern gelöscht werden sollten.
Gruß Atilla

Excel 2007
to top
#5
(31.03.2015, 14:18)atilla schrieb: Hallo Chris,

eine Lösung per Vba kann ich erst heute Abend aufzeigen.
Vom Prinzip her würde ich in einer Hilfszelle die zuletzt benutzte Nummer ablegen und dann bei neu Eingabe diese Nummer um eins erhöhen. Dann können Nummern auch nur einmal vergeben werden,
auch wenn in der Datentabelle Nummern gelöscht werden sollten.

Hallo Atilla,

Ja das hab ich auch schon probiert (In einer Hilfszelle z.B. C1 mit Formel =MAX(B:B) den Maximalen Wert eingefügt)
Und dann in der Zelle B2 =WENN(A2<>"";$C$1+1;0) - Leider bekomme ich hier einen Zirkelbezug, somit funktioniert das auch nicht.
Bei deiner Formel bekomm ich übrigens auch einen Zirkelbezug...

LG
to top
#6
Hallo Chris,

meine letzte Beschreibung bezog sich auf eine Vba Lösung.
Wie gesagt, eine dahingehende Lösung kann ich erst heute Abend zeigen.
Gruß Atilla

Excel 2007
to top
#7
Auch Hallo,

wenn ich es richtig verstanden habe, könnte es auch mit

PHP-Code:
ZÄHLENWENN(A$1:A1;A1
gehen.

Nachtrag: Ich habe es falsch verstanden. Obiges Teil geht nicht.
Gruß Stefan
Win 7 / Office 2007
to top
#8
Hola,

Glückwunsch! In 2 Foren Helfer beschäfigt.

http://www.herber.de/forum/messages/1418176.html

Gruß,
steve1da
to top
#9
Hallo Chris,

wenn Du in mehreren Foren nachfragst, dann solltest Du in allen auf diesen Umstand hinweisen. Das ist respektvoller den Helfern gegenüber.

Die Vba Lösung im anderen Forum geht solange gut, solange Du zwischendurch keine Werte in Spalte A löschst oder überschreibst.
Gruß Atilla

Excel 2007
to top
#10
So sorry, das war respektlos von mir!

Aber ich suche eben schon dringend eine Lösung und es dauert...
Aber gut.

Die VBA Lösung funktioniert bei mir irgendwie nicht! Wenn ich den Code wie beschrieben einfüge, dann tut sich gar nichts!
Ich kann das Makro nicht aktivieren!
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Automatische Übertragung von Excel zu Word TaperJeanGirl 3 43 01.12.2016, 11:19
Letzter Beitrag: User17330
  suche Macro fuer automatische Gruppierung FR-CGI 3 83 21.11.2016, 18:03
Letzter Beitrag: FR-CGI
  Automatische Zuordnung von Werten :-(?? Adenzl 6 115 17.11.2016, 11:08
Letzter Beitrag: schauan
  Automatische Sortierung zweier Werte Firason 5 97 16.11.2016, 17:54
Letzter Beitrag: shift-del
  Automatische Eintragung... dreamer84 17 364 25.10.2016, 22:43
Letzter Beitrag: dreamer84
  Automatische Summenbildung HBVAW 5 101 17.10.2016, 13:43
Letzter Beitrag: HBVAW
  Year To Date automatische Umsatzrechnung Sascha1990 6 255 13.09.2016, 12:18
Letzter Beitrag: Sascha1990
  Automatische Abfrage mehrerer Inhalte dsievert 13 600 25.08.2016, 08:31
Letzter Beitrag: steve1da
  Lösung zu: Automatische sortierung der Tische Gast 123 2 213 17.08.2016, 15:32
Letzter Beitrag: Gast 123
  Automatische sortierung der Tische Rabe79 127 5.193 16.08.2016, 05:45
Letzter Beitrag: Rabe79

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste