Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Werte einer Spalte in anderer Spalte suchen?
#1
hallo,

ich habe eine Mustermappe beigefügt.

Hilfe benötigt entweder per Formel oder VBA


Es sollen die Werte der Spalte AA in der Spalte N gesucht werden
ist der Wert in Spalte N gefunden soll der dazugehörige Wert der
Spalte A ausgegeben werden

ABER nur dann, wenn der Wert kleiner als Z1 ist


Hat jemand eine Idee?

LG
Angelina


Angehängte Dateien
.xls   Vergleichswert-suchen.xls (Größe: 47 KB / Downloads: 9)
to top
#2
Hallo,

suchst du etwas das in diese Richtung geht?

=WENN(INDEX(A:A;VERGLEICH(AA1;N:N;0))<=Z$1;INDEX(A:A;VERGLEICH(AA1;N:N;0));0)
Gruß
Peter
to top
#3
Hallo,

suchst du etwas das in diese Richtung geht?

=WENN(INDEX(A:A;VERGLEICH(AA1;N:N;0))<=Z$1;INDEX(A:A;VERGLEICH(AA1;N:N;0));0)

Was soll passieren wenn der Wert nicht gefunden wird: die Formel gibt in diesem Fall ein #NV aus.
Gruß
Peter
to top
#4
(29.03.2015, 14:56)Peter schrieb: Hallo,

suchst du etwas das in diese Richtung geht?

=WENN(INDEX(A:A;VERGLEICH(AA1;N:N;0))<=Z$1;INDEX(A:A;VERGLEICH(AA1;N:N;0));0)

Was soll passieren wenn der Wert nicht gefunden wird: die Formel gibt in diesem Fall ein #NV aus.


hallo Peter,

das schaut schon soweit perfekt aus. Danke für deine Zeit/Mühe

Nur gibt es noch ein kleines Problem.

Es kann eigentlich nicht sein das keine Werte gefunden werden - meine Datenbank ist länger-größer
habe ich ja nur ein Auszug davon in der Mappe.

Das Problem ist noch folgendes.

Spalte A stehen die Werte ja absteigend sortiert
Wenn nun in Z1 ein Wert steht - dürfen die Werte nur genommen werden, die <= dem Wert aus Z1 sind.

Verstehst du mich?

LG
Angelina
to top
#5
Hallo,

Zitat:Es kann eigentlich nicht sein das keine Werte gefunden werden - meine Datenbank ist länger-größer
habe ich ja nur ein Auszug davon in der Mappe.

Naja, bei deinen Beispielswerten habe ich ein #NV erhalten, aber wenn du nur einen Teil deiner Tabelle gepostet hast, dann könnte das die Erklärung dafür sein.
Gruß
Peter
to top
#6
(29.03.2015, 16:03)Peter schrieb: Hallo,


Zitat:Es kann eigentlich nicht sein das keine Werte gefunden werden - meine Datenbank ist länger-größer
habe ich ja nur ein Auszug davon in der Mappe.

Naja, bei deinen Beispielswerten habe ich ein #NV erhalten, aber wenn du nur einen Teil deiner Tabelle gepostet hast, dann könnte das die Erklärung dafür sein.

hallo nochmals,

ja - aber die Formel ist noch nicht ganz perfekt

Der Wert in Z1 soll besagen, das in der Spalte A erst die Zeilen genommen und gesucht werden darf
wenn kleiner gleich Z1 ist

LG
Angelina
to top
#7
Hallo,

nein, ich verstehe im Moment nicht auf was du genau hinaus willst - ich habe manchmal eine sehr lange Leitung.

Geraten:

=WENN(A1<=Z$1;INDEX(A:A;VERGLEICH(AA1;N:N;0));0)

Wenn ich damit daneben liege dann poste mal die Wunschergebnisse für AD1 bis AD20 - vielleicht verstehe ich dein Vorhaben dann besser.
Gruß
Peter
to top
#8
Hallo

Vielleicht so?
 AE
13101

ZelleFormel
AE1=VERWEIS(42;1/($N$1:$N$195=AA1)/($A$1:$A$195<$Z$1);$A$1:$A$195)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
to top
#9
(29.03.2015, 16:16)Peter schrieb: Hallo,

nein, ich verstehe im Moment nicht auf was du genau hinaus willst - ich habe manchmal eine sehr lange Leitung.

Geraten:

=WENN(A1<=Z$1;INDEX(A:A;VERGLEICH(AA1;N:N;0));0)

Wenn ich damit daneben liege dann poste mal die Wunschergebnisse für AD1 bis AD20 - vielleicht verstehe ich dein Vorhaben dann besser.

hallo nein leider nicht

Nochmals ganz laaaaaangsam

1. Formel für Spalte AD gesucht
2. Werte aus Spalte AA sollen in Spalte N gesucht werden
soweit denke ich hast du es verstanden

3. Jetzt haben wir in Spalte A Werte stehen und in Z1 steht ein Wert
Die Zeilen die in Spalte A stehen dürfen erst ab dem Wert genommen werden der kleiner = Z1 ist.
Damit soll die Suche eingeschränkt werden. Nicht von A1 bis Dateiende suchen, sondern erst ab
der Zeile A deren Wert kleiner = Z1 ist


LG
Angelina
to top
#10
Hallo, das hat hier mit dem Erklären auch nur suboptimal geklappt...

http://ms-office-forum.net/forum/showthr...p?t=321194
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Matrix bzw. Schnittpunkt der gesuchten Werte in einer Tabelle suchen Wolf59 5 65 08.12.2016, 20:59
Letzter Beitrag: Wolf59
  Dynamische Summe pro Spalte und Woche nycrom 8 110 08.12.2016, 20:42
Letzter Beitrag: schauan
Question Wie ordne ich Zeilen entsprechend einer Spalte alphabetisch? Olivenbaum2013 9 94 08.12.2016, 11:57
Letzter Beitrag: BoskoBiati
Question Zeilen entsprechend den Einträgen in einer Spalte automatisch alphabetisch ordnen. Olivenbaum2013 7 89 06.12.2016, 08:37
Letzter Beitrag: Olivenbaum2013
  Werte Zusammenzählen mit Suchkriterium in einer anderen Spalte EDmen 6 76 05.12.2016, 20:49
Letzter Beitrag: EDmen
  Wert suchen in Spalte und wert da neben ausgeben VBA michel34497 2 50 02.12.2016, 23:33
Letzter Beitrag: michel34497
  Spalte unsichbar machen aber trotzdem Daten nutzen Marius4444 3 53 18.11.2016, 12:36
Letzter Beitrag: chris-ka
  wenn in tabelle wert in spalte dann neue spalte in neuer tabelle merzens 4 102 16.11.2016, 13:44
Letzter Beitrag: schauan
  Formeln in Spalte ändern Icepic 14 316 16.11.2016, 11:30
Letzter Beitrag: Icepic
  Spalte mit Zahlenblock befüllen Greatbrian 9 168 14.11.2016, 21:19
Letzter Beitrag: WillWissen

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste