Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Werte einer Spalte in anderer Spalte suchen?
#1
hallo,

ich habe eine Mustermappe beigefügt.

Hilfe benötigt entweder per Formel oder VBA


Es sollen die Werte der Spalte AA in der Spalte N gesucht werden
ist der Wert in Spalte N gefunden soll der dazugehörige Wert der
Spalte A ausgegeben werden

ABER nur dann, wenn der Wert kleiner als Z1 ist


Hat jemand eine Idee?

LG
Angelina


Angehängte Dateien
.xls   Vergleichswert-suchen.xls (Größe: 47 KB / Downloads: 9)
to top
#2
Hallo,

suchst du etwas das in diese Richtung geht?

=WENN(INDEX(A:A;VERGLEICH(AA1;N:N;0))<=Z$1;INDEX(A:A;VERGLEICH(AA1;N:N;0));0)
Gruß
Peter
to top
#3
Hallo,

suchst du etwas das in diese Richtung geht?

=WENN(INDEX(A:A;VERGLEICH(AA1;N:N;0))<=Z$1;INDEX(A:A;VERGLEICH(AA1;N:N;0));0)

Was soll passieren wenn der Wert nicht gefunden wird: die Formel gibt in diesem Fall ein #NV aus.
Gruß
Peter
to top
#4
(29.03.2015, 14:56)Peter schrieb: Hallo,

suchst du etwas das in diese Richtung geht?

=WENN(INDEX(A:A;VERGLEICH(AA1;N:N;0))<=Z$1;INDEX(A:A;VERGLEICH(AA1;N:N;0));0)

Was soll passieren wenn der Wert nicht gefunden wird: die Formel gibt in diesem Fall ein #NV aus.


hallo Peter,

das schaut schon soweit perfekt aus. Danke für deine Zeit/Mühe

Nur gibt es noch ein kleines Problem.

Es kann eigentlich nicht sein das keine Werte gefunden werden - meine Datenbank ist länger-größer
habe ich ja nur ein Auszug davon in der Mappe.

Das Problem ist noch folgendes.

Spalte A stehen die Werte ja absteigend sortiert
Wenn nun in Z1 ein Wert steht - dürfen die Werte nur genommen werden, die <= dem Wert aus Z1 sind.

Verstehst du mich?

LG
Angelina
to top
#5
Hallo,

Zitat:Es kann eigentlich nicht sein das keine Werte gefunden werden - meine Datenbank ist länger-größer
habe ich ja nur ein Auszug davon in der Mappe.

Naja, bei deinen Beispielswerten habe ich ein #NV erhalten, aber wenn du nur einen Teil deiner Tabelle gepostet hast, dann könnte das die Erklärung dafür sein.
Gruß
Peter
to top
#6
(29.03.2015, 16:03)Peter schrieb: Hallo,


Zitat:Es kann eigentlich nicht sein das keine Werte gefunden werden - meine Datenbank ist länger-größer
habe ich ja nur ein Auszug davon in der Mappe.

Naja, bei deinen Beispielswerten habe ich ein #NV erhalten, aber wenn du nur einen Teil deiner Tabelle gepostet hast, dann könnte das die Erklärung dafür sein.

hallo nochmals,

ja - aber die Formel ist noch nicht ganz perfekt

Der Wert in Z1 soll besagen, das in der Spalte A erst die Zeilen genommen und gesucht werden darf
wenn kleiner gleich Z1 ist

LG
Angelina
to top
#7
Hallo,

nein, ich verstehe im Moment nicht auf was du genau hinaus willst - ich habe manchmal eine sehr lange Leitung.

Geraten:

=WENN(A1<=Z$1;INDEX(A:A;VERGLEICH(AA1;N:N;0));0)

Wenn ich damit daneben liege dann poste mal die Wunschergebnisse für AD1 bis AD20 - vielleicht verstehe ich dein Vorhaben dann besser.
Gruß
Peter
to top
#8
Hallo

Vielleicht so?
 AE
13101

ZelleFormel
AE1=VERWEIS(42;1/($N$1:$N$195=AA1)/($A$1:$A$195<$Z$1);$A$1:$A$195)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
to top
#9
(29.03.2015, 16:16)Peter schrieb: Hallo,

nein, ich verstehe im Moment nicht auf was du genau hinaus willst - ich habe manchmal eine sehr lange Leitung.

Geraten:

=WENN(A1<=Z$1;INDEX(A:A;VERGLEICH(AA1;N:N;0));0)

Wenn ich damit daneben liege dann poste mal die Wunschergebnisse für AD1 bis AD20 - vielleicht verstehe ich dein Vorhaben dann besser.

hallo nein leider nicht

Nochmals ganz laaaaaangsam

1. Formel für Spalte AD gesucht
2. Werte aus Spalte AA sollen in Spalte N gesucht werden
soweit denke ich hast du es verstanden

3. Jetzt haben wir in Spalte A Werte stehen und in Z1 steht ein Wert
Die Zeilen die in Spalte A stehen dürfen erst ab dem Wert genommen werden der kleiner = Z1 ist.
Damit soll die Suche eingeschränkt werden. Nicht von A1 bis Dateiende suchen, sondern erst ab
der Zeile A deren Wert kleiner = Z1 ist


LG
Angelina
to top
#10
Hallo, das hat hier mit dem Erklären auch nur suboptimal geklappt...

http://ms-office-forum.net/forum/showthr...p?t=321194
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Angeklickte Spalte Schrift + Farbe ändern hbboy15 2 24 Vor 11 Stunden
Letzter Beitrag: RPP63
  Werte in einer Zeile addieren bis Zielwert erreicht und verwendete Werte markieren hoteu 2 51 12.01.2017, 13:04
Letzter Beitrag: hoteu
  Werte aus verschiedenen Zellen auslesen und in einer Zelle eintragen Robbie1985 2 43 07.01.2017, 10:39
Letzter Beitrag: WillWissen
  MW der letzten 5 Werte einer Spalte tröntken 6 96 05.01.2017, 07:57
Letzter Beitrag: tröntken
  Dynamische Summe pro Spalte und Woche nycrom 12 236 30.12.2016, 09:40
Letzter Beitrag: BoskoBiati
  2 Werte mit definierten Kriterien aus einer Zelle Multiplizieren heppi14 6 134 28.12.2016, 23:29
Letzter Beitrag: Jockel
Question Wie ordne ich Zeilen entsprechend einer Spalte alphabetisch? Olivenbaum2013 24 350 16.12.2016, 20:57
Letzter Beitrag: schauan
  gleichen Namen in Spalte suchen und Zeilen miteinander subtrahieren Hanswurst1234 6 117 16.12.2016, 19:48
Letzter Beitrag: neopa
  Matrix bzw. Schnittpunkt der gesuchten Werte in einer Tabelle suchen Wolf59 5 105 08.12.2016, 20:59
Letzter Beitrag: Wolf59
Question Zeilen entsprechend den Einträgen in einer Spalte automatisch alphabetisch ordnen. Olivenbaum2013 7 158 06.12.2016, 08:37
Letzter Beitrag: Olivenbaum2013

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste