Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Maximaler Verlust in einer Serie ausrechnen lassen.
#1
Hallo zusammen

Ich bin ein Excel Anfänger. Alles was über einfachen Formeln wie das zusammenrechnen einer Spalte hinausgeht, bekomme ich nicht mehr hin.  22 Ich weiss aber das man vieles mit Formeln hinbekommt, wenn man sie noch dazu kombiniert. Nur der Weg bis dahin ist kompliziert. Vielleicht könnt ihr mir ja helfen und eine Lösung geben. Das wäre Super.

Ich habe für mein Anliegen ein Bild dazu.

?mage

Ich würde bei der Spalte "Ergebnis" gerne den maximalen Verlust, einer Verlustserie ausrechnen lassen.

Verlustserien sieht man bei
Spalte A6-A7= -40
Spalte A11-A12= -15
Spalte A16-A19= -50

Die Buchstaben sind eigentlich nur für das Filtern da um schnell Gewinne oder Verluste herauszufiltern. Ich weiss nicht ob man sie miteinbinden muss. Oder was einfacher ist. Mit oder ohne Buchstaben.

Der Grösste Verlust bei den ganzen Verlustserien war bei A16-A19 mit -50. und das sollte auch das Ergebnis sein.

Ich Hoffe ich habe das verständlich beschrieben und bitte um Hilfe.

Danke und einen schönen Sonntag noch

Lethandro
to top
#2
Hallo Lethandro

war das dein Ziel?

Tabelle3

AB
1Gewinne/VerlusteErgebnis
210-80
312in Zeile 9
415
5-40
6-22
722
845
9-80
1090
11100
Formeln der Tabelle
ZelleFormel
B2=MIN(A:A)
B3=VERGLEICH($B$2;A:A;0)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#3
Hallo Günter,

Lethandro meint das anders.

Er sucht die größte Summe aneinanderhängender negativen Zahlen=Verluste,
also in seinem Fall die Zellen A16 bis A19
Gruß Conny Smile
_______________________________________________________________

Ich habe keine Lösung, aber ich bewundere dein Problem !
to top
#4
Hallo Günter

Danke für deine Antwort. Es ist so wie Conny geschrieben hat.

Es müssen mindestens 2 aneinanderhängende Verluste gefunden und davon die grösste Summe ausgerechnet werden.

lg
Erich
to top
#5
Hi Erich,

schau mal, ob das so passt:

Tabelle1

ABCD
1Gewinne/Verluste
2-10-10-Größter Verlust: 107
3-20-20
420-30
5300
6400
7-10-10
8-20-20
9-30-30
10-40-40
1160-100
12900
131000
141100
151200
16-22-22
17-45-45
18-40-40
1910-107
20200
21300
Formeln der Tabelle
ZelleFormel
B2=WENN(A2<0;A2;"")
C2=WENN(B2="";SUMME($B$2:B2)-SUMME($C1:C$2);"")
D2=MIN(C:C)
B3=WENN(A3<0;A3;"")
C3=WENN(B3="";SUMME($B$2:B3)-SUMME($C2:C$2);"")
B4=WENN(A4<0;A4;"")
C4=WENN(B4="";SUMME($B$2:B4)-SUMME($C$2:C3);"")
B5=WENN(A5<0;A5;"")
C5=WENN(B5="";SUMME($B$2:B5)-SUMME($C$2:C4);"")
B6=WENN(A6<0;A6;"")
C6=WENN(B6="";SUMME($B$2:B6)-SUMME($C$2:C5);"")
B7=WENN(A7<0;A7;"")
C7=WENN(B7="";SUMME($B$2:B7)-SUMME($C$2:C6);"")
B8=WENN(A8<0;A8;"")
C8=WENN(B8="";SUMME($B$2:B8)-SUMME($C$2:C7);"")
B9=WENN(A9<0;A9;"")
C9=WENN(B9="";SUMME($B$2:B9)-SUMME($C$2:C8);"")
B10=WENN(A10<0;A10;"")
C10=WENN(B10="";SUMME($B$2:B10)-SUMME($C$2:C9);"")
B11=WENN(A11<0;A11;"")
C11=WENN(B11="";SUMME($B$2:B11)-SUMME($C$2:C10);"")
B12=WENN(A12<0;A12;"")
C12=WENN(B12="";SUMME($B$2:B12)-SUMME($C$2:C11);"")
B13=WENN(A13<0;A13;"")
C13=WENN(B13="";SUMME($B$2:B13)-SUMME($C$2:C12);"")
B14=WENN(A14<0;A14;"")
C14=WENN(B14="";SUMME($B$2:B14)-SUMME($C$2:C13);"")
B15=WENN(A15<0;A15;"")
C15=WENN(B15="";SUMME($B$2:B15)-SUMME($C$2:C14);"")
B16=WENN(A16<0;A16;"")
C16=WENN(B16="";SUMME($B$2:B16)-SUMME($C$2:C15);"")
B17=WENN(A17<0;A17;"")
C17=WENN(B17="";SUMME($B$2:B17)-SUMME($C$2:C16);"")
B18=WENN(A18<0;A18;"")
C18=WENN(B18="";SUMME($B$2:B18)-SUMME($C$2:C17);"")
B19=WENN(A19<0;A19;"")
C19=WENN(B19="";SUMME($B$2:B19)-SUMME($C$2:C18);"")
B20=WENN(A20<0;A20;"")
C20=WENN(B20="";SUMME($B$2:B20)-SUMME($C$2:C19);"")
B21=WENN(A21<0;A21;"")
C21=WENN(B21="";SUMME($B$2:B21)-SUMME($C$2:C20);"")

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8


Die markierten Spalten sind reine Hilfsspalten und können ausgeblendet werden.
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
Lethandro
to top
#6
Hallo,

die Formel in C2

=WENN(B2="";SUMME($B$2:B2)-SUMME($C1:C$2);"")

wirft einen Zirkelbezug aus wenn der Wert in B2 positiv ist. Müsste da nicht

=WENN(B2="";SUMME($B$2:B2)-SUMME($C1:C$1);"")

stehen?
Gruß
Peter
to top
#7
Hi Peter,


Zitat:Müsste da nicht


=WENN(B2="";SUMME($B$2:B2)-SUMME($C1:C$1);"")

stehen?

ganz klar. Ursprünglich hatte ich das auch, habe aber, weil mein Excel ein wenig rumgezickt hat, mein Muster in eine andere Instanz übernommen. Dabei habe ich wohl die falsche Zeile für die Ursprungsformel genommen und nach oben gezogen. Mea culpa.
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#8
Hallo,

da reicht eine Hilfsspalte:
Gruß


Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#9
(30.03.2015, 13:17)BoskoBiati schrieb: Hallo,

da reicht eine Hilfsspalte:


Arbeitsblatt mit dem Namen 'Tabelle1'
 ABC
1Gewinne/Verluste  
2-10-10-107
3-20-30 
4200 
5300 
6400 
7-10-10 
8-20-30 
9-30-60 
10-40-100 
11600 
12900 
131000 
141100 
151200 
16-22-22 
17-45-67 
18-40-107 
19100 
20200 
21300 

ZelleFormel
B2=WENN(A2>0;0;A2+WENN(A1<0;B1))
C2=MIN(B2:B21)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß


Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
Lethandro
to top
#10
Hallo zusammen

wow. Vielen Dank für eure Zeit die ihr euch genommen habt. Das ist ja Beeindruckend. Ihr habt mir sehr geholfen. Beide Varianten funktionieren Einwandfrei.

Ist es noch zusätzlich machbar, dass erst ab 2 verlusten anfängt zusammenzurechnen? Es ist im Moment so, dass wenn ich einen einzigen Verlust habe der grösser ist als alle anderen, wird er auch gewertet. Dieser sollte noch nicht gewertet werden. Erst wenn danach ein zweiter Verlust kommt, ist es eine Serie und wird zusammengerechnet.

Ich hab schon grossen Ansprüche was? :-)

Kann man das im Internet von Grund auf lernen? Gibt es da eine gute Lernseite die ihr empfehlen könnt? Ich bin jedesmal fasziniert von den Möglichkeiten :-)

lg
Erich
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  "Maximaler Wert" tauglich für Pivot formatieren Manu298 7 107 23.11.2016, 15:49
Letzter Beitrag: Manu298
  Tabelle oder Bereich über "Name" auswählen und anzeigen lassen Bernilli 7 202 30.09.2016, 12:17
Letzter Beitrag: Ego
Sad Formelwerte lassen sich nicht ändern Pivo 3 210 20.09.2016, 08:59
Letzter Beitrag: Rabe
Question Farbfelder zählen lassen - #BEZUG! Problem!? Yankee93 14 648 02.09.2016, 08:04
Letzter Beitrag: Yankee93
Question Über bed. Formatierung Geburtstage im Monatskalender anzeigen lassen Lusche800 21 762 01.09.2016, 09:23
Letzter Beitrag: Lusche800
  in buchhaltungsformat 0 anzeigen lassen? Lukaslukas 2 204 18.07.2016, 11:57
Letzter Beitrag: Lukaslukas
  atenüberprüfungsfeld beim start mit einer leeren Zeile anzeigen lassen seyan1408 10 562 29.06.2016, 13:06
Letzter Beitrag: seyan1408
  Leere Werte in Pivot anzeigen lassen Cp525 2 256 15.06.2016, 13:02
Letzter Beitrag: Peter
  [Fußball]Punkte aus Ergebnissen automatisch berechnen lassen SJL10 10 876 22.05.2016, 19:53
Letzter Beitrag: SJL10
  Sieger anzeigen lassen SJL10 21 1.032 14.05.2016, 07:28
Letzter Beitrag: shift-del

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste