Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Entwicklung Blutzuckerwerte prozentual darstellen
#1
Hallo zusammen!!!

Bin absoluter Excel Neuling und will aber, da ich Diabetiker bin, die prozentualen Entwicklungen meiner Blutzuckerwerte  in einer Exceldatei darstellen. Leider habe ich keinen Plan, wie das geht. Könntet Ihr mir vielleicht dabei helfen, da das sehr sehr wichtig für mich wäre?!

Ich habe hier drei Werte: Blutzucker heute (z.B. Zelle A8), Blutzucker gestern  (z.B. Zelle A7) und Blutzucker gleicher Tag Vorwoche (z.B. Zelle A 1).

Die Formel in Zelle B 8 (prozentuale Veränderung zum Vortag) sollte folgendermaßen aussehen:

- Wenn A8 leer, dann schreibe nichts

- Wenn A8 = A7 (Wert Vortag) dann schreibe 0 Prozent schwarz

- Wenn A8 höher als A7 dann schreibe Prozentzahl rot

- Wenn A8 niedriger als A 7 dann schreibe Prozentzahl grün

Das gleiche analog zum gleichen Tag der Vorwoche

Kann man so etwas überhaupt darstellen, und wenn ja, wie würde das aussehen? Wäre echt nett und für mich sehr wichtig, wenn Ihr mir da helfen könntet!!!

Vielen Dank schon mal!!!!
to top
#2
Hi Kurt,

(25.03.2015, 12:52)Kurt1958 schrieb: Kann man so etwas überhaupt darstellen, und wenn ja, wie würde das aussehen? Wäre echt nett und für mich sehr wichtig, wenn Ihr mir da helfen könntet!!!

so?
Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCD
1160  BZ Vorwoche
2    
3    
4    
5    
6    
7140zu gesternzu VorwocheBZ gestern
8150107%94%BZ heute

ZelleFormatWert
B80%1,07142857142857
C80%0,9375

ZelleFormel
B8=WENN(A8=A7;0;A8/A7)
C8=WENN(A8=A1;0;A8/A1)

Zellebedingte Formatierung...Format
B81: =$A$8<$A$7abc
B82: =$A$8>$A$7abc
C81: =$A$8<$A$1abc
C82: =$A$8>$A$1abc
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top
#3
Danke für die suuuuuuper schnelle Antwort, kann man auch nur die Zahlen selber einfärben und den Hintergrund der Zelle weiss lassen?
to top
#4
Hallo Kurt,

... wie würde das aussehen? Wäre echt nett und für mich sehr wichtig, ...

Ich bin seit etwa 1 1/2 Jahren auch Diabetiker Typ II (Insulinpflichtig) ... also noch in der Lernphase.
Verrätst Du mir, warum diese Werte wichtig sein können?
Ich Danke Dir schon mal
________________________________________________________________________
wer aufgibt, ohne es versucht zu haben, gibt einfach nur auf!

?mage
to top
#5
Hallo Ralf,

vielen vielen Dank!! Werde mich gleich mal dransetzen und die Tabelle machen, falls es nicht klappt, bzw. ich mal wieder was nicht blicke, dann meld ich mich noch mal!!!!

Hallo Blaubär,

werde gerade auf Insulin eingestellt, deshalb ist die Entwicklung des Blutzuckers für mich wichtig. Falls Du die Tabelle willst und ich habe sie erstellt und alles klappt, dann kann ich sie Dir ja auch mailen, wenn Du was damit anfangen kannst?!

Gruss

Kurt 1958
to top
#6
Hallo Kurt,
... werde gerade auf Insulin eingestellt, ...

dann bist Du ja noch mehr Frischling als ich es bin. Das hätte ich nicht vermutet. 19
Natürlich kannst Du mir Deine Datei zumailen oder per PN schicken.
Danke schonmal vorab dafür
________________________________________________________________________
wer aufgibt, ohne es versucht zu haben, gibt einfach nur auf!

?mage
to top
#7
Hi Kurt,

(25.03.2015, 13:14)Kurt1958 schrieb: Danke für die suuuuuuper schnelle Antwort, kann man auch nur die Zahlen selber einfärben und den Hintergrund der Zelle weiss lassen?

in meinem eingestellten Ausschnitt ist doch die Schrift gefärbt und nicht der Hintergrund.
Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
[-] Folgende(r) 1 Benutzer sagt Danke an Rabe für diesen Beitrag:
Kurt1958
to top
#8
Hallo,

ich bin's nochmal. War jetzt den ganzen Nachmittag dran kriege es aber nicht gebacken! Habe halt noch nie was mit Tabellenkalkulationen zu tun gehabt, bin schon total aufgelöst. Als Anhang habe ich die Datei angehängt so wie sie am Ende aussehen sollte. Könnt Ihr mr da nochmal mit den Formeln helfen!!?? Vielen Dank!!!!


Angehängte Dateien
.xlsx   Mappe2.xlsx (Größe: 9,28 KB / Downloads: 5)
to top
#9
Hi Kurt,

passt das so?


Tabelle1

ABC
1DatumBlutzuckerwertDiff. % Vortag
218.03.2015100
319.03.201511010%
420.03.201510010%
521.03.20158025%
622.03.2015600650%
723.03.201560900%
824.03.2015400567%
925.03.2015200100%
1026.03.2015100100%
1127.03.20151000%
1228.03.20158025%
1329.03.2015nichtsnichts
1430.03.2015nichtsnichts
1531.03.2015nichtsnichts
Formeln der Tabelle
ZelleFormel
C3=WENN(B3="nichts";"nichts";WENN(B3>B2;B3/B2-1;B2/B3-1))
C4=WENN(B4="nichts";"nichts";WENN(B4>B3;B4/B3-1;B3/B4-1))
C5=WENN(B5="nichts";"nichts";WENN(B5>B4;B5/B4-1;B4/B5-1))
C6=WENN(B6="nichts";"nichts";WENN(B6>B5;B6/B5-1;B5/B6-1))
C7=WENN(B7="nichts";"nichts";WENN(B7>B6;B7/B6-1;B6/B7-1))
C8=WENN(B8="nichts";"nichts";WENN(B8>B7;B8/B7-1;B7/B8-1))
C9=WENN(B9="nichts";"nichts";WENN(B9>B8;B9/B8-1;B8/B9-1))
C10=WENN(B10="nichts";"nichts";WENN(B10>B9;B10/B9-1;B9/B10-1))
C11=WENN(B11="nichts";"nichts";WENN(B11>B10;B11/B10-1;B10/B11-1))
C12=WENN(B12="nichts";"nichts";WENN(B12>B11;B12/B11-1;B11/B12-1))
C13=WENN(B13="nichts";"nichts";WENN(B13>B12;B13/B12-1;B12/B13-1))
C14=WENN(B14="nichts";"nichts";WENN(B14>B13;B14/B13-1;B13/B14-1))
C15=WENN(B15="nichts";"nichts";WENN(B15>B14;B15/B14-1;B14/B15-1))
Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
C31. / Formel ist =$C3=0Abc
C32. / Formel ist =$B3<$B2Abc
C33. / Formel ist =$B3>$B$2Abc
C41. / Formel ist =$C3=0Abc
C42. / Formel ist =$B3<$B2Abc
C43. / Formel ist =$B3>$B$2Abc
C51. / Formel ist =$C3=0Abc
C52. / Formel ist =$B3<$B2Abc
C53. / Formel ist =$B3>$B$2Abc
C61. / Formel ist =$C3=0Abc
C62. / Formel ist =$B3<$B2Abc
C63. / Formel ist =$B3>$B$2Abc
C71. / Formel ist =$C3=0Abc
C72. / Formel ist =$B3<$B2Abc
C73. / Formel ist =$B3>$B$2Abc
C81. / Formel ist =$C3=0Abc
C82. / Formel ist =$B3<$B2Abc
C83. / Formel ist =$B3>$B$2Abc
C91. / Formel ist =$C3=0Abc
C92. / Formel ist =$B3<$B2Abc
C93. / Formel ist =$B3>$B$2Abc
C101. / Formel ist =$C3=0Abc
C102. / Formel ist =$B3<$B2Abc
C103. / Formel ist =$B3>$B$2Abc
C111. / Formel ist =$C3=0Abc
C112. / Formel ist =$B3<$B2Abc
C113. / Formel ist =$B3>$B$2Abc
C121. / Formel ist =$C3=0Abc
C122. / Formel ist =$B3<$B2Abc
C123. / Formel ist =$B3>$B$2Abc
C131. / Formel ist =$C3=0Abc
C132. / Formel ist =$B3<$B2Abc
C133. / Formel ist =$B3>$B$2Abc
C141. / Formel ist =$C3=0Abc
C142. / Formel ist =$B3<$B2Abc
C143. / Formel ist =$B3>$B$2Abc
C151. / Formel ist =$C3=0Abc
C152. / Formel ist =$B3<$B2Abc
C153. / Formel ist =$B3>$B$2Abc

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8



Die Schriftfarbe aus der bedingten Formatierung ist leider nicht sichtbar - deshalb zum Ansehen noch zusätzlich ein Screenshot.

   
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
Kurt1958
to top
#10
Hallo,

vielen Dank!! Das mit den Formeln funktioniert einwandfrei!!! Aber wo gebe ich die Formeln für die bedingten Formatierungen ein??
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Zahl korrekt darstellen newnew 6 64 04.12.2016, 18:46
Letzter Beitrag: RPP63
  Veränderung des Mittelwerts graphisch darstellen moson 5 93 14.11.2016, 19:46
Letzter Beitrag: moson
  Nicht-Numerische Werte als Prozentzahlen und dann als Tortendiagramm darstellen RobExcelBob 9 153 29.10.2016, 11:59
Letzter Beitrag: RobExcelBob
  VBA Text in PowerPoint darstellen raw90 2 119 14.10.2016, 20:39
Letzter Beitrag: snb
  Daten aus Zeilen in Spalten darstellen AngelaW 6 409 30.07.2016, 07:36
Letzter Beitrag: Rabe
  Zeitabschnitte aus Start- und Endzeit darstellen Morkar 1 213 18.07.2016, 06:26
Letzter Beitrag: Rabe
  Excel : Text nach Extension (Erweiterung) farbig darstellen Sir Anthony 5 426 04.07.2016, 07:18
Letzter Beitrag: RPP63
  Pivot-Tabelle auf einer Zeichnung darstellen mw210 1 289 23.04.2016, 11:43
Letzter Beitrag: schauan
  Bilder in Excel darstellen themanfrommoon 6 870 29.02.2016, 09:21
Letzter Beitrag: Kuwer
  Daten für einen Zeitraum durch Eingabefeld darstellen sveninho11 15 1.147 05.02.2016, 19:19
Letzter Beitrag: GMG-CC

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste