Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

"Zählenwenn" bei bestimmtem Wertebereich und bestimmten Zellen
#1
Hallo Leute,

ich stehe gerade vor einem Problem bei einer Tabelle, die ich im Excel aufbauen möchte und hoffe, dass ihr mir helfen könnt.

Ich würde gerne die Funktion "ZählenWenn" benutzen, allerdings soll diese nur auf jedes vierte Feld der Tabelle angewendet werden und auch dann nur, wenn der enthaltene Wert in der Zelle ungleich 0 ist.
Ein Beispiel:

A1: 5
A2: 3
A3: 4
A4: 0 (soll geprüft werden: Wird nicht gezählt, weil 0)
A5: 2
A6: 3
A7: 3
A8: 1 (soll geprüft werden: Wird gezählt, weil ungleich 0)
...
A200: ZählenWenn-Ausgabe

Grüße
Jubeldibub
to top
#2
Hola,

meinst du das so? (für den Bereich A1 bis A100):


Code:
=SUMMENPRODUKT((REST(ZEILE(1:100);4)=0)*(A1:A100<>0))


Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
Jubeldibub
to top
#3
Perfekt, Steve Smile Tausend Dank!

Noch eine kleine Zusatzfrage: Kann man auch mehrere Werte von der Zählung ausschließen? Z.B. nicht nur die Nullen, sondern auch bestimmte Zeichen (z.B. "-")?
to top
#4
Hola,

so?


Code:
=SUMMENPRODUKT((REST(ZEILE(1:100);4)=0)*(A1:A100<>0)*(A1:A100<>"-"))


Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
Jubeldibub
to top
#5
Genau! Danke Smile
to top
#6
Ein Ausschluss bestimmter Zellen bei der Zählung anhand der dort verwendeten Schriftfarbe ist aber nicht möglich, oder?
to top
#7
Hola,

sind die Zellen über die bedingte Formatierung gefärbt, oder per Hand?

Gruß,
steve1da
to top
#8
Derzeit noch per Hand (wobei auch nicht die Zellen gefärbt sind, sondern die Schrift der enthaltenen Daten). Würde das einen Unterschied für die Umsetzbarkeit machen? Ansonsten könnte ich es auch auf Bedingte Formatierung und eine passende Zellfärbung umstellen.

Grüße
Jubeldibub
to top
#9
Hola,

einen großen Unterschied. Farben auslesen ist recht schwierig. Bei einer bedingten Formatierung weißt du ja, wann gefärbt wird - das kann man formelmäßig dann bestimmt einbauen.


Gruß,
steve1da
to top
#10
Ah okay, verstehe. Dann passt es so wie es ist, die Formel deckt es ja ab. Nochmals Danke!
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Summenprodukt und Zählenwenn Denitschki 2 50 21.03.2017, 14:54
Letzter Beitrag: Denitschki
  Zelle ab bestimmtem mehrfachen Zeichen auslesen? xlsxvba 4 84 16.03.2017, 12:41
Letzter Beitrag: snb
  Probleme mit "ZÄHLENWENN" Ouriso 4 62 10.03.2017, 13:25
Letzter Beitrag: Ouriso
  ZählenWenn mit index cult 16 312 01.03.2017, 13:52
Letzter Beitrag: shift-del
  Makro kann kopiert Wertebereich nicht wenn Tabelle ausgeblendet ist Eistee 6 166 06.02.2017, 13:38
Letzter Beitrag: Eistee
  Zellen sperren bei bestimmten Bedingungen (ja/nein) PhiLa303 7 210 03.02.2017, 18:19
Letzter Beitrag: schauan
  ZÄHLENWENN... Rooneybob 2 140 28.01.2017, 12:38
Letzter Beitrag: Rooneybob
  DropDown-Liste mit Wertebereich TaylorGangHRO 4 208 19.01.2017, 13:31
Letzter Beitrag: atilla
  Auflistung nach bestimmtem Argument Doon 7 320 29.11.2016, 23:57
Letzter Beitrag: Jockel
  Nur zellen mit bestimmten Wert kopieren teufelchenbs 1 206 25.11.2016, 22:25
Letzter Beitrag: schauan

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste