Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


SVERWEIS 2 Tabellen mit Texten
#1
Hallo,

ich hab da eine Frage.

Habe zwei Tabellen. Eine ist mehrspaltig und erhält in einerSpalte das Suchkriterium in der Form von Texten.
Die zweite Tabelle enthält lediglich eine Spalte und ebenfalls Texte, die jedoch im Gegensatz zu den Texten in Tabelle 1 eine führnde Zahl haben, also ungefähr so:

Tabelle 1:

Sport
Musik
Freizeit
etc.

Tabelle 2:

1 Musik
2 Sport
3 Freizeit
....


Jetzt soll der Text aus Tabelle 1 mit Tabelle 2 verglichen werden und wenn gefunden in Tabelle drei der Text aus Tabelle 2 wiedergegeben.

Hört sich verwirrend an, ich weiß. Ohne die Führende Ziffer ist das ganze mit SVERWEIS kein Problem, aber gehts auch mit?
to top
#2
Hallo

Zitat:Jetzt soll der Text aus Tabelle 1 mit Tabelle 2 verglichen werden und wenn gefunden in Tabelle drei der Text aus Tabelle 2 wiedergegeben.
Das ergibt für mich keinen Sinn.
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
to top
#3
Die erste Tabelle ist dynamisch. Die Frage ist, ob das überhaupt geht. hier mal ein kleines Beispiel:

?mage
to top
#4
Hi, poste doch bitte (D)eine (Beispiel)Datei und kein Bild...
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#5
Hi,

Füge vor deiner Spalte F eine Hilfsspalte ein, in der du den reinen Text extrahierst und beziehe dich mit deinem Verweis auf diese Spalte. Du kannst sie ausblenden.

Tabelle2

BCDEFG
3blablablablaSportAuto1 Auto
4blablablablaMusikSport2 Sport
5blablablablaSportMusik3 Musik
6blablablablaFreizeitFreizeit4 Freizeit
7blablablablaAuto
8blablablablaAuto
9
10
11
12
132 Sport
143 Musik
152 Sport
164 Freizeit
171 Auto
181 Auto
Formeln der Tabelle
ZelleFormel
F3=RECHTS(G3;LÄNGE(G3)-SUCHEN(" ";G3))
F4=RECHTS(G4;LÄNGE(G4)-SUCHEN(" ";G4))
F5=RECHTS(G5;LÄNGE(G5)-SUCHEN(" ";G5))
F6=RECHTS(G6;LÄNGE(G6)-SUCHEN(" ";G6))
B13=SVERWEIS(D3;$F$3:$G$6;2;0)
B14=SVERWEIS(D4;$F$3:$G$6;2;0)
B15=SVERWEIS(D5;$F$3:$G$6;2;0)
B16=SVERWEIS(D6;$F$3:$G$6;2;0)
B17=SVERWEIS(D7;$F$3:$G$6;2;0)
B18=SVERWEIS(D8;$F$3:$G$6;2;0)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#6
Moin

Ich bin der Ansicht dass es sich bei der neuen Spalte nicht um eine dritte Liste handelt sondern um eine Erweiterung der ersten Liste.
Code:
=VERGLEICH("*"&D3;$F$3:$F$6;0)&" "&D3
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
to top
#7
(13.03.2015, 06:06)shift-del schrieb: Moin

Ich bin der Ansicht dass es sich bei der neuen Spalte nicht um eine dritte Liste handelt sondern um eine Erweiterung der ersten Liste.
Code:
=VERGLEICH("*"&D3;$F$3:$F$6;0)&" "&D3


Ich glaube das wars. Danke. Manchmal sieht man den Wald vor lauter Bäumen nicht.
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  SVERWEIS über mehrer Tabellen Kreck2 5 602 27.02.2016, 21:52
Letzter Beitrag: WillWissen
  Suche Formel für Vergleich und Zusammenführen von Texten Chuchip 6 903 25.12.2015, 15:29
Letzter Beitrag: Chuchip
  Summenprodukt mit variablen Texten Ina1978 9 1.424 21.09.2015, 07:06
Letzter Beitrag: Ina1978
Question Zahlen aus Texten extrahieren und deren Summe berechnen merlinuwe 3 714 03.09.2015, 07:32
Letzter Beitrag: RPP63
  Sverweis aktualisiert nicht automatisch und Sverweis mit Trennen von einer Zelle vivendo 15 3.362 27.05.2015, 08:13
Letzter Beitrag: BoskoBiati
  Excel-tabellen mit Daten Aus anderen Tabellen automatisch aktualisieren Slaydark 9 2.487 07.05.2015, 14:06
Letzter Beitrag: Slaydark
Smile Prozentuale Übereinstimmung von 2 Texten fredl89 5 1.655 16.01.2015, 17:44
Letzter Beitrag: RPP63
  SVerweis über 4 Tabellen Bernie 8 1.671 27.08.2014, 10:13
Letzter Beitrag: shift-del

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste