Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

Mittelwert / Anzahl / Standardabweichung mit leeren Zellen
#1
   

Hallo miteinander

Ich habe eine Datenrieihe mit  Absatzzahlen Jan bis Dez, wobei nicht jeden Monat ein Absatz stattgefunden hat (Zelle also leer - sorry wenn ich das so schreibe, bin aber nicht sicher ob der Code mit html jennie korrekt dargestellt wird). Aus dieser Datenreihe soll einerseits die Anzahl Monate mit einem Absatz ermittelt werden, andererseits soll der Durchschnittsabsatz des Jahres berechnet werden, d.h. also inklusive der Monate mit Nullabsatz.  Die Formel Mittelwert berechnet aber nur die Zellen mit Inhalt, somit erhalte ich einen zu hohen Durchschnittswert. Wenn ich leere Zellen mit Null ergänze, stimmt die Anzahl nicht da Null ja als Zahl gerechnet wird.  Dazu soll noch die Standardabweichung berechnet werden exklusiv der leeren Zellen/Nullwerte da ich ja wissen muss wo die effektive Abweichung ist in den Monaten wo es einen Absatz gab.

Mit welchen Formeln kann ich diese Problematik am erfolgreichsten meistern? 

Vielen Dank und Gruss
marc

Daten 2013_2014

DGDHDIDJDKDLDMDNDODPDQDR
45632020812620

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8


edit: HTML-Code richtig eingefügt
to top
#2
Hallo Marc,


vielleicht kannst du deine Datei oder Beispieldatei hochladen, dann wird es sicher einfacher dir zu helfen!


VG
Alexandra
to top
#3
Hallo Marc

Wenn du in die leeren Zellen Nullen einträgst, dann stimmen doch die Ergebnisse von MITTELWERT() und STABW.N().
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
[-] Folgende(r) 1 Benutzer sagt Danke an shift-del für diesen Beitrag:
zbude
to top
#4
Hi,

(12.03.2015, 20:53)shift-del schrieb: Wenn du in die leeren Zellen Nullen einträgst, dann stimmen doch die Ergebnisse von MITTELWERT() und STABW.N().

und für die Zahl der Absatz-Monate kann man alle Monate zählen, deren Absatz größer als 0 ist.

Tabelle1
DFDGDHDIDJDKDLDMDNDODPDQDR
45630200002081200620
4564
4565Anzahl6
4566Mittelwert7,17
4567Std-Abw8,30

verwendete Formeln
Zelle Formel Bereich N/A
DG4565=ZÄHLENWENN(DG4563: DR4563;">0")
DG4566=MITTELWERT(DG4563: DR4563)
DG4567=STABWN(DG4563: DR4563)
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.24 einschl. 64 Bit

Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
[-] Folgende(r) 1 Benutzer sagt Danke an Rabe für diesen Beitrag:
zbude
to top
#5
Hallo Marc,

Zitat:Wenn ich leere Zellen mit Null ergänze, stimmt die Anzahl nicht da Null ja als Zahl gerechnet wird

Trag Nullen ein und ermittle die Anzahl mit der Funktion =ZÄHLENWENN()

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEF
1100200303

ZelleFormel
F1=ZÄHLENWENN(A1:E1;"<>0")
[-] Folgende(r) 1 Benutzer sagt Danke an Kl@us-M. für diesen Beitrag:
zbude
to top
#6
Hallo,

geht auch so:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFGHIJKLMNO
12015   3  18 10 13,26,1122827 
2201500030018010 66,11228277,7576941

ZelleFormel
M1=MITTELWERT(A1:K1)
N1=STABWN(A1:K1)
M2=MITTELWERT(A2:K2)
N2{=STABWN(WENN(A2:K2>0;A2:K2))}
O2=STABWN(A2:K2)
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß


Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
zbude
to top
#7
Hallo miteinander

Vielen Dank für die Zahlreichen Antworten und Hilfestellungen - die Kombination der Antworten hat mir tip top geholfen!

Gruss
marc
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Mittelwert mit mehreren Bedingungen und auslassen von Zellen Tebo 10 61 Vor 6 Stunden
Letzter Beitrag: shift-del
  Mittelwert durch suchen Jalou 5 51 Vor 9 Stunden
Letzter Beitrag: Jalou
  Felder bei Neuberechnung leeren lassen Basti5 4 60 26.03.2017, 16:44
Letzter Beitrag: GMG-CC
  Mittelwert aus einer Zeile mit Bedingungen MMeyer 7 90 26.03.2017, 10:20
Letzter Beitrag: WillWissen
  Mittelwert dideldei 5 120 22.03.2017, 10:25
Letzter Beitrag: BoskoBiati
  Mittelwert bei < Zeichen mosef 7 150 02.03.2017, 10:11
Letzter Beitrag: mosef
  Mittelwert pro Monat Holger Weber 16 349 28.02.2017, 15:44
Letzter Beitrag: Holger Weber
  Wenn Dann Zelle leeren pingu312 4 133 23.02.2017, 17:59
Letzter Beitrag: atilla
  Mittelwert abhängig vom Monat bilden thyslo 7 224 06.02.2017, 17:21
Letzter Beitrag: shift-del
  Anzahl Zellen ermitteln, wenn... stella_gen 7 211 18.01.2017, 18:37
Letzter Beitrag: stella_gen

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste