Inhalte anzeigen
#1
Hallo Forum

Ich möchte gerne aus dieser Anzieige Teile anzeigen.

AB15CDEF

Ziel ist es mit einer Formel, nur noch die 15 dazustellen.

Danke für die Inputs :-)

cuba
to top
#2
Hola,

schau mal hier:

http://www.excelformeln.de/formeln.html?welcher=102

Gruß,
steve1da
to top
#3
Hallo

Hmmm, habe da wohl etwas falsch beschrieben.... Mit der Formel hole ich zwar die Buchstabnen raus, aber ich habe z.B. die Anzeige AB15X1234.

Damit kommt die Formel nicht klar  ;-) und ich auch nicht 

Gruss
cuba
to top
#4
Hola,

im zweiten Beispiel steht in der Tat das X mit in der Ausgabe, dann nimm das hier:

http://www.excelformeln.de/formeln.html?welcher=103

Gruß,
steve1da
to top
#5
Hi,

wo genau passt das bei dir nicht? Hast du die Formel mit STRG-UMSCHALT-ENTER abgeschlossen?

Tabelle2

AB
1AB15CDEF15
Formeln der Tabelle
ZelleFormel
B1{=TEIL(LINKS(A1;MAX(ISTZAHL(TEIL(A1;SPALTE(1:1);1)*1)*SPALTE(1:1)));VERGLEICH(1;ISTZAHL(TEIL(A1&0;SPALTE(1:1);1)*1)*1;0);LÄNGE(A1))}

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#6
Hi Günther

Doch, die Klammern sind gesetzt.

Keine Ahnung, wieso dass das bei mir nicht funktioniert. In meinem ersten Beispiel hatte ich nebst dem 15 keine weiteren Zahlen dirn, das war dann eben falsch, da ich nicht wusste, dass welche Tragweite dahinter steckt.

Mit AB15V1234 ist das Beispiel so, dass ich die Formlen jeweils von A1 auf AE176 angepasst habe, da ist diese "ominöse" Kombination. Dann wird mir aber nur die AB wegrationalisiert, der Rest bleibt dann.

Ich habe mir in meinen Träumen vorgestellt, dass es über die Wenn-Formel eine Möglichkeit geben würde.......

wenn in der Position 3+4 = 15;15;""   nur wie bringe ich Excel dazu, in die Positionen 3 und 4 zu schauen?

Dass die AB15V1234 noch einen Link hinterlegt hat, tut hoffentlich nichts zur Sache?

=SUMME((TEIL(0&AE176;KGRÖSSTE(WENN(ISTZAHL(TEIL(0&AE176;ZEILE($1:$2000);1)*1);ZEILE($1:$2000);1);ZEILE($1:$2000));1)*1)*10^(ZEILE($1:$2000)-1))  abgeschlossen mit Klammern ergibt dann die Anzeige #Zahl!

Gruss
Cuba
to top
#7
Hola,

lade bitte eine Beispieldatei hoch, anhand der man die Fehlermeldung #ZAHL sehen kann.

Gruß,
steve1da
to top
#8
Hi

Habe versucht, die Datei so gut wie möglich abzuspecken.....

Gruss
cuba


Angehängte Dateien
.xlsb   Mappe1.xlsb (Größe: 14,4 KB / Downloads: 3)
to top
#9
Hola,

warum du die Formel abgehändert hast, sagst du leider nicht.


Code:
{=SUMME((TEIL(0&AE176;KGRÖSSTE(WENN(ISTZAHL(TEIL(0&AE176;ZEILE($1:$256);1)*1);ZEILE($1:$256);1);ZEILE($1:$256));1)*1)*10^(ZEILE($1:$256)-1))}


Gruß,
steve1da
to top
#10
Hmmm,  habe ich da einen  Bock geschossen?

A1 habe ich auf AE1 umgewandelt, weil die AB151234 in der Spalte AE drin ist. Eigentlich habe ich dann auch die 256 auf 2500 erhöht, damit sich der Bereich vergrössert.

Mit der "Anpassung" der Formel hatte ich nichts gemeines im Sinn, aber es funtioniert leider nicht.

Gruss
cuba
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste