Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

Zahlenfolge in Spalte zählen
#1
Guten Tag,

ich habe eine Spalte A1:A1000, welche entweder eine 1 oder eine 0 beinhalten. Ich würde diese 1000 Zahlen nun gerne dahingehend auswerten, zu wissen wie oft genau die Zahlenfolge vorkommt:

...
1
1
0
...

Was muss ich dafür tun?
Danke für eine Antwort.

MFG.
André
to top
#2
Hi René,

prüfe deine Zahlenfolge in einer Hilfsspalte (kann ausgeblendet werden) und zähle die Anzahl an WAHR.

Tabelle1

DEF
10FALSCH3
20FALSCH
30FALSCH
40FALSCH
51WAHR
61FALSCH
70FALSCH
81WAHR
91FALSCH
100FALSCH
111WAHR
121FALSCH
130FALSCH
141FALSCH
150FALSCH
Formeln der Tabelle
ZelleFormel
E1=UND(D1=1;D2=1;D3=0)
F1=ZÄHLENWENN(E1:E15;WAHR)
E2=UND(D2=1;D3=1;D4=0)
E3=UND(D3=1;D4=1;D5=0)
E4=UND(D4=1;D5=1;D6=0)
E5=UND(D5=1;D6=1;D7=0)
E6=UND(D6=1;D7=1;D8=0)
E7=UND(D7=1;D8=1;D9=0)
E8=UND(D8=1;D9=1;D10=0)
E9=UND(D9=1;D10=1;D11=0)
E10=UND(D10=1;D11=1;D12=0)
E11=UND(D11=1;D12=1;D13=0)
E12=UND(D12=1;D13=1;D14=0)
E13=UND(D13=1;D14=1;D15=0)
E14=UND(D14=1;D15=1;D16=0)
E15=UND(D15=1;D16=1;D17=0)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#3
Jo Danke Günther,

es klappt. <:

MFG.
André
to top
#4
Hallo,

dann habe ich die Aufgabe nicht verstanden.

Die 1 gefolgt von einer 0 kommt in dem Beispiel 4 mal vor: D6/D7, D9/D10, D12/D13 und D14/D15.

Ich hätte hier Zählenwenns gearbeitet:

=ZÄHLENWENNS(D1:D15;1;D2:D16;0)
Gruß
Peter
to top
#5
Hi Peter,

André wollte nicht die Zahlenfolge 1-0, sondern 1-1-0. Siehe sein Beitrag:

Zitat:zu wissen wie oft genau die Zahlenfolge vorkommt:


...
1
1
0
...

ZÄHLENWENNS geht natürlich auch bei dieser Konstellation.
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#6
Hallo,

danke - jetzt habe ich verstanden wie das gemeint war.
Gruß
Peter
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Zahlen aus mehreren Zellen zusammenfügen / Zahlen auch mit 0 beginnend JoergPorsch 3 112 09.02.2017, 22:32
Letzter Beitrag: JoergPorsch
  wenn in tabelle wert in spalte dann neue spalte in neuer tabelle merzens 4 262 16.11.2016, 13:44
Letzter Beitrag: schauan
Question Anzahl der Einträge in einer Zeile zählen (nicht Zahlen) Olivenbaum2013 6 335 11.11.2016, 10:35
Letzter Beitrag: Olivenbaum2013
Question Einzelne Zahlen aus einer Zahlenfolge pay4get 4 362 04.10.2016, 17:22
Letzter Beitrag: pay4get
  Wenn Spalte E nicht leer dann Datum in Spalte O VBA BadHabiit 4 435 20.09.2016, 14:49
Letzter Beitrag: BadHabiit
  Funktion -> Nur in Spalte X zählen wenn Y in Spalte Z steht MacTop 18 1.004 07.09.2016, 13:59
Letzter Beitrag: MacTop
  Verkette Spalte A wenn "x" in Spalte B Goleo 6 627 31.05.2016, 17:39
Letzter Beitrag: Goleo
  Auszug aus Spalte mit Bedingung in anderer Spalte MalteMobile 4 510 11.05.2016, 08:15
Letzter Beitrag: steve1da
  Koordinaten aus Zahlen in Zeile und Spalte bestimmen joshua 11 919 26.04.2016, 12:36
Letzter Beitrag: Rabe
  Zahlenfolge erweitern Far3ll 4 645 25.04.2016, 21:14
Letzter Beitrag: Far3ll

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste