Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Zeile kopieren wenn...
#1
Question 
Hallo zusammen,

ich habe ein Problem, das hier und auch sonst im Internet sicher schon hunderte Male gelöst wurde. Bewstimmt habe ich das auch selbst schonmal gemacht, aber ich komme gerade nicht drauf und ich finde die richtige Lösung nirgendwo :/

Also: ich will, dass wenn ein bestimmter Name ein einer Spalte auftaucht die ganze betreffende Zeile in ein anderes Tabellenblatt kopiert wird. So will ich neben einer Hauptliste mit allen Namen auch einzelne Tabellenblätter für die jeweiligen Namen erstellen (quasi als wäre die Hauptliste nach Namen gefiltert). Das kann doch eigentlich nicht so schwer seinSad

Ich hoffe mir kann einer auf die Sprünge helfen!

Danke und viele Grüße
Oli
to top
#2
Hallo!
Ohne nähere Angaben Deinerseits könnte Dir ein SVERWEIS in Verbindung mit WENNFEHLER weiterhelfen.
Lade doch mal eine Beispieldatei hoch (Aufbau muss exakt stimmen, Namen anonymisieren).

Gruß Ralf
to top
#3
Hey, danke für die schnelle Rückmeldung. Anbei die Beispieldatei! Ich hoffe es wird damit klarer, was ich suche...

Herzlichsten Dank!
Oli


Angehängte Dateien
.xlsx   Beispiel_1.xlsx (Größe: 12,23 KB / Downloads: 7)
to top
#4
Hola,

für Inga als Beispiel:

In eine Hilfszelle, z.B. S1, folgende Formel:


Code:
=VERGLEICH("inga";Tabelle1!M:M;0)


In S2:


Code:
=WENNFEHLER(S1+VERGLEICH("inga";INDEX(INDEX(Tabelle1!M:M;S1+1):Tabelle1!M$65536;);0);"")


Diese Formel nach unten kopieren.

In A2 dann:


Code:
=WENN($S1="";"";INDEX(Tabelle1!A:A;$S1))


Diese Formel nach rechts und nach unten kopieren.

Gruß,
steve1da
to top
#5
Hi,

ich habe es so verstanden, daß für jeden Namen ein eigenes Tabellenblatt erstellt und/oder benutzt werden soll.

Das automatische Erstellen der Tabellenblätter geht mMn nur per Makro.

Wenn die Tabellen schon bestehen, dann könnte es mit den Formeln gehen.
Aber da die Tabellen ständig mitwachsen sollen, müßten alle Zellen bis unten schon mal mit Formeln ausgefüllt werden. Das macht die Datei sehr langsam.

Aber was ist, wenn "plötzlich" ein neuer Name auftaucht? Deswegen würde ich es komplett per Makro lösen.
Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top
#6
(09.03.2015, 14:38)Rabe schrieb: Hi,

ich habe es so verstanden, daß für jeden Namen ein eigenes Tabellenblatt erstellt und/oder benutzt werden soll.

Das automatische Erstellen der Tabellenblätter geht mMn nur per Makro.

Wenn die Tabellen schon bestehen, dann könnte es mit den Formeln gehen.
Aber da die Tabellen ständig mitwachsen sollen, müßten alle Zellen bis unten schon mal mit Formeln ausgefüllt werden. Das macht die Datei sehr langsam.

Aber was ist, wenn "plötzlich" ein neuer Name auftaucht? Deswegen würde ich es komplett per Makro lösen.

Hallo Ralf, wollen wir doch erst mal abwarten, was der TE - uns Oli - dazu sagt... automatisch geht das Erstellen wirklich nur mit Makro, aber was spricht dagegen in einer Zelle den Tabellennamen auslesen zu lassen (per Formel, und da können durch kopieren doch neue TabellenBlätter entstehen und es würde trotzdem funzen) und darauf zu refenzieren per Formel in der Art wie steve1da das beschrieben hat, ist doch sauber...!?!?!
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#7
Hi Jörg,

(09.03.2015, 15:13)Jockel schrieb: wollen wir doch erst mal abwarten, was der TE - uns Oli - dazu sagt... automatisch geht das Erstellen wirklich nur mit Makro, aber was spricht dagegen in einer Zelle den Tabellennamen auslesen zu lassen (per Formel, und da können durch kopieren doch neue TabellenBlätter entstehen und es würde trotzdem funzen) und darauf zu refenzieren per Formel in der Art wie steve1da das beschrieben hat, ist doch sauber...!?!?!

hier ein Zitat aus der Datei:
Zitat:da "Tabelle 1" beständig wächst und das Tabellenblatt "Inga" automatisch mitwachsen soll.

Ich dachte halt: dann müssen die Formeln gaaaaanz weit runtergezogen werden und durch die vielen Formeln wird es langsam.
Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top
#8
(09.03.2015, 15:49)Rabe schrieb: Ich dachte halt: dann müssen die Formeln gaaaaanz weit runtergezogen werden und durch die vielen Formeln wird es langsam.

Hi Ralf, die Gefahr sehe ich bei der beschriebenen Methode hier nicht ...
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#9
Hi Jörg,

(09.03.2015, 16:25)Jockel schrieb: die Gefahr sehe ich bei der beschriebenen Methode hier nicht ...

ich habe jetzt mal nur für die 2 Namen Inga und Rolf die Formeln 4000 Zeilen nach unten kopiert.

Allein dadurch ist die Datei jetzt von 13 kB auf 1,474 MB angewachsen.

Bei einem Ticket-System gehe ich von mehr Betreuern und auch mehr als nur 4000 Fällen pro Betreuer aus. Das heißt, es werden schnell viel mehr (oder müssen schon von vornherein mehr sein) und diese Vorratshaltung an Formeln macht die Datei zu groß und langsam.

Bei Verwendung eines Makros stehen nur die schon aufgetretenen Daten aus den tatsächlich verwendeten Zeilen in den Namenstabellen und nicht noch zigtausend Formeln.

Beispieldatei mit Formeln
Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top
#10
Okay, okay... ;-( Hallo Ralf, ich verstehe aber auch nicht, warum für jeden MA ein TabellenBlatt. Ich würde das so machen. MA-Name in S1 und den Rest wie unten ..:

Oder gänzlich ohne Formel dafür mit dem SpezialFilter hier braucht's dann aber a bissle VBA wegen der Aktualisierung, aber das ist ja machbar...

Arbeitsblatt mit dem Namen 'Rolf'
CDEFGHIJKLMNOPQRS
1UhrzeitTicketTicket IITicket ArtTicket Art IINummerSicherheitPreisMengeKurzformMitarbeiterProvision AnteilProvision Gesamt Inga
208:00:004DIAA114100101AAAInga0,11 6
308:00:007GIAA117100101AAAInga0,11 9
408:00:008HIIBB118100101AAAInga0,11 10
508:00:009IIIICC119100101AAAInga0,11 11
608:00:0014NIIBB124100101AAAInga0,11 16

NameBezug
MA=Tabelle1!$M$1:INDEX(Tabelle1!$M:$M;VERGLEICH(0;Tabelle1!$A:$A;-1))

ZelleFormel
C2=WENN($S2="";"";INDEX(Tabelle1!C:C;$S2))
D2=WENN($S2="";"";INDEX(Tabelle1!D:D;$S2))
E2=WENN($S2="";"";INDEX(Tabelle1!E:E;$S2))
F2=WENN($S2="";"";INDEX(Tabelle1!F:F;$S2))
G2=WENN($S2="";"";INDEX(Tabelle1!G:G;$S2))
H2=WENN($S2="";"";INDEX(Tabelle1!H:H;$S2))
I2=WENN($S2="";"";INDEX(Tabelle1!I:I;$S2))
J2=WENN($S2="";"";INDEX(Tabelle1!J:J;$S2))
K2=WENN($S2="";"";INDEX(Tabelle1!K:K;$S2))
L2=WENN($S2="";"";INDEX(Tabelle1!L:L;$S2))
M2=WENN($S2="";"";INDEX(Tabelle1!M:M;$S2))
N2=WENN($S2="";"";INDEX(Tabelle1!N:N;$S2))
O2=WENN($S2="";"";INDEX(Tabelle1!O:O;$S2))
S2=VERGLEICH(S1;MA;0)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
Photo Makro zum Kopieren bis eine leere Zeile kommt ambropete 2 41 Vor 21 Minuten
Letzter Beitrag: Kuwer
  Zeile kopieren und einfügen, Positionierung stimmt nicht. Icepic 1 26 Vor 5 Stunden
Letzter Beitrag: schauan
  Datum aus Zeile 1 in Formel in Zeile 2 Mcnick78 2 43 08.12.2016, 16:01
Letzter Beitrag: shift-del
  Excel VBA, Bild aus nebenstehender Zelle kopieren wenn Zelle ausgewählt ist xChristianx 5 78 30.11.2016, 11:32
Letzter Beitrag: xChristianx
Question Eine bestimmte Feldformatierung, wenn in gleicher Zeile ein Wort vorkommt Olivenbaum2013 11 172 15.11.2016, 11:33
Letzter Beitrag: Olivenbaum2013
Lightbulb VBA Zeile in eine Arbeitsmappe kopieren wenn in der Zeile eine 1 steht Olossos 8 133 11.11.2016, 17:08
Letzter Beitrag: Kuwer
  VBA: Mit Textbausteinen finden und Zeile kopieren? orgel 3 66 07.11.2016, 16:12
Letzter Beitrag: Fennek
  Zeile kopieren - Anzahl wie in Zeile July0210 10 220 26.09.2016, 10:08
Letzter Beitrag: July0210
  Wenn in Spalte C keine Füllfarbe, dann ganze Zeile löschen grummelbaer 22 699 19.09.2016, 08:55
Letzter Beitrag: IchBinIch
  Makro zum kopieren von Zeile wenn Wort drin steht l2amzZ 2 158 14.09.2016, 22:57
Letzter Beitrag: IchBinIch

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste