Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Zählen, wenn mehrmals gleicher Wert in Folge
#1
Hallo Smile

In Spalte A meines Arbeitsblatts stehen Datumswerte (Format 01.01.2010) und in Spalte B meines Arbeitsblatts stehen nur entweder 0 oder 1.

Ich möchte, dass gern in Spalte C für jeden Monat, d.h. für den Januar 2010, den Februar 2010 etc., gezählt wird, wie oft, z.B. mindestens dreimal nacheinander in B eine 1 stand.

In dem angehängte Beispiel sollte als in Spalte C eine 2 stehen.

Ich würde mich sehr über eure Hilfe freuen.

Danke Smile


Angehängte Dateien
.xlsx   Example.xlsx (Größe: 10,79 KB / Downloads: 7)
to top
#2
Hallo,

mit einer Hilfsspalte:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDE
1DateValuecount  
201.01.20100 02
302.01.20100 0 
403.01.20100 0 
504.01.20100 0 
605.01.20101 1 
706.01.20101 0 
807.01.20101 0 
908.01.20100 0 
1009.01.20101 1 
1110.01.20101 0 
1211.01.20101 0 
1312.01.20101 0 
1413.01.20100 0 
1514.01.20100 0 
1615.01.20100   

ZelleFormel
D2=(MONAT(A4)=MONAT(A2))*(B1<>1)*(B2=1)*(SUMME(B2:INDEX(B3:$B$999;VERGLEICH(0;B3:$B$999;0)))>2)
E2=SUMMENPRODUKT((MONAT(A2:A999)=1)*(D2:D999=1))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß


Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Feiertage zählen nur, wenn kein Sa oder So Papppa 2 53 Gestern, 08:17
Letzter Beitrag: Papppa
  Wert nach Prüfung von anderem Wert überschreiben lassen? dodo 4 71 15.01.2017, 17:26
Letzter Beitrag: schauan
  mit VBA Linie im Liniendiagramm rot wenn Wert negativ Mario 12 292 07.01.2017, 13:58
Letzter Beitrag: Mario
  Zellen - Sverweis nur wenn Wert größer 0 Daniel Albert 36 609 22.12.2016, 21:34
Letzter Beitrag: snb
Brick Anzahl gleicher Werte unter Duplikatoren marinko 17 279 19.12.2016, 09:04
Letzter Beitrag: marinko
  Wert suchen in Spalte und wert da neben ausgeben VBA michel34497 2 111 02.12.2016, 23:33
Letzter Beitrag: michel34497
  Spalten in Zeilen umwanden mit gleicher Überschrift fabian1994 2 129 23.11.2016, 17:50
Letzter Beitrag: schauan
  wenn in tabelle wert in spalte dann neue spalte in neuer tabelle merzens 4 162 16.11.2016, 13:44
Letzter Beitrag: schauan
Question Eine bestimmte Feldformatierung, wenn in gleicher Zeile ein Wort vorkommt Olivenbaum2013 11 266 15.11.2016, 11:33
Letzter Beitrag: Olivenbaum2013
Question Anzahl der Einträge in einer Zeile zählen (nicht Zahlen) Olivenbaum2013 6 168 11.11.2016, 10:35
Letzter Beitrag: Olivenbaum2013

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste