Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Zählen, wenn mehrmals gleicher Wert in Folge
#1
Hallo Smile

In Spalte A meines Arbeitsblatts stehen Datumswerte (Format 01.01.2010) und in Spalte B meines Arbeitsblatts stehen nur entweder 0 oder 1.

Ich möchte, dass gern in Spalte C für jeden Monat, d.h. für den Januar 2010, den Februar 2010 etc., gezählt wird, wie oft, z.B. mindestens dreimal nacheinander in B eine 1 stand.

In dem angehängte Beispiel sollte als in Spalte C eine 2 stehen.

Ich würde mich sehr über eure Hilfe freuen.

Danke Smile


Angehängte Dateien
.xlsx   Example.xlsx (Größe: 10,79 KB / Downloads: 7)
to top
#2
Hallo,

mit einer Hilfsspalte:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDE
1DateValuecount  
201.01.20100 02
302.01.20100 0 
403.01.20100 0 
504.01.20100 0 
605.01.20101 1 
706.01.20101 0 
807.01.20101 0 
908.01.20100 0 
1009.01.20101 1 
1110.01.20101 0 
1211.01.20101 0 
1312.01.20101 0 
1413.01.20100 0 
1514.01.20100 0 
1615.01.20100   

ZelleFormel
D2=(MONAT(A4)=MONAT(A2))*(B1<>1)*(B2=1)*(SUMME(B2:INDEX(B3:$B$999;VERGLEICH(0;B3:$B$999;0)))>2)
E2=SUMMENPRODUKT((MONAT(A2:A999)=1)*(D2:D999=1))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß


Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  gleicher Name gleichen Wert zuweisen lizagliza 4 68 21.02.2017, 19:42
Letzter Beitrag: Glausius
  WENN Funktion: Entweder Datum oder bestimmter Wert Ahnunglos 8 113 16.02.2017, 11:32
Letzter Beitrag: Ahnunglos
  Anzahl Werte in Folge mit Bedingung x Felixanius 8 106 15.02.2017, 14:22
Letzter Beitrag: Felixanius
  Zahlen aus mehreren Zellen zusammenfügen / Zahlen auch mit 0 beginnend JoergPorsch 3 73 09.02.2017, 22:32
Letzter Beitrag: JoergPorsch
  Zählen, wenn Bedingungen erfüllt sind liass 7 115 08.02.2017, 16:54
Letzter Beitrag: BoskoBiati
  Zahlen addieren, wenn Buchstaben enthalten sind Kaewien 12 219 07.02.2017, 17:53
Letzter Beitrag: snb
  Zählen nach Datum wenn/oder sash! 28 439 03.02.2017, 14:05
Letzter Beitrag: sash!
  Zählen wenn mit zwei Bedinungen ( Monat und Ja/Nein) DBSB 6 144 31.01.2017, 12:55
Letzter Beitrag: RPP63
  Aulistung aller Zahlen zu einem Wert lascava 7 131 26.01.2017, 16:57
Letzter Beitrag: atilla
  + Zeichen vor Zahl wenn positiver Wert Sebastian8029 1 55 26.01.2017, 09:29
Letzter Beitrag: Peter

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste