Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Rang ermitteln
#1
Hallo Leute,
ich benötige wieder mal eure Hilfe.
Im Hochsprungwettbewerb soll der Rang ermittelt werden.
In meiner Beispieltabelle habe ich den Rang eingetragen. Künftig soll dieser errechnet werden.
Der Rang oder besser die Platzierung bei gleicher Höhe ist abhängig von den gesamten Versuchen und den Fehlversuchen.
Finde keine Lösung.
Ein gültiger Versuch wird mit einer Null (0) dargestellt, ein Fehlversuch mit einem Kreuz (X) und ein Verzicht mit einen Strich (-).
Doch wenn ein Strich eingegeben wird, dann will excel rechnen. Gibt es hier eine Möglichkeit, das bei der Eingabe des Striches durch den Kampfrichter, excel nicht rechnet.
Ich gehe davon aus, das nicht jeder Kampfrichter mit excel umgehen kann.
Hochsprung Test

ABCDEFGHIJKLMNOPQRSTUVWXY
10= gültigX=Fehlversuch-=Verzicht
2SprunghöhenVersuche insgesamtFehl-versuchePlatz
3Wettkämpfer1,751,801,841,881,911,941,97
4Springer A0 x0 0 x0 x-xx952
5Springer B-x0 -x0 --xxx751
6Springer C-0 x0 x0 -xxx853
7Springer D-x0 x0 x0 xxx964
Formeln der Tabelle
ZelleFormel
W4=ZÄHLENWENN(A4:V4;"x")+ZÄHLENWENN(B4:V4;"0")
X4=ZÄHLENWENN(B4:V4;"x")
W5=ZÄHLENWENN(A5:V5;"x")+ZÄHLENWENN(B5:V5;"0")
X5=ZÄHLENWENN(B5:V5;"x")
W6=ZÄHLENWENN(A6:V6;"x")+ZÄHLENWENN(B6:V6;"0")
X6=ZÄHLENWENN(B6:V6;"x")
W7=ZÄHLENWENN(A7:V7;"x")+ZÄHLENWENN(B7:V7;"0")
X7=ZÄHLENWENN(B7:V7;"x")

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Ich würde mich freuen, wenn ihr mir helfen könntet.
Gruß Roland
to top
#2
Hallo,
ich schicke die Tabelle zur Ansicht.
Gruß


Angehängte Dateien
.xlsx   Hochsprung.xlsx (Größe: 11,98 KB / Downloads: 4)
to top
#3
Hallo,

z.B. dadurch, dass statt - eine 1 eingegeben wird und das Zellformat so lautet:

Arbeitsblatt mit dem Namen 'Tabelle1'
 A
4-

ZelleFormatWert
A4[=1]"-";Standard1
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß


Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
horo
to top
#4
Hallo horo,

füge doch hinter Spalte V eine Spalte ein, in der die größte Höhe angezeigt wird.
Dann kannst du anhand dieser Spalte auch den Platz ermitteln.
Gruß Conny Smile
_______________________________________________________________

Ich habe keine Lösung, aber ich bewundere dein Problem !
to top
#5
Hallo Edgar,
das hat funktioniert. Danke für die Lösung. Muß nur den Kampfrichtern sagen, dass bei Verzicht eine 1 einzutragen ist, doch das kann man sich merken.

Hallo Conny,
ich verstehe deine Lösung noch nicht. Alle Springer sind 1,88m hoch gesprungen.
Keiner hat bei den neuen Höhen einen gültigen Versuch.
Die größte Höhe war also 1,88m bei jedem Springer. Sie sind nur unterschiedlich oft gesprungen und haben unterschiedlich viele Fehlversuche benötigt.
Ein Gedanke war die Anzahl der gesamten Versuche und Fehlversuche zu addieren und dann ein rangking zu errechnen.
Doch das klappt auch nicht immer, das könnte auch gleich sein. 
Gruß Roland
to top
#6
Hallo,

ich sehe das so, in Einklang mit den Wettkampfregeln:

Arbeitsblatt mit dem Namen 'Hochsprung'
 ABCDEFGHIJKLMNOPQRSTUVWXYZAA
1 0= gültig   X=Fehlversuch     1=Verzicht               
2            Sprunghöhen         Versuche insgesamtFehl-versuchePlatzmax.

Höhe
Rang
3Wettkämpfer1,751,801,841,881,911,941,97     
4Springer A 0 x0  0 x0 x- xx    9211,881,02
5Springer B - x0 x- x0  -  - xxx8321,881,03
6Springer C -  0 x0 xx  - xxx   8141,844
7Springer D - x0 x0 x0 xxx      9321,881,03

ZelleFormatWert
B4[=1]"-";Standard 

ZelleFormel
W4=ZÄHLENWENN(A4:V4;"x")+ZÄHLENWENN(B4:V4;0)
X4=ZÄHLENWENN(B4:INDEX($A4:$V4;VERWEIS(9;1/($A4:$V4=0)/($A4:$V4<>"");SPALTE($A4:$V4)));"x")
Y4=RANG(AA4;$AA$4:$AA$7;1)
Z4=INDEX($B$3:$V$3;(KÜRZEN((VERWEIS(9;1/($B4:$V4=0)/($B4:$V4<>"");SPALTE($B4:$V4))+1)/3;)-1)*3+1)
AA4=RANG(Z4;$Z$4:$Z$7)+WENN((RANG(Z4;$Z$4:$Z$7)=1)*(ZÄHLENWENN($Z$4:$Z$7;Z4)>1);X4/100;0)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß


Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
horo
to top
#7
Hallo Edgar,
ich habe deine Lösung übernommen. Es passt. Danke für die Hilfe.
Hat etwas gedauert, doch ich habe es hin bekommen.
Habe auch schon mit den Versuchen probiert, es funktioniert.
Mir ist aufgefallen, dass, wenn es bei gleichen Höhen, auch gleiche Ränge geben kann.
Siehe meine geänderte Tabelle.
Hochsprung

ABCDEFGHIJKLMNOPQRSTUVWXYZAA
10= gültigX=Fehlversuch1=Verzicht
2SprunghöhenVersuche insgesamtFehl-versuchePlatzmax. HöheRang
3Wettkämpfer1,751,801,841,881,911,941,97
4Springer A0x00x0x-xx9211,881,02
5Springer B-x0x0x0--xxx9331,881,03
6Springer C-0x0x0-xxx8211,881,02
7Springer D-x0x0x0xxx9331,881,03
Formeln der Tabelle
ZelleFormel
W4=ZÄHLENWENN(A4:V4;"x")+ZÄHLENWENN(B4:V4;"0")
X4=ZÄHLENWENN(B4:INDEX($A4:$V4;VERWEIS(9;1/($A4:V4=0)/($A4:$V4<>"");SPALTE($A4:$V4)));"x")
Y4=RANG(AA4;$AA$4:$AA$7;1)
Z4=INDEX($B$3:$V$3;(KÜRZEN((VERWEIS(9;1/($B4:$V4=0)/($B4:$V4<>"");SPALTE($B4:$V4))+1)/3;)-1)*3+1)
AA4=RANG(Z4;$Z$4:$Z$7)+WENN((RANG(Z4;$Z$4:$Z$7)=1)*(ZÄHLENWENN($Z$4:$Z$7;Z4)>1);X4/100;0)
W5=ZÄHLENWENN(A5:V5;"x")+ZÄHLENWENN(B5:V5;"0")
X5=ZÄHLENWENN(B5:INDEX($A5:$V5;VERWEIS(9;1/($A5:V5=0)/($A5:$V5<>"");SPALTE($A5:$V5)));"x")
Y5=RANG(AA5;$AA$4:$AA$7;1)
Z5=INDEX($B$3:$V$3;(KÜRZEN((VERWEIS(9;1/($B5:$V5=0)/($B5:$V5<>"");SPALTE($B5:$V5))+1)/3;)-1)*3+1)
AA5=RANG(Z5;$Z$4:$Z$7)+WENN((RANG(Z5;$Z$4:$Z$7)=1)*(ZÄHLENWENN($Z$4:$Z$7;Z5)>1);X5/100;0)
W6=ZÄHLENWENN(A6:V6;"x")+ZÄHLENWENN(B6:V6;"0")
X6=ZÄHLENWENN(B6:INDEX($A6:$V6;VERWEIS(9;1/($A6:V6=0)/($A6:$V6<>"");SPALTE($A6:$V6)));"x")
Y6=RANG(AA6;$AA$4:$AA$7;1)
Z6=INDEX($B$3:$V$3;(KÜRZEN((VERWEIS(9;1/($B6:$V6=0)/($B6:$V6<>"");SPALTE($B6:$V6))+1)/3;)-1)*3+1)
AA6=RANG(Z6;$Z$4:$Z$7)+WENN((RANG(Z6;$Z$4:$Z$7)=1)*(ZÄHLENWENN($Z$4:$Z$7;Z6)>1);X6/100;0)
W7=ZÄHLENWENN(A7:V7;"x")+ZÄHLENWENN(B7:V7;"0")
X7=ZÄHLENWENN(B7:INDEX($A7:$V7;VERWEIS(9;1/($A7:V7=0)/($A7:$V7<>"");SPALTE($A7:$V7)));"x")
Y7=RANG(AA7;$AA$4:$AA$7;1)
Z7=INDEX($B$3:$V$3;(KÜRZEN((VERWEIS(9;1/($B7:$V7=0)/($B7:$V7<>"");SPALTE($B7:$V7))+1)/3;)-1)*3+1)
AA7=RANG(Z7;$Z$4:$Z$7)+WENN((RANG(Z7;$Z$4:$Z$7)=1)*(ZÄHLENWENN($Z$4:$Z$7;Z7)>1);X7/100;0)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Ich denke wer im Wettkampf zuerst die Höhe springt kann bei gleicher Platzierung auch den höheren Rang beanspruchen.
Was meinst du? Kann man das errechen?
Hab das zwar noch nicht mit dem Sportclub so abgestimmt, ob sie das auch mitgehen und so sehen. Kann falsch sein, aber wäre eine Möglichkeit, so gibt es keine zwei 1. Plätze oder zwei 3. Plätze.
Die Wettkampfregeln 181.8 und 181.9 (Stichkampf), finden National keine Anwendung.
Gruß Roland


Edit:
Zur korrekten Darstellung der Formeln Smilies in diesem Beitrag ausgeschaltet.
to top
#8
Hallo Roland,

wenn dies ein offizieller Wettkampf ist, müsst ihr euch an die Wettkampfbestimmungen des DLV halten.
Ihr könnt also keine eigenen Regeln aufstellen!
d.h.
Zitat:8. Bei gleichen Leistungen ist wie folgt zu verfahren:
a) Der Wettkämpfer mit der geringsten Zahl von Versuchen bei gleicher Höhe ist besser platziert.
b) Besteht danach weiterhin Gleichstand, ist der Wettkämpfer mit der geringsten Gesamtzahl von Fehlversuchen im Wettkampf einschließlich bei der zuletzt überquerten Höhe, besser platziert.

Außerdem erkennst du an der Tabelle von Edgar, dass nur die Fehlversuche bis zur erreichten Bestleistung gezählt werden.
Gruß Conny Smile
_______________________________________________________________

Ich habe keine Lösung, aber ich bewundere dein Problem !
to top
#9
Hallo,

aber die Regel, dass bei gleicher Höhe die geringste Anzahl von Fehlversuchen zählt, gilt auch hier.
Gruß


Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#10
Hallo Conny,
die Wettkampfbestimmungen müssen eingehalten werden. Das ist ohne Zweifel.
Mit Edgars Hilfe kann der Rang und Platzierung errechnet werden.
In meiner letzten Tabelle gibt es zwei 1. Plätze und zwei 3. Plätze.
So wie es in deinem Zitat beschrieben, war mein Gedanke zu errechnen, wer der Bessere ist.
Hier wäre Springer C auf dem 1. Platz der Bessere, dann Springer A. Nur bei Springer B und D 
gibt es keinen Unterschied. Da wollte ich noch im Sportclub nachfragen, wie hier verfahren wird.
Doch es wird wohl eine Platzteilung geben.Danke für die Unterstüzung.
Gruß Roland
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Wochenzahl ermitteln dindu 5 84 19.11.2016, 11:41
Letzter Beitrag: dindu
  Alter des Hundes ermitteln Gurch 5 160 28.09.2016, 19:45
Letzter Beitrag: Gurch
  Mittelwert Indirekt ermitteln Norcoc 10 395 04.09.2016, 22:01
Letzter Beitrag: Norcoc
  Auswertung im Sportverein - Probleme mit RANG Bödefeld 20 748 04.05.2016, 10:22
Letzter Beitrag: BoskoBiati
  Ist Arbeitszeit ermitteln joerg0606 1 336 06.04.2016, 09:20
Letzter Beitrag: shift-del
  tagescode ermitteln joerg0606 2 367 24.03.2016, 08:24
Letzter Beitrag: BoskoBiati
  Rang ermitteln Helmut0209 2 420 23.02.2016, 18:20
Letzter Beitrag: Helmut0209
  Ermitteln gekennzeichneter Kalendertage Hardbopper 7 674 02.12.2015, 18:16
Letzter Beitrag: Hardbopper
Exclamation Arbeitszeit ermitteln Weiss der Geier 26 3.804 08.09.2015, 13:50
Letzter Beitrag: Weiss der Geier
  leere Zelle ermitteln karomue 88 14.072 25.07.2015, 18:13
Letzter Beitrag: karomue

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste