Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Benutzerdefinierte Formatierung von Endungen
#1
Hallo Leute,
kann mir jemand bei meinem Problem helfen?
In meiner Tabelle werden Tage errechnet. Nur klappt das mit dem Text hinter der Zahl nicht.
Habe erst in einer Formel den Text mit eingebaut. Passte nicht.
Nun möchte ich es über die bF versuchen.
Hab es in Zeile 6 probiert und in D6 und E6 hinbekommen. Möchte aber eine Formatierung nutzen,
die erkennt, ob es 1 Tag oder 0 Tage, bzw. 2 und mehr Tage sind.
Geht das zu machen?
Tabelle3

ABCDE
1AnreiseAbreiseMeetingAnreiseAbreise
211.01.15.01.15.01.vor 4 Tagenach 4 Tage
310.01.16.01.15.01.vor 5 Tagenach 6 Tage
414.01.16.01.15.01.vor 1 Tagenach 2 Tage
515.01.16.01.15.01.vor 0 Tagenach 1 Tage
615.01.16.01.15.01.vor 0 Tagenach 1 Tag
Formeln der Tabelle
ZelleFormel
D2=WENN(UND(A2="";B2="");"";"vor "&(DATEDIF(A2;C2;"yd")& " Tage"))
E2=WENN(UND(B2="");"";"nach "&(DATEDIF(A2;B2;"yd")&" Tage"))
D3=WENN(UND(A3="";B3="");"";"vor "&(DATEDIF(A3;C3;"yd")& " Tage"))
E3=WENN(UND(B3="");"";"nach "&(DATEDIF(A3;B3;"yd")&" Tage"))
D4=WENN(UND(A4="";B4="");"";"vor "&(DATEDIF(A4;C4;"yd")& " Tage"))
E4=WENN(UND(B4="");"";"nach "&(DATEDIF(A4;B4;"yd")&" Tage"))
D5=WENN(UND(A5="";B5="");"";"vor "&(DATEDIF(A5;C5;"yd")& " Tage"))
E5=WENN(UND(B5="");"";"nach "&(DATEDIF(A5;B5;"yd")&" Tage"))
D6=WENN(UND(A6="";B6="");"";(DATEDIF(A6;C6;"yd")))
E6=WENN(UND(B6="");"";(DATEDIF(A6;B6;"yd")))
Datengültigkeit der Tabelle
ZelleZulassenDatenEingabe 1Eingabe 2
A2DatumZellwert ist zwischen 01.01.201531.12.2015
B2DatumZellwert ist zwischen 01.01.201531.12.2015
C2Benutzerdefiniert=WOCHENTAG(C2;2)<6
A3DatumZellwert ist zwischen 01.01.201531.12.2015
B3DatumZellwert ist zwischen 01.01.201531.12.2015
C3Benutzerdefiniert=WOCHENTAG(C3;2)<6
A4DatumZellwert ist zwischen 01.01.201531.12.2015
B4DatumZellwert ist zwischen 01.01.201531.12.2015
C4Benutzerdefiniert=WOCHENTAG(C4;2)<6
A5DatumZellwert ist zwischen 01.01.201531.12.2015
B5DatumZellwert ist zwischen 01.01.201531.12.2015
C5Benutzerdefiniert=WOCHENTAG(C5;2)<6
A6DatumZellwert ist zwischen 01.01.201531.12.2015
B6DatumZellwert ist zwischen 01.01.201531.12.2015
C6Benutzerdefiniert=WOCHENTAG(C6;2)<6
Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
E21. / Formel ist =DATEDIF(A2;B2;"yd")>$E$3Abc
E31. / Formel ist =DATEDIF(A2;B2;"yd")>$E$3Abc
E41. / Formel ist =DATEDIF(A2;B2;"yd")>$E$3Abc
E51. / Formel ist =DATEDIF(A2;B2;"yd")>$E$3Abc
E61. / Formel ist =DATEDIF(A2;B2;"yd")>$E$3Abc

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Gruß Roland


Angehängte Dateien
.xlsx   Reisekosten.xlsx (Größe: 11,44 KB / Downloads: 0)
to top
#2
Hola,

und was möchtest du dann ausgeben?

Die bedingte Formatierung ändert nur das Format, keine Texte.

Gruß,
steve1da
to top
#3
Hallo,
erstamal danke, dass du dich mit meinem Problem befasst.
Es soll in Spalte D und E angezeigt werden, das die Anreise vor 1Tag, vor 2 Tagen oder 3 Tagen erfolgte.
Je nach Datum in Spalte A und B.
Bei der Abreise soll es auch so stehen.
Es sieht nicht aus, wenn da steht, die Anreise erfolgte vor 4 Tag oder die Anreise erfolgte vor 1 Tagen.
Gruß Roland
to top
#4
Hola,

bin grad nicht an einem PC, von daher kann es fehlerhaft sein:


Code:
=WENN(UND(A2="";B2="");"";"vor "&(DATEDIF(A2;C2;"yd")& " Tag"&wenn(C2-A2>1;"e";"")))



Gruß,
steve1da
to top
#5
Hi,

versuchs mal so für Spalte D:


Tabelle1
ABCD
613.01.201516.01.201515.01.2015vor 2 Tagen

verwendete Formeln
Zelle Formel Bereich N/A
D6=WENN(UND(A6="";B6="");"";WENN(DATEDIF(A6;C6;"yd")=1;"vor " & DATEDIF(A6;C6;"yd")&" Tag";"vor "&DATEDIF(A6;C6;"yd")&" Tagen"))
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.19 einschl. 64 Bit


Spalte E dann analog aufbauen
Mit freundlichen Grüßen  Smile
Michael

Win 7 64 bit / Excel 2007/2016
to top
#6
Hi

so für beide Spalten


Tabelle1
ABCDE
614.01.201516.01.201515.01.2015vor 1 Tagnach 2 Tagen

verwendete Formeln
Zelle Formel Bereich N/A
D6=WENN(UND(A6="";B6="");"";WENN(DATEDIF(A6;C6;"yd")=1;"vor " & DATEDIF(A6;C6;"yd")&" Tag";"vor "&DATEDIF(A6;C6;"yd")&" Tagen"))
E6=WENN(UND(A6="";B6="");"";WENN(DATEDIF(A6;B6;"yd")=1;"nach " & DATEDIF(A6;B6;"yd")&" Tag";"nach "&DATEDIF(A6;B6;"yd")&" Tagen"))
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.19 einschl. 64 Bit

Mit freundlichen Grüßen  Smile
Michael

Win 7 64 bit / Excel 2007/2016
to top
#7
14.01.201516.01.201515.01.2015vor 1 Tagnach 2 Tagen

ZelleFormel
D6=WENN(UND(A6="";B6="");"";WENN(DATEDIF(A6;C6;"yd")=1;"vor " & DATEDIF(A6;C6;"yd")&" Tag";"vor "&DATEDIF(A6;C6;"yd")&" Tagen"))
E6=WENN(UND(A6="";B6="");"";WENN(DATEDIF(A6;B6;"yd")=1;"nach " & DATEDIF(A6;B6;"yd")&" Tag";"nach "&DATEDIF(A6;B6;"yd")&" Tagen"))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

So sieht die Antwort besser aus, weiß nicht warum das bei Nutzung des anderen Darstellungstools so zerschossen rüberkommt.
Mit freundlichen Grüßen  Smile
Michael

Win 7 64 bit / Excel 2007/2016
[-] Folgende(r) 1 Benutzer sagt Danke an Zwergel für diesen Beitrag:
horo
to top
#8
Hallo,
habe deine Formel eingegeben. In Zeile 2 u. 3 sprich Zelle D2 und D3 hat es funktioniert, nur in Zeile 4, 5 und 6 also D4, D5 u. D6 nicht.
Hier kommt als Ergebniss in D4 -vor 1- und in den D5 u. D6 -vor 0-.
Kann ich was falsch gemacht haben?
Roland
to top
#9
Hi so siehts bei mir aus:

11.01.201515.01.201515.01.2015vor 4 Tagennach 4 Tagen
10.01.201516.01.201515.01.2015vor 5 Tagennach 6 Tagen
14.01.201516.01.201515.01.2015vor 1 Tagnach 2 Tagen
15.01.201516.01.201515.01.2015vor 0 Tagennach 1 Tag
14.01.201516.01.201515.01.2015vor 1 Tagnach 2 Tagen

ZelleFormel
D2=WENN(UND(A2="";B2="");"";WENN(DATEDIF(A2;C2;"yd")=1;"vor " & DATEDIF(A2;C2;"yd")&" Tag";"vor "&DATEDIF(A2;C2;"yd")&" Tagen"))
E2=WENN(UND(A2="";B2="");"";WENN(DATEDIF(A2;B2;"yd")=1;"nach " & DATEDIF(A2;B2;"yd")&" Tag";"nach "&DATEDIF(A2;B2;"yd")&" Tagen"))
D3=WENN(UND(A3="";B3="");"";WENN(DATEDIF(A3;C3;"yd")=1;"vor " & DATEDIF(A3;C3;"yd")&" Tag";"vor "&DATEDIF(A3;C3;"yd")&" Tagen"))
E3=WENN(UND(A3="";B3="");"";WENN(DATEDIF(A3;B3;"yd")=1;"nach " & DATEDIF(A3;B3;"yd")&" Tag";"nach "&DATEDIF(A3;B3;"yd")&" Tagen"))
D4=WENN(UND(A4="";B4="");"";WENN(DATEDIF(A4;C4;"yd")=1;"vor " & DATEDIF(A4;C4;"yd")&" Tag";"vor "&DATEDIF(A4;C4;"yd")&" Tagen"))
E4=WENN(UND(A4="";B4="");"";WENN(DATEDIF(A4;B4;"yd")=1;"nach " & DATEDIF(A4;B4;"yd")&" Tag";"nach "&DATEDIF(A4;B4;"yd")&" Tagen"))
D5=WENN(UND(A5="";B5="");"";WENN(DATEDIF(A5;C5;"yd")=1;"vor " & DATEDIF(A5;C5;"yd")&" Tag";"vor "&DATEDIF(A5;C5;"yd")&" Tagen"))
E5=WENN(UND(A5="";B5="");"";WENN(DATEDIF(A5;B5;"yd")=1;"nach " & DATEDIF(A5;B5;"yd")&" Tag";"nach "&DATEDIF(A5;B5;"yd")&" Tagen"))
D6=WENN(UND(A6="";B6="");"";WENN(DATEDIF(A6;C6;"yd")=1;"vor " & DATEDIF(A6;C6;"yd")&" Tag";"vor "&DATEDIF(A6;C6;"yd")&" Tagen"))
E6=WENN(UND(A6="";B6="");"";WENN(DATEDIF(A6;B6;"yd")=1;"nach " & DATEDIF(A6;B6;"yd")&" Tag";"nach "&DATEDIF(A6;B6;"yd")&" Tagen"))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Erkenne da keinen Fehler bei mir.
Mit freundlichen Grüßen  Smile
Michael

Win 7 64 bit / Excel 2007/2016
[-] Folgende(r) 1 Benutzer sagt Danke an Zwergel für diesen Beitrag:
horo
to top
#10
Hallo zusammen,
zur Zeit sieht mein Bildschirm etwas verschoben aus, doch die Lösung von zwergel passt.
Besten Dank euch Helfern.
Roland
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Bei bedingter Formatierung die Formatierung der Zelle berücksichtigen SGMP 7 121 04.11.2016, 13:50
Letzter Beitrag: SGMP
  Benutzerdefinierte Formatierung ohne führende Nullen und mit dynamischen Zeichen VodeAn 2 350 30.01.2016, 06:37
Letzter Beitrag: schauan

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste