Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Summenbildung mit 2 Kriterien
#1
Hallo,
ich komme nicht zu einem Ergebnis.
Beispiel in Anlage

Wo liegt der Fehler ?
Ich möchte nach Kriterien Spalte A und Kriterien Spalte B  filtern und die Summe aus Spalte B haben.
Einige Leerspalten  vorhanden. Zeilen sind teilweise in Spalte A verbunden.

Gerne Hilfe und dank schonmals.

Gruß Jannils


Angehängte Dateien
.xlsx   Beispiel Excel Forum.xlsx (Größe: 8,41 KB / Downloads: 16)
to top
#2
Hallo,

ich würde die verbundenen Zellen in Spalte A und Spalte B auflösen und in jede Zelle den entsprechenden Wert schreiben.

in B16 folgende Formel: =SUMMENPRODUKT(($A$4:$A$13="MP4")*($B$4:$B$13=0,8);($B$4:$B$13))
in B17 folgende Formel: =SUMMENPRODUKT(($A$4:$A$13="MP4")*($B$4:$B$13=1);($B$4:$B$13))

wobei mir im Moment noch nicht klar ist warum hier zweimal Summe MP4 aufgeführt ist.
Gruß
Peter
to top
#3
(01.03.2015, 14:17)Peter schrieb: Hallo,

ich würde die verbundenen Zellen in Spalte A und Spalte B auflösen und in jede Zelle den entsprechenden Wert schreiben.

in B16 folgende Formel: =SUMMENPRODUKT(($A$4:$A$13="MP4")*($B$4:$B$13=0,8);($B$4:$B$13))
in B17 folgende Formel: =SUMMENPRODUKT(($A$4:$A$13="MP4")*($B$4:$B$13=1);($B$4:$B$13))

wobei mir im Moment noch nicht klar ist warum hier zweimal Summe MP4 aufgeführt ist.

Hallo
danke.
wegen Kriterium 100% und 80%;
werde die verbundene Zellen auflösen

Jannils
to top
#4
Hallo,

dann würde auch das funktionieren:


Code:
=SUMMEWENNS($B$4:$B$13;$A$4:$A$13;"MP4";$B$4:$B$13;0,8)
Gruß


Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#5
(01.03.2015, 14:17)Peter schrieb: Hallo,

ich würde die verbundenen Zellen in Spalte A und Spalte B auflösen und in jede Zelle den entsprechenden Wert schreiben.

in B16 folgende Formel: =SUMMENPRODUKT(($A$4:$A$13="MP4")*($B$4:$B$13=0,8);($B$4:$B$13))
in B17 folgende Formel: =SUMMENPRODUKT(($A$4:$A$13="MP4")*($B$4:$B$13=1);($B$4:$B$13))

wobei mir im Moment noch nicht klar ist warum hier zweimal Summe MP4 aufgeführt ist.

Hallo Peter,
ich erhalte aber nicht das gewünschte Ergebnis mit Deiner Formel.
Das Ergebnis hatte ich in Spalte D angegeben
to top
#6
Hi Edgar,

SUMMEWENNS geht in diesem Fall nicht - Jannils hat XL-Version 2003
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#7
(01.03.2015, 14:48)BoskoBiati schrieb: Hallo,

dann würde auch das funktionieren:



Code:
=SUMMEWENNS($B$4:$B$13;$A$4:$A$13;"MP4";$B$4:$B$13;0,8)

Hallo Edgar,
führt auch nicht zu der gewünschten Endsumme.
siehe Antwort AN Peter; oder mache ich was falsch?
to top
#8
Hallo,

und welches Ergebnis erhälst du?

Bei mir passt das (B16 und B17 solltest du noch als Prozent formatieren):

Arbeitsblatt mit dem Namen 'beispiel '
 AB
4MP480,0%
5MP4100,0%
6MP480,0%
7MP480,0%
8x 
9MP1n.r.
10MP1n.r.
11SP3n.r.
12SP3n.r.
13SP3n.r.
14  
15Summe MP12
16Summe MP42,4
17Summe MP41
18summe Sp33

ZelleFormel
B15=SUMMENPRODUKT(($A$4:$A$13="MP1")*($B$4:$B$13="n.r."))
B16=SUMMENPRODUKT(($A$4:$A$13="MP4")*($B$4:$B$13=0,8);($B$4:$B$13))
B17=SUMMENPRODUKT(($A$4:$A$13="MP4")*($B$4:$B$13=1);($B$4:$B$13))
B18=SUMMENPRODUKT(($A$4:$A$13="SP3")*($B$4:$B$13="n.r."))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Peter
to top
#9
Hallo,

(01.03.2015, 14:55)WillWissen schrieb: SUMMEWENNS geht in diesem Fall nicht - Jannils hat XL-Version 2003

Wie kommst du darauf - zumindest die hochgeladene Datei mit dem Format xlsx lässt darauf nicht schließen.
Gruß
Peter
to top
#10
Hi Peter,

(01.03.2015, 15:00)Peter schrieb: Wie kommst du darauf - zumindest die hochgeladene Datei mit dem Format xlsx lässt darauf nicht schließen.

weil er es in seinem Profil so angegeben hat (siehe Kopfdaten im Beitrag).
Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Suche nach bestimmten Kriterien abbrechen wirsing 19 197 03.12.2016, 21:18
Letzter Beitrag: schauan
  bedingte Summenbildung dantri81 4 90 01.12.2016, 09:46
Letzter Beitrag: dantri81
  WENN/DANN Gesamtsumme nach Kriterien Baldi 5 80 28.11.2016, 16:53
Letzter Beitrag: Baldi
  Zellen aufsummieren, für die 2 verschiedene Kriterien zutreffen rincewind 5 101 09.11.2016, 16:27
Letzter Beitrag: rincewind
  Summe ohne Duplikate mit mehreren Kriterien ConDucTi 7 159 08.11.2016, 13:40
Letzter Beitrag: ConDucTi
  Sverweis mit mehreren Kriterien Excelmonsta 12 177 19.10.2016, 11:51
Letzter Beitrag: Jockel
  Datenüberprüfung mit mehreren Kriterien Gabriel 4 129 19.10.2016, 11:22
Letzter Beitrag: BoskoBiati
  Automatische Summenbildung HBVAW 5 101 17.10.2016, 13:43
Letzter Beitrag: HBVAW
  Tabellenblätter nach Kriterien abfragen PHI 16 593 30.09.2016, 16:32
Letzter Beitrag: shift-del
  Kontoauszug Filtern nach Datum & Kriterien brendli 3 182 26.09.2016, 19:40
Letzter Beitrag: schauan

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste