Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


MSG-Box, wenn Zellen nicht = 0
#1
Hallo Helfer

Könnt Ihr mir bitte ein Makro schreiben das folgendes auslöst:

Wenn im aktiven Tabellenblatt die Zellen  
Q24    und/oder  
Q32    und/oder 
Q37
<> 0 sind,
Hintergrund der betroffenen vorgelagerten Zellen
B24, B32, B37
rot einfärben
und eine MSG-Box anzeigen mit dem Text "Kontierung fehlt!"

Also wenn zum Beispiel die Zellen Q24 und Q37 <> 0 sind,
die Zellen B24 und B37 rot einfärben
und die MSG-Box anzeigen.

Ich bin sehr froh, wenn Ihr mir helfen könnt.

Dank und Gruss

Theo
to top
#2
Hallo Theo,

das sind mir zu viele UND/ODER Huh .

Dein Beispiel ist soweit klar. Aber was ist in diesem Fall mit der Zelle Q32?

Gruß
Max
to top
#3
Hallo Theo,

grundsätzlich ginge es leichter mit einer Kombination aus Bedingter Formatierung und Datengültigkeit, also ohne VBA.


Wenn Du aber unbedingt VBA einsetzen möchtest, dann brauchen wir mehr Infos.
Soll das Makro manuell angestoßen werden?
Wenn ja, muss noch ein Makro her, dass nach Korrektur der Eingaben die Farben wieder zurücksetzt, auch manuell.

Sonst musst Du beschreiben, ob die Eingaben in Spalte B gemacht werden oder in andern Zellen?
Gruß Atilla

Excel 2007
to top
#4
Hallo Max

Danke für Deine Antwort.

Q32 ist in meinem Beispiel = 0, also muss B32 nicht eingefärbt werden.

Zur Erklärung:
In Spalte B sind Kontierungen. In Spalte Q kumulierte Umsätze.
Es braucht jedoch nur einen Eintrag in Spalte B, wenn auch Werte in Spalte Q vorhanden sind.

Wenn in einer Zelle in Spalte Q ein Wert vorhanden ist, muss das Makro prüfen ob in Spalte
B auf der gleichen Zeile ein Eintrag enthalten ist. Also Zellinhalt <> 0.
Wenn nein, soll es Zelle Bx markieren und die MSG-Box aktivieren.

Gruss

Theo
to top
#5
Hi Theo,

also prüfst Du zeilenweise. Okay.

Dann blieben noch die Fragen von Atilla offen.

Gruß
Max
to top
#6
(24.02.2015, 12:43)atilla schrieb: Hallo Theo,

grundsätzlich ginge es leichter mit einer Kombination aus Bedingter Formatierung und Datengültigkeit, also ohne VBA.


Wenn Du aber unbedingt VBA einsetzen möchtest, dann brauchen wir mehr Infos.
Soll das Makro manuell angestoßen werden?
Wenn ja, muss noch ein Makro her, dass nach Korrektur der Eingaben die Farben wieder zurücksetzt, auch manuell.

Sonst musst Du beschreiben, ob in die Eingaben in Spalte B gemacht werden oder in andern Zellen?

Hallo Atilla

Ich brauche die MSG-Box, damit die fehlende Kontierung nicht übersehen wird. Ich denke, das geht nur mit VBA, oder?
Das Makro soll angestossen werden, wenn in Spalte Q der Wert <> 0 wird. Der Wert wird aus vorgelagerten Zellen berechnet.

An das Zurücksetzten der Farbe habe ich nicht gedacht.
Kann man im Makro einbauen, dass, wenn in den definierten Zellen Qx und den entsprechenden Zellen Bx
in beiden Zellen "0" oder in beiden Zellen ein Wert ist, keine Färbung erfolgen soll?
  Huh
Kompliziert...

Danke Dir für Deine Unterstützung

Gruss

Theo
to top
#7
Hallo Theo,

eine Datei mit anonymisierten Daten wäre einfacher für uns.
Wie sollen wir wissen, in welchem Bereich die auszuwertenden Daten stehen?
Hast Du in Zeile 1 Überschriften und danach folgen dann die Daten, oder wie sieht die Tabelle aus?

Gruß
Max
to top
#8
Hallo Theo,

das geht auch ohne VBA.

In den Zellen der Spalte Q befinden sich Formeln, richtig?
Diese Formel hat einen Bezug zu einer Zelle, in der eine Eingabe gemacht wird. Welche Zelle ist das?

Zeig uns mal die Formel in Q24
Gruß Atilla

Excel 2007
to top
#9
(24.02.2015, 13:19)atilla schrieb: Hallo Theo,

das geht auch ohne VBA.

In den Zellen der Spalte Q befinden sich Formeln, richtig?
Diese Formel hat einen Bezug zu einer Zelle, in der eine Eingabe gemacht wird. Welche Zelle ist das?

Zeig uns mal die Formel in Q24

Hallo Atilla

auch mit MSG-Box? Oder Kommentar? Oder sonst einem Popup? Ich bin gespannt.

Also, in Q24 steht zum Beispiel:
=SUMME(E24Tongue24)

Gruss

Theo
to top
#10
(24.02.2015, 13:28)Theo schrieb:
(24.02.2015, 13:19)atilla schrieb: Hallo Theo,

das geht auch ohne VBA.

In den Zellen der Spalte Q befinden sich Formeln, richtig?
Diese Formel hat einen Bezug zu einer Zelle, in der eine Eingabe gemacht wird. Welche Zelle ist das?

Zeig uns mal die Formel in Q24

Hallo Atilla

auch mit MSG-Box? Oder Kommentar? Oder sonst einem Popup? Ich bin gespannt.

Also, in Q24 steht zum Beispiel:
=SUMME(E24Tongue24)

Gruss

Theo

Hallo Atilla,

Ich bin irritiert.
Warum steht da nicht
=Summe(E23:'P14')

Theo
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  WENN 5 Zellen ISTLEER dann... Argre 7 107 03.12.2016, 22:48
Letzter Beitrag: schauan
  Formel funktioniert nicht (WENN) StefanM 14 223 03.12.2016, 20:58
Letzter Beitrag: schauan
  Formel funktioniert nicht in allen Zellen Lini Morini 10 130 25.11.2016, 15:14
Letzter Beitrag: Jockel
  Wenn Zelleninhalt > 0 dann die 5 linken Zellen farbig Daniel Albert 5 83 22.11.2016, 18:48
Letzter Beitrag: Daniel Albert
  Summe wenn Zellen befüllt sind Nightshift 2 79 13.11.2016, 21:17
Letzter Beitrag: Nightshift
  Zellen automatisch füllen, wenn eine Bedingung erfüllt Bananajo 4 148 15.10.2016, 17:20
Letzter Beitrag: schauan
  Wenn Spalte E nicht leer dann Datum in Spalte O VBA BadHabiit 4 240 20.09.2016, 14:49
Letzter Beitrag: BadHabiit
  EXCEL VBA Zellen sperren wenn Bedingung erfüllt! mirobo 1 212 14.09.2016, 14:17
Letzter Beitrag: schauan
  Diagramm mit nicht zusammenhängenden Zellen erstellen Günti 2 173 14.09.2016, 09:17
Letzter Beitrag: Günti
  Wenn dann Formel mit und Bedingung funktioniert nicht Svenja94 23 909 31.08.2016, 08:27
Letzter Beitrag: steve1da

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste