Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Verknüpfungen
#1
Hallo!

Ich möchte z.B. in der Tabelle die 20€ so verknüpfen, dass diese immer hinter dem A auftaucht.
Lässt sich das irgendwie automatisch machen?
Weil wenn man eine sehr lange Tabelle hat kostet das viel Zeit.

LG  


Angehängte Dateien Thumbnail(s)
   
to top
#2
Hallo

dann schreib in B1:

Code:
=WENN(A1="A";"20 €";"")
Gruß
Fred0



Meine Antworten sind freiwillig und ohne Gewähr!
Wenn nichts angegeben beziehe ich mich auf Excel 2016

to top
#3
(23.02.2015, 22:02)Fred0 schrieb: Hallo

dann schreib in B1:





Code:
=WENN(A1="A";"20 €";"")


Vielen Dank!

Lassen sich auch gleichzeitig mehrere Zahlen z.B. aus den drei Zellen verknüpfen oder ist das nicht möglich?


Angehängte Dateien Thumbnail(s)
   
to top
#4
Hi,

(23.02.2015, 23:10)chrise81 schrieb:
Code:
=WENN(A1="A";"20 €";"")
Lassen sich auch gleichzeitig mehrere Zahlen z.B. aus den drei Zellen verknüpfen oder ist das nicht möglich?

so?

Tabelle1
ABCD
1A203040
2B
3C
4A203040
5B
6C
7A203040
8B
9C
10
11203040

verwendete Formeln
Zelle Formel Bereich N/A
B1: D9=WENN($A1="A";A$11;"")

Zahlenformate
Zelle Format Wert
A11, B1, B4, B7 '_-* #.##0,00 €_-;-* #.##0,00 €_-;_-* "-"?? €_-;_-@_- 20
B2: D3, B5: D6, B8: D9 '_-* #.##0,00 €_-;-* #.##0,00 €_-;_-* "-"?? €_-;_-@_-
B11, C1, C4, C7 '_-* #.##0,00 €_-;-* #.##0,00 €_-;_-* "-"?? €_-;_-@_- 30
C11, D1, D4, D7 '_-* #.##0,00 €_-;-* #.##0,00 €_-;_-* "-"?? €_-;_-@_- 40
Zellen mit Format Standard werden nicht dargestellt
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.19 einschl. 64 Bit

Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top
#5
(23.02.2015, 23:37)Rabe schrieb: Hi,




(23.02.2015, 23:10)chrise81 schrieb:
Code:
=WENN(A1="A";"20 €";"")
Lassen sich auch gleichzeitig mehrere Zahlen z.B. aus den drei Zellen verknüpfen oder ist das nicht möglich?

so?

Tabelle1
ABCD
1A203040
2B
3C
4A203040
5B
6C
7A203040
8B
9C
10
11203040

verwendete Formeln
Zelle Formel Bereich N/A
B1: D9=WENN($A1="A";A$11;"")

Zahlenformate
Zelle Format Wert
A11, B1,  B4,   B7 '_-* #.##0,00 €_-;-* #.##0,00 €_-;_-* "-"?? €_-;_-@_- 20
B2: D3, B5: D6,  B8: D9 '_-* #.##0,00 €_-;-* #.##0,00 €_-;_-* "-"?? €_-;_-@_-
B11, C1,  C4,   C7 '_-* #.##0,00 €_-;-* #.##0,00 €_-;_-* "-"?? €_-;_-@_- 30
C11, D1,  D4,   D7 '_-* #.##0,00 €_-;-* #.##0,00 €_-;_-* "-"?? €_-;_-@_- 40
Zellen mit Format Standard werden nicht dargestellt
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.19 einschl. 64 Bit

Hallo!

Danke, in diesem Beispiel funktioniert das schon ganz gut Smile
Zuerst dachte ich, dass es nicht klappt weil sich nur die 20 gezeigt hat. Aber ich musste das Kästchen dann halt bis zum dritten weiterziehen.

Ich habe jetzt aber ein anderes Problem. Die Werte befinden sich auf einem anderen Reiter.
Formel: =WENN($A1="A";Tabelle2!A$1:C$1;"")
Wenn ich das aber so eingebe, dann sieht es so aus wie im Anhang.
Was mache ich falsch? Smile


Angehängte Dateien Thumbnail(s)
   
to top
#6
Hi,

die Zahlen befinden sich im Tabelllenblatt2 in A1 bis C1.

Tabelle1

ABCD
1A203040
2B
3C
4A203040
5B
6C
7A203040
8B
9C
Formeln der Tabelle
ZelleFormel
B1=WENN($A1<>"A";"";Tabelle2!A$1)
C1=WENN($A1<>"A";"";Tabelle2!B$1)
D1=WENN($A1<>"A";"";Tabelle2!C$1)
B2=WENN($A2<>"A";"";Tabelle2!A$1)
C2=WENN($A2<>"A";"";Tabelle2!B$1)
D2=WENN($A2<>"A";"";Tabelle2!C$1)
B3=WENN($A3<>"A";"";Tabelle2!A$1)
C3=WENN($A3<>"A";"";Tabelle2!B$1)
D3=WENN($A3<>"A";"";Tabelle2!C$1)
B4=WENN($A4<>"A";"";Tabelle2!A$1)
C4=WENN($A4<>"A";"";Tabelle2!B$1)
D4=WENN($A4<>"A";"";Tabelle2!C$1)
B5=WENN($A5<>"A";"";Tabelle2!A$1)
C5=WENN($A5<>"A";"";Tabelle2!B$1)
D5=WENN($A5<>"A";"";Tabelle2!C$1)
B6=WENN($A6<>"A";"";Tabelle2!A$1)
C6=WENN($A6<>"A";"";Tabelle2!B$1)
D6=WENN($A6<>"A";"";Tabelle2!C$1)
B7=WENN($A7<>"A";"";Tabelle2!A$1)
C7=WENN($A7<>"A";"";Tabelle2!B$1)
D7=WENN($A7<>"A";"";Tabelle2!C$1)
B8=WENN($A8<>"A";"";Tabelle2!A$1)
C8=WENN($A8<>"A";"";Tabelle2!B$1)
D8=WENN($A8<>"A";"";Tabelle2!C$1)
B9=WENN($A9<>"A";"";Tabelle2!A$1)
C9=WENN($A9<>"A";"";Tabelle2!B$1)
D9=WENN($A9<>"A";"";Tabelle2!C$1)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8


Du gibst diese Formel  =WENN($A1<>"A";"";Tabelle2!A$1) im Blatt1 in die Zelle B1 ein und ziehst sie nach rechts und nach unten.
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
chrise81
to top
#7
Hi,

(24.02.2015, 00:38)chrise81 schrieb: Ich habe jetzt aber ein anderes Problem. Die Werte befinden sich auf einem anderen Reiter.
Formel: =WENN($A1="A";Tabelle2!A$1:C$1;"")
Wenn ich das aber so eingebe, dann sieht es so aus wie im Anhang.
Was mache ich falsch? Smile

zuerst: Du musst nicht den ganzen Vorgängerbeitrag zitieren, es reicht der relevante Teil, der Beitrag steht doch darüber.

Zum zweiten: mit Tabelle2!A$1:C$1 beziehst DU Dich auf mehrere Zellen, woher soll Excel wissen, welcher Wert verwendet werden soll?
Wenn, dann so:
Für die erste Spalte: =WENN($A1="A";Tabelle2!A$1;"")
zweite Spalte: =WENN($A1="A";Tabelle2!B$1;"")
dritte Spalte: =WENN($A1="A";Tabelle2!C$1;"")

Excel passt die Formel an, wenn Du sie rüber und runter ziehst. Mit dem $ wird dann die Zeile fixiert und die Spalte weitergezählt.

zum Dritten:
Ein Bild der Tabelle ist schlecht, besser wäre ein Ausschnitt erfasst mit einem der von uns verwendeten Tools, mit diesem können die Ausschnitte auch wieder in eine Tabelle rückgewandelt werden.
Also stelle die relevanten Ausschnitte hier dar, siehe die als Wichtige Themen: markierten Forums-Beiträge.
Die farbigen Texte sind anklickbare Links:

Beitrag 1 Für Neulinge im Forum: Tabellenausschnitte im Forum einstellen



Ich würde es so machen, dann kannst Du in Tabelle 2 für jeden Buchstaben die entsprechenden Beträge definieren und mit nur einer Formel rüberholen.

Tabelle1
ABCD
1A203040
2B506070
3C8090100
4A203040
5B506070
6C8090100
7A203040
8B506070
9C8090100

verwendete Formeln
Zelle Formel Bereich N/A
B1: D9=SVERWEIS($A1;Tabelle2!$A$1:$D$3;SPALTE(B$1);0)

Zahlenformate
Zelle Format Wert
B1, B4,  B7 '_-* #.##0,00 €_-;-* #.##0,00 €_-;_-* "-"?? €_-;_-@_- 20
B2, B5,  B8 '_-* #.##0,00 €_-;-* #.##0,00 €_-;_-* "-"?? €_-;_-@_- 50
B3, B6,  B9 '_-* #.##0,00 €_-;-* #.##0,00 €_-;_-* "-"?? €_-;_-@_- 80
C1, C4,  C7 '_-* #.##0,00 €_-;-* #.##0,00 €_-;_-* "-"?? €_-;_-@_- 30
C2, C5,  C8 '_-* #.##0,00 €_-;-* #.##0,00 €_-;_-* "-"?? €_-;_-@_- 60
C3, C6,  C9 '_-* #.##0,00 €_-;-* #.##0,00 €_-;_-* "-"?? €_-;_-@_- 90
D1, D4,  D7 '_-* #.##0,00 €_-;-* #.##0,00 €_-;_-* "-"?? €_-;_-@_- 40
D2, D5,  D8 '_-* #.##0,00 €_-;-* #.##0,00 €_-;_-* "-"?? €_-;_-@_- 70
D3, D6,  D9 '_-* #.##0,00 €_-;-* #.##0,00 €_-;_-* "-"?? €_-;_-@_- 100
Zellen mit Format Standard werden nicht dargestellt


Tabelle2
ABCD
1A203040
2B506070
3C8090100

Zahlenformate
Zelle Format Wert
B1 '_-* #.##0,00 €_-;-* #.##0,00 €_-;_-* "-"?? €_-;_-@_- 20
B2 '_-* #.##0,00 €_-;-* #.##0,00 €_-;_-* "-"?? €_-;_-@_- 50
B3 '_-* #.##0,00 €_-;-* #.##0,00 €_-;_-* "-"?? €_-;_-@_- 80
C1 '_-* #.##0,00 €_-;-* #.##0,00 €_-;_-* "-"?? €_-;_-@_- 30
C2 '_-* #.##0,00 €_-;-* #.##0,00 €_-;_-* "-"?? €_-;_-@_- 60
C3 '_-* #.##0,00 €_-;-* #.##0,00 €_-;_-* "-"?? €_-;_-@_- 90
D1 '_-* #.##0,00 €_-;-* #.##0,00 €_-;_-* "-"?? €_-;_-@_- 40
D2 '_-* #.##0,00 €_-;-* #.##0,00 €_-;_-* "-"?? €_-;_-@_- 70
D3 '_-* #.##0,00 €_-;-* #.##0,00 €_-;_-* "-"?? €_-;_-@_- 100
Zellen mit Format Standard werden nicht dargestellt
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.22 einschl. 64 Bit

Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
[-] Folgende(r) 1 Benutzer sagt Danke an Rabe für diesen Beitrag:
chrise81
to top
#8
Hallo!

Vielen Dank für die Antworten.
Ich werde versuchen, dass mit Euren Tipps hinzukriegen. Als Anfänger muss man sich da ein wenig reinfuxen Wink

Ich hätte noch eine Frage: Wenn Ich z.B. den Filter benutze, nach A filtere, dann kann ich einen verknüpften Wert einfach runterziehen. Wenn ich aber z.B. die drei Werte nehme und dann runter ziehen, dann erhalte ich nur Nullen. Gibt es eine einfache Möglichkeit mehrere Verknüpfte Zellen gleichzeitig runterzuziehen?

Danke für den Hinweis mit den „relevanten Ausschnitten“. Wusste gar nicht, dass es so etwas gibt Smile

Beste Grüße
to top
#9
Hi,

(24.02.2015, 13:16)chrise81 schrieb: Ich hätte noch eine Frage: Wenn Ich z.B. den Filter benutze, nach A filtere, dann kann ich einen verknüpften Wert einfach runterziehen. Wenn ich aber z.B. die drei Werte nehme und dann runter ziehen, dann erhalte ich nur Nullen. Gibt es eine einfache Möglichkeit mehrere Verknüpfte Zellen gleichzeitig runterzuziehen?

ich verstehe jetzt die Frage nicht.

Warum willst Du filtern, um die Formel zu ziehen? Du kannst sie doch einfach ohne filtern ziehen, durch die Formel wird doch bisher nach gar nichts anderem gesucht als nach A.

Nur meine SVERWEIS-Formel holt die Werte auch zu B und C
Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top
#10
Hallo,

Zitat:Wenn ich aber z.B. die drei Werte nehme und dann runter ziehen, dann erhalte ich nur Nullen. Gibt es eine einfache Möglichkeit mehrere Verknüpfte Zellen gleichzeitig runterzuziehen?

sowohl Ralf als auch ich haben dir funktionsfähige Vorschläge gemacht und auch auf deren Anwendung hingewiesen. Da du anscheinend noch Probleme beim Umsetzen der Vorschläge hast, solltest du deine Datei mit den von dir eingesetzten Formeln hochladen. Nur so können wir dir gezielt sagen, wo der Fehler ist.
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Excel Makro oder Verknüpfungen? freeloader1986 5 173 29.09.2016, 13:20
Letzter Beitrag: freeloader1986
  Wenn Formel mit Stunden Verknüpfungen Actionfreak 5 147 20.09.2016, 14:31
Letzter Beitrag: Actionfreak
  Dateiumbenennung und Verknüpfungen beibehalten Kamamalo 12 372 12.09.2016, 15:22
Letzter Beitrag: schauan
  Externe Verknüpfungen INDIVIDUELL aktualisieren Albus1965 2 253 26.07.2016, 06:59
Letzter Beitrag: Rabe
  Fehleranzeige bei Verknüpfungen, aber Status ok Denise 2 345 08.07.2016, 09:20
Letzter Beitrag: Denise
  Verknüpfungen suchen tesch Tegen 2 426 13.04.2016, 10:30
Letzter Beitrag: shift-del
  Aktualisieren von Verknüpfungen zwischen 2 Dateien el cativo 2 485 22.12.2015, 12:14
Letzter Beitrag: el cativo
  Einstellung der Verknüpfungen cuba 0 189 12.12.2015, 17:44
Letzter Beitrag: cuba
  Excel Fehler bei Verknüpfungen (VBA) friedensbringer 1 495 25.11.2015, 16:50
Letzter Beitrag: RPP63
  Sortierung einer Tabelle mit Verknüpfungen fischi-01 25 3.326 07.09.2015, 11:27
Letzter Beitrag: fischi-01

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste