Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Dopplungen im sverweis
#1
Hallo,

ich habe eine angepasste Tabelle aller Gemeinden vom Statistischen Bundesamt (Tabellenblatt "VG250"). Im Tabellenblatt "sverweis" sollen ca. 6.000 Zeilen eingefügt werden und dann über den Gemeindenamen der Allgemeine Gemeinde Schlüssel (AGS) zugewiesen werden. Die Gemeindenamen sind leider nicht eindeutig, deshalb brauche ja die Zuweisung zu den AGS. Gibt es eine Möglichleit, dass alle eindeutigen zugewiesen werden und gleichzeitig alle mehrdeutigen irgendwie markiert werden? Ich denke daran, dass einfach alle AGS-Werte reingeschrieben werden. Dann lässt sich ja auch relativ einfach nachvollziehen, welche noch einmal manuell geprüft werden müssen. Oder evtl auch eine andere Variante. Bin für alles offen.

Ps: in meiner Tabelle sind rund 11.000 Gemeinden, aufgrund der Größenbeschränkung musste ich sie kürzen.

Viele Grüße


Angehängte Dateien
.xlsx   dopplungen Sverweis.xlsx (Größe: 137,67 KB / Downloads: 6)
to top
#2
Hallo

Meinst du es so?
Code:
=WENN(ZÄHLENWENN('VG250'!$E$2:$E$1068;A2)>1;"mehrere Einträge";SVERWEIS(A2;'VG250'!E:F;2;FALSCH))
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Sverweis aktualisiert nicht automatisch und Sverweis mit Trennen von einer Zelle vivendo 15 3.339 27.05.2015, 08:13
Letzter Beitrag: BoskoBiati

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste