Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Wählen und Anzeigen
#1
Hallo Forum,

ist vermutlich nicht schwer aber ich komme gerade nicht selbst auf die Lösung:

In C5 kann man ein Start-Datum aussuchen (Dropdown) (formatiert als Datum: (Wochentag, Zahl. Monat Jahr)
IN D5 kann man ein End-Datum aussuchen (Dropdown) (formatiert wie oben)

von F5 bis M5 sind die auswählbaren Tage nochmal in Form einer Übersicht darstellt.

Das Ziel:

Wählt jemand in C5 und D5 ein entsprechendes Datum aus, so soll ihm seine Auswahl (und die dazwischen liegenden Tage in F5 bis M5) angezeigt werden. Die ausgewählten Tage sollen dann mit "X" gekennzeichnet werden.

Vorab herzlichen Dank für eure Hilfe!

Viele Grüße
Alex
to top
#2
Hallo Alex,

die Dropdowns bekommst Du selber hin?

Arbeitsblatt mit dem Namen 'Tabelle1'
 CDEFGHIJKLMNOPQ
519.02.201524.02.2015 16. Feb17. Feb18. Feb19. Feb20. Feb21. Feb22. Feb23. Feb24. Feb25. Feb26. Feb27. Feb
6      XXXXXX   

ZelleFormel
C5=HEUTE()
D5=HEUTE()+5
F6=WENN(UND(F5>=$C$5;F5<=$D$5);"X";"")
G6=WENN(UND(G5>=$C$5;G5<=$D$5);"X";"")
H6=WENN(UND(H5>=$C$5;H5<=$D$5);"X";"")
I6=WENN(UND(I5>=$C$5;I5<=$D$5);"X";"")
J6=WENN(UND(J5>=$C$5;J5<=$D$5);"X";"")
K6=WENN(UND(K5>=$C$5;K5<=$D$5);"X";"")
L6=WENN(UND(L5>=$C$5;L5<=$D$5);"X";"")
M6=WENN(UND(M5>=$C$5;M5<=$D$5);"X";"")
N6=WENN(UND(N5>=$C$5;N5<=$D$5);"X";"")
O6=WENN(UND(O5>=$C$5;O5<=$D$5);"X";"")
P6=WENN(UND(P5>=$C$5;P5<=$D$5);"X";"")
Q6=WENN(UND(Q5>=$C$5;Q5<=$D$5);"X";"")
Diese Tabelle wurde mit Tab2Html (v2.5.0) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
[-] Folgende(r) 1 Benutzer sagt Danke an schauan für diesen Beitrag:
Alex105
to top
#3
Hallo Schauan,

ich wusste es. Ich hatte einen Fehler mit der UND variante. Sonst sind die Formeln gleich.

Ich versuche es gleich morgen früh!

Aber, vielen Dank schon mal :-) 15

Viele Grüße

Alex
to top
#4
Hallo André,

hm. Irgendwie mache ich scheinbar was falsch 16

Das Auswahldatum in C5 und D5 stehen per Dropdown fest (Dropdownauswahl = Liste auf Tabellenblatt 2). Mann kann nur zwischen 7 Tagen auswählen, in einem definierten Zeitraum. Ist die Formel =heute() & =heute()+5 dann noch richtig?

Von F4 bis M4 steht nur ein Datum und darüber -also F3 bis M3- die passenden Wochentage als Wort.

Treffe ich eine Auswahl in C5 und D5 soll mir also ein "X" -in F5 bis M5- meine Auswahl kennzeichnen und der Rest soll "" dargestellt werden.

Wärst du nochmal so nett? 100

Herzlichen Dank Smile

Alex
to top
#5
Hallo Alex,

André hat dir genau nach deiner Beschreibung eine Lösung angeboten. Auch nach deiner zweiten Erklärung passt Andrés Vorschlag. Ich habe ihn dir hier nochmals (mit ein paar anderen Werten) als Tabellenausschnitt eingestellt.

Tabelle1

CDEFGHIJKLMN
3Mo., 12. JanDi., 13. JanMi., 14. JanDo., 15. JanFr., 16. JanSa., 17. JanSo., 18. JanDropdownliste
4xx01. Jan
514.01.201515.01.201502. Jan
603. Jan
704. Jan
805. Jan
906. Jan
1007. Jan
1108. Jan
1209. Jan
1310. Jan
1411. Jan
1512. Jan
1613. Jan
1714. Jan
1815. Jan
Formeln der Tabelle
ZelleFormel
F4=WENN(UND(F3>=$C$5;F3<=$D$5);"x";"")
G4=WENN(UND(G3>=$C$5;G3<=$D$5);"x";"")
H4=WENN(UND(H3>=$C$5;H3<=$D$5);"x";"")
I4=WENN(UND(I3>=$C$5;I3<=$D$5);"x";"")
J4=WENN(UND(J3>=$C$5;J3<=$D$5);"x";"")
K4=WENN(UND(K3>=$C$5;K3<=$D$5);"x";"")
L4=WENN(UND(L3>=$C$5;L3<=$D$5);"x";"")
Datengültigkeit der Tabelle
ZelleZulassenDatenEingabe 1Eingabe 2
C5Liste=$N$4:$N$18
D5Liste=$N$4:$N$18

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Edit:

Tabellenausschnitt vergessen Sad

Falls es immer noch nicht dein erwünschtes Ergebnis bringt, solltes du uns deine Datei (gerne anonymisiert) hochladen und dein Wunschergebnis manuell eintragen.
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
Alex105
to top
#6
Hallo Günter,

schein nicht ganz mein bester Excel Tag zu sein heute Blush
Funktioniert super. Ich habe am Ende noch -1 eingetragen, damit er mir die für mich benötigte "Wahrheit" anzeigt.

Thema gelöst!

Herzlichsten Dank!

Bis bald 28

Alex
to top
#7
(20.02.2015, 12:29)Alex105 schrieb: Hallo
...
Ich habe am Ende noch -1 eingetragen, damit er mir die für mich benötigte "Wahrheit" anzeigt.
...
Alex

Hallo, was meinst Du denn mit -1..? Wie sieht denn Deine Formel jetzt aus..?
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#8
Hallo Jockel,

sorry, für die späte Rückmeldung. Irgendwie habe ich keine E-Mail zu dem Thema bekommen.

=WENN(UND(F$5>=$C7;F$5<=$D7-1);"X";"")

Viele Grüße
Alex
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Matrix nach Bedingung wählen birnemaik 4 234 07.08.2016, 12:08
Letzter Beitrag: RPP63
  Filter Farbe wählen YvonneW 8 1.752 23.01.2015, 22:37
Letzter Beitrag: YvonneW

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste