Bedingung (Zelle mit Nachfolgezelle abgleichen)
#1
Guten Abend,

hoffe es kann mir auch bei diesem Problem jemand helfen.


Beispiel:

Werte Zeilenweise angeordnet:
A2:2 B2:4 C2:5 D2:2 E2:3 ...

Steht in Zelle die Zahl 2?
-> ja
-> prüfe ob in Folge-Zelle die Zahl 3 steht
-> ja
-> Bedingung erfüllt und zählen
(und dies für jede Zelle bzw. Folgezelle über ca. 500 Spalten) -> am Ende soll dann die Summe der gefunden Zellen ausgegeben werden (in dem obigen Beispiel wäre das Ergebnis also 1 (nur für D2 und E2 zutreffend)

-> Ansatz: =Wenn(UND(A2=2;B2=3);1;0)
-> daraus generiere ich eine Hilfstabelle und bilde daraus die Summe.
-> das ist aber unschön und nicht sehr komfortabel...

Ich suche jetzt nach einer Formel, die ohne die Hilfstabelle mir die Summe in einem Schritt berechnet.
to top
#2
Hallo

Zitat:das ist aber unschön und nicht sehr komfortabel...
Deine Formel läßt sich noch kürzen:
Code:
=(A2=2)*(B2=3)
Und gegen Hilfszellen ist erst mal nichts einzuwenden.
Eine Ein-Formel-Lösung wäre:
Code:
=SUMMENPRODUKT((A2:E2=2)*(B2:F2=3))
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
to top
#3
Perfekt. Funktioniert einwandfrei.

Vielen Dank
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste