Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

Bedingung (Zelle mit Nachfolgezelle abgleichen)
#1
Guten Abend,

hoffe es kann mir auch bei diesem Problem jemand helfen.


Beispiel:

Werte Zeilenweise angeordnet:
A2:2 B2:4 C2:5 D2:2 E2:3 ...

Steht in Zelle die Zahl 2?
-> ja
-> prüfe ob in Folge-Zelle die Zahl 3 steht
-> ja
-> Bedingung erfüllt und zählen
(und dies für jede Zelle bzw. Folgezelle über ca. 500 Spalten) -> am Ende soll dann die Summe der gefunden Zellen ausgegeben werden (in dem obigen Beispiel wäre das Ergebnis also 1 (nur für D2 und E2 zutreffend)

-> Ansatz: =Wenn(UND(A2=2;B2=3);1;0)
-> daraus generiere ich eine Hilfstabelle und bilde daraus die Summe.
-> das ist aber unschön und nicht sehr komfortabel...

Ich suche jetzt nach einer Formel, die ohne die Hilfstabelle mir die Summe in einem Schritt berechnet.
to top
#2
Hallo

Zitat:das ist aber unschön und nicht sehr komfortabel...
Deine Formel läßt sich noch kürzen:
Code:
=(A2=2)*(B2=3)
Und gegen Hilfszellen ist erst mal nichts einzuwenden.
Eine Ein-Formel-Lösung wäre:
Code:
=SUMMENPRODUKT((A2:E2=2)*(B2:F2=3))
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
to top
#3
Perfekt. Funktioniert einwandfrei.

Vielen Dank
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Zwei Tabellen abgleichen brummel 3 126 17.02.2017, 19:39
Letzter Beitrag: schauan
  Datum abgleichen und ggf. Wert aus Zelle wiedergeben Tobias159 13 309 19.01.2017, 09:50
Letzter Beitrag: Tobias159
  Werte mit vorgegebener Menge abgleichen aeugeln 7 330 08.12.2016, 06:19
Letzter Beitrag: WillWissen
  Excel Listen automatisch miteinander abgleichen Kickban 7 475 05.11.2016, 16:28
Letzter Beitrag: schauan
  Einträge abgleichen, nach Datenvergleich Dolly 1 179 25.10.2016, 13:25
Letzter Beitrag: steve1da
Sad Pivot Tabelle, Werte abgleichen caro2508 1 328 17.08.2016, 13:39
Letzter Beitrag: Peter
  Preise und Warenbestand mithilfe Excel Listen abgleichen crystalkoch 4 479 31.05.2016, 10:07
Letzter Beitrag: MatiW
  Tabellen abgleichen ? patrickkupper 21 1.631 26.05.2016, 23:48
Letzter Beitrag: Gast 123
  2 Tabellen abgleichen, doppelte Namen entfernen Jasper 8 1.262 09.12.2015, 20:43
Letzter Beitrag: schauan
  Mehrfachauswahl mit einer Liste abgleichen und untereinander vergleichen Knut S. 3 730 24.11.2015, 23:28
Letzter Beitrag: Karl-Heinz

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste