Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Progressiver Prozentsatz
#1
Hallo, ich habe ein Problem mit WENN und DANN Wink

Kann mir jemand helfen, die Felder wie u.a. zu programmieren?
(Anteilige Gewichtung, dass Ertrag bis 50.000€ dann 50% anteilig ist, dann
Ertrag von 50.000 bis 100.000 zu 68% anteilig ist usw...)

Danke vorab & VG,

Gesamtertrag in EUR xxx.xxx (z.B. 131.927,-)

Ertrag in EUR Faktor Ertrag in EUR

bis 50.000,00 € 50%
bis 100.000,00 € 68%
bis 150.000,00 € 70%
bis 200.000,00 € 75%
ab 200.001,00 € 80%
to top
#2
Hi Manhac,

das ist der klassische Fall für den Sverweis,

schau dir das mal an:



Tabelle1
ABCDEFGH
1500000,5
21000000,68ErtragFaktor ErtragGesamt
31500000,7Betrag155000108500263500
42000000,75
5200000,010,8
6

verwendete Formeln
Zelle Formel Bereich N/A
G3=WENNFEHLER(SVERWEIS(F3;$B$1:$C$5;2);0)*F3
H3=F3+G3
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 14.24 einschl. 64 Bit

Es ist nicht genug, zu wissen. Man muss es auch anwenden.
Es ist nicht genug, zu wollen. Man muss es auch tun.
to top
#3
Hallo Heinz,

wird nicht so ein Schuh draus?

Tabelle1

ABCDEFGHIJK
1Vorgabe
2ErtragFaktor ErtragGesamtbis50.000,0050%0,010,5
3Betrag    49.900,00 € 50%    74.850,00 € bis100.000,0068%500000,68
4    50.000,00 € 68%    84.000,00 € bis150.000,0070%1000000,7
5    99.999,00 € 68%  167.998,32 € bis200.000,0075%1500000,75
6  100.000,00 € 70%  170.000,00 € ab200.001,0080%2000000,8
7  149.900,00 € 70%  254.830,00 €
8  199.000,00 € 75%  348.250,00 €
9  200.000,00 € 80%  360.000,00 €
Formeln der Tabelle
ZelleFormel
C3=SVERWEIS(B3;$J$2:$K$6;2;1)
D3=B3+(B3*C3)
C4=VERWEIS(B4;$J$2:$K$6;$K$2:$K$6)
D4=B4+(B4*C4)
C5=VERWEIS(B5;$J$2:$K$6;$K$2:$K$6)
D5=B5+(B5*C5)
C6=VERWEIS(B6;$J$2:$K$6;$K$2:$K$6)
D6=B6+(B6*C6)
C7=VERWEIS(B7;$J$2:$K$6;$K$2:$K$6)
D7=B7+(B7*C7)
C8=VERWEIS(B8;$J$2:$K$6;$K$2:$K$6)
D8=B8+(B8*C8)
C9=VERWEIS(B9;$J$2:$K$6;$K$2:$K$6)
D9=B9+(B9*C9)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#4
Hallo Günter, beim VERWEIS() kannst Du ne Menge (Zeichen) sparen... ... hier reicht..:

PHP-Code:
=VERWEIS(B3;$J$2:$K$6
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#5
Hi Jörg,

yep, absolut richtig. In meinem Tab.-Ausschnitt sollte eigentlich die 2. VERWEIS-Variante ebenfalls noch rein. Aber C & P haben das vereitelt und ich hab's nicht bemerkt. Sad
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#6
Hallöchen,

nach den guten Verweisen mal noch die Prinzip-Antwort zum ursprünglichen Ansatz:
Code:
=WENN(A1<=50.000;0,5*a1;WENN(A1<=100000;0,68*a1;...;WENN(A1<=20000;075*a1;0,8*a1))))...
Klammern müssen hinten genau so viele geschlossen werden wie insgesamt geöffnet.

Die Verweisformeln mit der Hilfstabelle haben den Vorteil, dass bei Änderungen nur die Daten der Hilfstabelle geändert werden müssen und nicht die Formel(n).
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Ausgabe von bestimmten Prozentsatz an Gesamtsumme PraktiController 3 149 10.10.2016, 07:45
Letzter Beitrag: PraktiController
  Prozentsatz grösser in Zellen, dann Msgbox und Eintrag nicht zulassen Mario 7 878 21.10.2015, 09:13
Letzter Beitrag: Mario

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste