Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

Rechnen mit Datum
#1
Hallo Forum

Ich habe in der Beilage eine Datei, welche in der Zelle D20 einen falschen Wert ausgibt.

Dort sollte eigentlich die Differenz der Arbeitstage ausgeweisen werden, auch wenn die Spalte C leer ist; will heissen, ich möchte dort den Wert der Arbeitstage..... Wenn die Spalte C dann mit einem Datum versehen wird, ist die Formel wieder OK!

Freue mich auf eine saubere Lösung.


Angehängte Dateien
.xlsb   Rechnen mit Datum.xlsb (Größe: 16,04 KB / Downloads: 8)
to top
#2
Hallo!
Es gibt im Register Formeln die Formelauswertung!
Lasse sie mal durchlaufen und Du siehst, dass
Code:
WENN(C20="";B20-HEUTE()
zwingend (zumindest heute) -24 ergeben muss.

Gruß Ralf
to top
#3
Hallo,

suchst du das?

=WENN(ODER(B2="";C2="");"";NETTOARBEITSTAGE(B2;C2))

oder evtl. das?

=WENN(ODER(B2="";C2="");"";NETTOARBEITSTAGE(B2;C2))
Gruß
Peter
to top
#4
Danke für die Hilfe.

Es wäre aber toll, wenn z.B. in D20 die Minustage erscihtlich sind, damit ich weiss, wie lange die Bearbeitung bereits läuft?

Gruss
cuba
to top
#5
Hallo,

und was spricht dann dagegen, dass du diesen Teil deiner Formel

B2-HEUTE()

durch

NETTOARBEITSTAGE(B2;HEUTE())

ersetzt?

Oder bin ich jetzt vollkommen auf dem falschen Dampfer und verstehe dein Vorhaben vollkommen falsch?
Gruß
Peter
[-] Folgende(r) 1 Benutzer sagt Danke an Peter für diesen Beitrag:
cuba
to top
#6
Hallo Peter

=WENN(B2="";"";WENN(C2="";NETTOARBEITSTAGE(B2;HEUTE());NETTOARBEITSTAGE(B2;C2)))

das war genau die richtige Lösung von Dir, vielen Dank. Genau in diesem Bereich war mein Gedankenfehler eingebaut!

LG
cuba
to top
#7
Hallo,

dann vielleicht auch so:

Code:
=WENN(B2="";"";NETTOARBEITSTAGE(B2;wenn(c2="";HEUTE();C2)))
Gruß


Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#8
Danke Edgar

auch dies hat funktioniert.

Gruss
cuba
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  in UserForm rechnen und drucken radkappe22 4 97 20.03.2017, 10:54
Letzter Beitrag: radkappe22
  Rechnen mit hh:mm:ss,000 punktum 14 275 28.02.2017, 12:10
Letzter Beitrag: Rabe
  Tabelle mit mehreren Variablen rechnen fuzzy 12 225 28.02.2017, 09:05
Letzter Beitrag: fuzzy
  Kombination aus Rechnen mit Zeitangaben + bedingter Formatierung 1Selection 4 188 19.02.2017, 22:45
Letzter Beitrag: 1Selection
  Prozent rechnen tommy10_13 5 161 09.02.2017, 17:04
Letzter Beitrag: Palomino
  Rechnen in VBA Mario 2 154 08.02.2017, 19:56
Letzter Beitrag: Mario
  Mit Hintergrundfarbe rechnen merlin-rainbow 2 135 20.01.2017, 12:12
Letzter Beitrag: schauan
  zusammen rechnen Harald 13 379 03.01.2017, 09:55
Letzter Beitrag: lupo1
  Mit Zeit rechnen fhares 4 195 07.11.2016, 16:37
Letzter Beitrag: Jockel
  Farben rechnen Leo-world 2 239 07.10.2016, 16:31
Letzter Beitrag: Leo-world

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste