Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Rechnen mit Datum
#1
Hallo Forum

Ich habe in der Beilage eine Datei, welche in der Zelle D20 einen falschen Wert ausgibt.

Dort sollte eigentlich die Differenz der Arbeitstage ausgeweisen werden, auch wenn die Spalte C leer ist; will heissen, ich möchte dort den Wert der Arbeitstage..... Wenn die Spalte C dann mit einem Datum versehen wird, ist die Formel wieder OK!

Freue mich auf eine saubere Lösung.


Angehängte Dateien
.xlsb   Rechnen mit Datum.xlsb (Größe: 16,04 KB / Downloads: 8)
to top
#2
Hallo!
Es gibt im Register Formeln die Formelauswertung!
Lasse sie mal durchlaufen und Du siehst, dass
Code:
WENN(C20="";B20-HEUTE()
zwingend (zumindest heute) -24 ergeben muss.

Gruß Ralf
to top
#3
Hallo,

suchst du das?

=WENN(ODER(B2="";C2="");"";NETTOARBEITSTAGE(B2;C2))

oder evtl. das?

=WENN(ODER(B2="";C2="");"";NETTOARBEITSTAGE(B2;C2))
Gruß
Peter
to top
#4
Danke für die Hilfe.

Es wäre aber toll, wenn z.B. in D20 die Minustage erscihtlich sind, damit ich weiss, wie lange die Bearbeitung bereits läuft?

Gruss
cuba
to top
#5
Hallo,

und was spricht dann dagegen, dass du diesen Teil deiner Formel

B2-HEUTE()

durch

NETTOARBEITSTAGE(B2;HEUTE())

ersetzt?

Oder bin ich jetzt vollkommen auf dem falschen Dampfer und verstehe dein Vorhaben vollkommen falsch?
Gruß
Peter
[-] Folgende(r) 1 Benutzer sagt Danke an Peter für diesen Beitrag:
cuba
to top
#6
Hallo Peter

=WENN(B2="";"";WENN(C2="";NETTOARBEITSTAGE(B2;HEUTE());NETTOARBEITSTAGE(B2;C2)))

das war genau die richtige Lösung von Dir, vielen Dank. Genau in diesem Bereich war mein Gedankenfehler eingebaut!

LG
cuba
to top
#7
Hallo,

dann vielleicht auch so:

Code:
=WENN(B2="";"";NETTOARBEITSTAGE(B2;wenn(c2="";HEUTE();C2)))
Gruß


Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#8
Danke Edgar

auch dies hat funktioniert.

Gruss
cuba
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Mit Zeit rechnen fhares 4 74 07.11.2016, 16:37
Letzter Beitrag: Jockel
  Farben rechnen Leo-world 2 114 07.10.2016, 16:31
Letzter Beitrag: Leo-world
  Mit Zeiten rechnen Stefan1 4 170 02.10.2016, 12:31
Letzter Beitrag: Stefan1
  Rechnen mit Uhrzeiten xJustx 3 207 05.09.2016, 14:19
Letzter Beitrag: hisid1
  Werte horizontal rechnen. Michael77 5 170 04.09.2016, 10:35
Letzter Beitrag: RPP63
  Rechnen mit Höchst- und Mindestwerten Hardbopper 11 450 24.08.2016, 01:30
Letzter Beitrag: Ego
  Rechnen mit der Userform Ben 17 721 05.08.2016, 18:20
Letzter Beitrag: snb
  mit großen Zahlen rechnen coemm 5 305 03.07.2016, 10:10
Letzter Beitrag: Ego
  Kartenspiele - Rechnen mit Outs - Mehrstufige Zufallsexperimente Lost In Calculation 0 189 22.06.2016, 19:45
Letzter Beitrag: Lost In Calculation
  VBA nur mit Variablen rechnen hbboy15 17 985 03.06.2016, 15:46
Letzter Beitrag: snb

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste