Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

Vergleich von Spalten und Übernahme eines Referenzbegriffs
#1
Hallo Forum,

ich habe eine Zweispaltige Vorlage, in deren erster Spalte ein Begriff und in der zweiten Spalte eine zugehörige Übersetzung steht.

Bsp.:

nose Nase
house Haus
wired seltsam

Nun will ich eine neue Liste mit z.B. englischen Wörtern, die ebenfalls Spaltenweise aufgelistet sind mit obiger ersten Liste vergleichen und im Falle von schon bekannter Übersetzung aus der ersten Liste diese in die nächste Spalte ausgeben.

Bsp:

tent
house Haus
glass
nose Nase

könnt ihr mir helfen, hier eine Vergleichsformel aufzusetzen?

vielen Dank!
to top
#2
Hallo

Eine Aufgabe für SVERWEIS().
SVERWEIS() hat vier Parameter.
Falls die erste Spalte nicht aufsteigend sortiert ist, muß der vierte Parameter zwingend FALSCH sein.
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
to top
#3
Hi,

das sollte es treffen:

Arbeitsblatt mit dem Namen 'Liste1'
 AB
1EnglischDeutsch
2houseHaus
3noseNase
4wiredseltsam

Arbeitsblatt mit dem Namen 'Liste2'
 AB
1EnglischDeutsch
2tent 
3houseHaus
4glass 
5noseNase

ZelleFormel
B2=WENNFEHLER(SVERWEIS($A2;Liste1!$A$1:$B$4;2;FALSCH);"")
B3=WENNFEHLER(SVERWEIS($A3;Liste1!$A$1:$B$4;2;FALSCH);"")
B4=WENNFEHLER(SVERWEIS($A4;Liste1!$A$1:$B$4;2;FALSCH);"")
B5=WENNFEHLER(SVERWEIS($A5;Liste1!$A$1:$B$4;2;FALSCH);"")

Gruß
Max

Edit sagt:
Wenn Du Deinen Referenzbereich als Tabelle formatierst, brauchst Du nicht jedes Mal
Deine Matrix im Sverweis-Teil anzupassen wenn Du eine Vokabel ergänzt, da sich dieser automatisch mit anpasst.

Hier mal beide Listen in einer Tabelle.

Arbeitsblatt mit dem Namen 'Liste1'
 ABCDE
1EnglischDeutsch EnglischDeutsch
2houseHaus tent 
3noseNase houseHaus
4wiredseltsam glass 
5disappointedenttäuscht noseNase
6exhaustederschöpft exhaustederschöpft

ZelleFormel
E2=WENNFEHLER(SVERWEIS($D2;Referenz;2;FALSCH);"")
E3=WENNFEHLER(SVERWEIS($D3;Referenz;2;FALSCH);"")
E4=WENNFEHLER(SVERWEIS($D4;Referenz;2;FALSCH);"")
E5=WENNFEHLER(SVERWEIS($D5;Referenz;2;FALSCH);"")
E6=WENNFEHLER(SVERWEIS($D6;Referenz;2;FALSCH);"")
to top
#4
Hallo Max,

danke für die Hilfe, aktuell klappt das bei mir nicht, ich benutze Excel 2000, evtl. liegt's daran.
ich bekomme eine #name? Fehlermeldung.

Grüße,
Stefan
to top
#5
Hallo Stefan,

hast Du die Formel kopiert oder abgetippt?

#NAME lässt
a) auf einen Tippfehler oder
b) auf einen falsch definierten Bereich schließen

Kannst Du eine Beispieldatei mit ein paar Referenzen einstellen?

Gruß
Max

Edit sagt:
Hier steht wie es geht.
to top
#6
Hi,

das mit der formatierten Tabelle funktioniert unter Excel 2000 nicht.
Sorry zu spät gesehen.

Schau mal hier:

.xls   Bsp_Reisenase - Kopie.xls (Größe: 33 KB / Downloads: 2)

Gruß
Max
to top
#7
Hallo Max,

WENNFEHLER() gibt es ab 2007, daher der Fehler #Name?
Gruß Atilla


...und ich gelobe Besserung...

[-] Folgende(r) 1 Benutzer sagt Danke an atilla für diesen Beitrag:
Max
to top
#8
(12.02.2015, 23:04)atilla schrieb: Hallo Max,

WENNFEHLER() gibt es ab 2007, daher der Fehler #Name?

Stimmt. Das hatte ich nicht auf dem Schirm.

Danke.

Gruß
Max
to top
#9
Hi Stefan.

bei Dir sollte das dann so funktionieren:

Formel für B2 in Tabelle2:
Code:
=WENN(ISTFEHLER(SVERWEIS($A2;Liste2!$A$2:$B$6;2;FALSCH));"";SVERWEIS($A2;Liste2!$A$2:$B$6;2;FALSCH))

sonst, wenn beide Bereiche in einer Tabelle liegen wie im Edit von Post#3

Code:
=WENN(ISTFEHLER(SVERWEIS($D2;$A$2:$B$6;2;FALSCH));"";SVERWEIS($D2;$A$2:$B$6;2;FALSCH))

Die Formelprofis hier haben vielleicht noch andere Lösungen.

Sorry und Gruß
Max
to top
#10
Hallöchen,

ich nehme bei der "Vorbereitung" meist Zählenwenn und nicht Istfehler.

Code:
=WENN(ZÄHLENWENN($A2;Liste2!$A$2:$B$6);SVERWEIS($A2;Liste2!$A$2:$B$6;2;FALSCH);"")
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
Question [GELÖST] Wert ausgeben, abhängig von Vergleich mit 2 Spalten dexlunar 3 47 21.03.2017, 11:22
Letzter Beitrag: dexlunar
  Übernahme von Wert bei Übereinstimmung sunny01 11 162 16.03.2017, 20:47
Letzter Beitrag: sunny01
  Übernahme von Wert aus Spalte sunny01 5 71 14.03.2017, 16:27
Letzter Beitrag: Glausius
  Ausgaben Übernahme oOManuelOo 8 177 16.02.2017, 22:08
Letzter Beitrag: oOManuelOo
  Übernahme von Zellen, Leerzeilen löschen Brettenbach 2 144 09.12.2016, 14:43
Letzter Beitrag: Brettenbach
  Bestellung/Spalten: nur bestimmte Spalten kopieren teufelchenbs 14 794 25.11.2016, 20:55
Letzter Beitrag: schauan
  Übernahme Inhalt aus Tabelle1 in Tabelle2 Marlak 1 412 26.07.2016, 16:21
Letzter Beitrag: Luffy
  Übernahme des Inhalts von IFC-Dateien in Excel Tabelle sunny01 54 4.244 09.05.2016, 17:43
Letzter Beitrag: schauan
  Übernahme von Internetinhalten in Excel Spalten financeangel 3 588 28.03.2016, 10:31
Letzter Beitrag: GMG-CC
  Übernahme von Zeilen in neues Register sunny01 7 937 12.03.2016, 12:19
Letzter Beitrag: GMG-CC

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste